fwupdate-12-lp151.3.21.x86_64.rpm


Advertisement

Description

fwupdate - Tools to manage UEFI firmware updates

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename fwupdate-12-lp151.3.21.x86_64.rpm
Package name fwupdate
Package version 12
Package release lp151.3.21
Package architecture x86_64
Package type rpm
Category System/Base
Homepage https://github.com/rhinstaller/fwupdate
License GPL-2.0-or-later
Maintainer -
Download size 31.55 KB
Installed size 37.75 KB
fwupdate provides a simple command line interface to the UEFI firmware updates.

Alternatives

Package Version Architecture Repository
fwupdate - - -

Requires

Name Value
/bin/bash -
efibootmgr -
fwupdate-efi -
libc.so.6(GLIBC_2.4)(64bit) -
libefivar.so.1()(64bit) -
libefivar.so.1(LIBEFIVAR_0.24)(64bit) -
libefivar.so.1(LIBEFIVAR_1.30)(64bit) -
libefivar.so.1(libefivar.so.0)(64bit) -
libfwup.so.1()(64bit) -
libfwup.so.1(LIBFWUP_1.11)(64bit) -
libfwup.so.1(libfwup.so.1)(64bit) -
libfwup1 = 12-lp151.3.21
libpopt.so.0()(64bit) -
libpopt.so.0(LIBPOPT_0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
shim >= 11
systemd -

Provides

Name Value
fwupdate = 12-lp151.3.21
fwupdate(x86-64) = 12-lp151.3.21

Download

Type URL
Mirror widehat.opensuse.org
Binary Package fwupdate-12-lp151.3.21.x86_64.rpm
Source Package fwupdate-12-lp151.3.21.src.rpm

Install Howto

Install fwupdate rpm package:

# zypper install fwupdate

Files

Path
/run/fwupdate/
/usr/bin/fwupdate
/usr/lib/fwupdate/cleanup
/usr/lib/systemd/system/fwupdate-cleanup.service
/usr/sbin/rcfwupdate-cleanup
/usr/share/bash-completion/
/usr/share/bash-completion/completions/fwupdate
/usr/share/licenses/fwupdate/COPYING
/usr/share/man/man1/fwupdate.1.gz

Changelog

2019-01-28 - Gary Ching-Pang Lin <glin@suse.com>
- Fix the destination of 'efi'-executables for i586 (FATE#326960)
2019-01-17 - rw@suse.com
- Move 'efi'-executables to '/usr/share/efi'  (FATE#326960)
2018-10-23 - Gary Ching-Pang Lin <glin@suse.com>
- Amend the spec file to avoid fwup*.efi from being removed
mistakenly (bsc#1112832)
2018-07-19 - bjorn.lie@gmail.com
- Update to version 12 (FATE#326702)
+ Better CI.
+ Limit how large our WMI buffer can be.
+ Add fwup_version() because fwupd wants it.
+ Fix linking on (some) platforms that need libgcc_eh.a.
+ abicheck improvements.
+ Default to creating a UX capsule, whatever it may actually do.
- Refresh fwupdate-suse-build.patch with quilt.
- Use url for source tarball and license tag for COPYING.
2018-06-28 - glin@suse.com
- Correct the requirement of efivar-devel version
2018-06-20 - oliver@getspam.de
- Update to version 11
+ lots of fixes from cov-scan and clang analyzer
+ support for Lenovo machines
+ experimental support for UI Capsules
+ Dell WMI support
+ lots of bugfixes
+ configurable EFI ESP location by setting ESPMOUNTPOINT or the git
config property fwupdate.espmountdir during the build.
+ Lots of coverity work
+ ABI compatibility checking during the release process
+ Make subdirectory builds work
- removed fwupdate-list-firmware-types.patch
2018-04-09 - glin@suse.com
- Require shim only for x86_64 (bsc#1088434)
2018-02-09 - glin@suse.com
- Remove fwupdate-bsc988886-add-leading-space.patch and bump the
shim version requirement since we got the new signature for shim
(bsc#1054712)
2017-12-18 - mls@suse.de
- bring back accidental removed needssslcertforbuild
2017-12-15 - stefan.bruens@rwth-aachen.de
- EFI updates through fwupdate are also possible on Aarch64.
smbios support is only relevant for some Dell machines, i.e.
x86 only.

See Also

Package Description
fwupdate-devel-12-lp151.3.21.x86_64.rpm Development headers for libfwup
fwupdate-efi-12-lp151.3.21.x86_64.rpm UEFI binaries used by libfwup
fwzs-0.5-lp151.2.1.noarch.rpm Tray applet that allows to switch firewall zones of interfaces
fxload-2008_10_13-lp151.2.3.x86_64.rpm Download Firmware into USB FX and FX2 Devices
fzy-0.9-lp151.2.3.x86_64.rpm A fuzzy text selector
g3utils-1.1.37-lp151.3.29.x86_64.rpm Tools for the G3 (Fax) Graphics Format
gaa-1.6.6-lp151.2.3.x86_64.rpm GAA Argument Analyzer and Code Generator
gajim-1.0.3-lp151.2.2.noarch.rpm XMPP client written in Python and Gtk3
gajim-lang-1.0.3-lp151.2.2.noarch.rpm Translations for package gajim
galaxis-1.9-lp151.2.2.x86_64.rpm Clone of the nifty little Macintosh game
galculator-2.1.4-lp151.2.3.x86_64.rpm A GTK 3 based calculator
galculator-lang-2.1.4-lp151.2.3.noarch.rpm Translations for package galculator
gama-1.22-lp151.2.5.x86_64.rpm Adjustment of geodetic networks
gambas3-3.10.0-lp151.3.66.x86_64.rpm BASIC interpreter under Linux
gambas3-devel-3.10.0-lp151.3.66.x86_64.rpm The Gambas devel package
Advertisement
Advertisement