fwupd-devel-1.0.9-lp151.1.6.x86_64.rpm


Advertisement

Description

fwupd-devel - Allow session software to update device firmware

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename fwupd-devel-1.0.9-lp151.1.6.x86_64.rpm
Package name fwupd-devel
Package version 1.0.9
Package release lp151.1.6
Package architecture x86_64
Package type rpm
Category Development/Languages/C and C++
Homepage https://fwupd.org/
License GPL-2.0-or-later AND LGPL-2.1-or-later
Maintainer -
Download size 122.00 KB
Installed size 1.01 MB
fwupd is a daemon to allows session software to update device firmware on
the local machine.

Alternatives

Package Version Architecture Repository
fwupd-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libfwupd2 = 1.0.9
pkgconfig(gio-2.0) -

Provides

Name Value
fwupd-devel = 1.0.9-lp151.1.6
fwupd-devel(x86-64) = 1.0.9-lp151.1.6
pkgconfig(fwupd) = 1.0.9

Download

Type URL
Mirror widehat.opensuse.org
Binary Package fwupd-devel-1.0.9-lp151.1.6.x86_64.rpm
Source Package fwupd-1.0.9-lp151.1.6.src.rpm

Install Howto

Install fwupd-devel rpm package:

# zypper install fwupd-devel

Files

Path
/usr/include/fwupd-1/fwupd.h
/usr/include/fwupd-1/libfwupd/fwupd-client.h
/usr/include/fwupd-1/libfwupd/fwupd-common.h
/usr/include/fwupd-1/libfwupd/fwupd-deprecated.h
/usr/include/fwupd-1/libfwupd/fwupd-device.h
/usr/include/fwupd-1/libfwupd/fwupd-enums.h
/usr/include/fwupd-1/libfwupd/fwupd-error.h
/usr/include/fwupd-1/libfwupd/fwupd-release.h
/usr/include/fwupd-1/libfwupd/fwupd-remote.h
/usr/include/fwupd-1/libfwupd/fwupd-version.h
/usr/lib64/libfwupd.so
/usr/lib64/pkgconfig/fwupd.pc
/usr/share/gir-1.0/Fwupd-2.0.gir
/usr/share/gtk-doc/html/libfwupd/annotation-glossary.html
/usr/share/gtk-doc/html/libfwupd/api-index-full.html
/usr/share/gtk-doc/html/libfwupd/home.png
/usr/share/gtk-doc/html/libfwupd/index.html
/usr/share/gtk-doc/html/libfwupd/intro.html
/usr/share/gtk-doc/html/libfwupd/left-insensitive.png
/usr/share/gtk-doc/html/libfwupd/left.png
/usr/share/gtk-doc/html/libfwupd/libfwupd-FuDevice.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-FuDeviceLocker.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-FuPlugin.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-FuUsbDevice.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-FwupdClient.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-FwupdDevice.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-FwupdRelease.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-FwupdRemote.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-fu-common.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-fu-device-metadata.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-fu-quirks.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-fwupd-enums.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-fwupd-error.html
/usr/share/gtk-doc/html/libfwupd/libfwupd-fwupd-version.html
/usr/share/gtk-doc/html/libfwupd/libfwupd.devhelp2
/usr/share/gtk-doc/html/libfwupd/libfwupd.html
/usr/share/gtk-doc/html/libfwupd/plugin-reference.html
/usr/share/gtk-doc/html/libfwupd/right-insensitive.png
/usr/share/gtk-doc/html/libfwupd/right.png
/usr/share/gtk-doc/html/libfwupd/style.css
/usr/share/gtk-doc/html/libfwupd/tutorial.html
/usr/share/gtk-doc/html/libfwupd/up-insensitive.png
/usr/share/gtk-doc/html/libfwupd/up.png
/usr/share/vala/vapi/fwupd.deps
/usr/share/vala/vapi/fwupd.vapi

Changelog

2018-09-21 - fezhang@suse.com
- Update to version 1.0.9 (FATE#326702):
+ New Features:
- Add support for more Wacom tablets.
- Add support for the Synaptics Panamera chip.
- Add validation for Titan Ridge Thunderbolt devices.
- Use boltd force power API if available.
+ Bugfixes:
- Allow flashing Unifying devices in recovery mode.
- Allow updating just one specific device from the commandline.
- Do not hold hidraw devices open forever.
- Do not use 8bitdo bootloader commands after a successful
flash.
- Don't crash when the Dell alternate device has not been set.
- Don't potentially expose user passwords for remotes.
- Fix a potential buffer overflow when applying a DFU patch.
- Fix a potential segfault in smbios data processing.
- Fix downgrading older releases to devices.
- Fix failure to detach Unifying devices when using a slow host
controller.
- Fix flashing devices that require a manual replug.
- Handle -EAGAIN from the kernel better when reading NVM.
- Drop enable_pkcs7_when_testing_only.patch: fixed upstream.
2018-09-10 - Jan Engelhardt <jengelh@inai.de>
- Use noun phrase for summary. Trim request for comments from
description.
2018-07-25 - tchvatal@suse.com
- Run %udev_rules_update in post as package install udev rules
2018-07-11 - oliver@getspam.de
- Update to version 1.0.8:
+ New Features (including version 1.0.7):
- Add an plugin to update some future Wacom tablets
- Add 'fwupdmgr get-topology' to show logical device tree
- Add support for creating a flatpak
- Add support for creating a snap
- Add support for Motorola S-record files
- Add the Linux Foundation public GPG keys for firmware and metadata
- Show a translated warning when the server is limiting downloads
- Add enable-remote and disable-remote commands to fwupdmgr
- Add fu_plugin_add_compile_version() for libraries to use
- Allow requiring specific versions of libraries for firmware updates
- If no remotes are enabled try to enable the LVFS
- Show a warning with interactive prompt when enabling a remote
+ Bugfixes (including version 1.0.7):
- Add a firmware diagnostic tool called fwupdtool
- Adjust all licensing to LGPL 2.1+
- Allow installing more than one firmware using 'fwupdmgr install'
- Allow specifying hwids with OR relationships
- Do not call fu_plugin_init() on blacklisted plugins
- Do not require libcolorhug to build
- Fix a crash in libfwupd where no device ID is set
- Fix a potential DoS in libdfu by limiting holes to 1MiB
- Fix a segfault that sometimes occurs during cleanup of USB plugins
- Fix Hardware-ID{0,1,2,12} compatibility with Microsoft
- Hide devices that aren't updatable by default in fwupdmgr
- Search all UEFI GUIDs when matching hardware
- Stop matching Nintendo Switch Pro in the 8bitdo plugin
- Check that EFI system partition is mounted before update
- Disable synapticsmst remote control on failure
- Don't recoldplug thunderbolt to fix a flashing failure
- Fix SQL error when running 'fwupdmgr clear-offline'
- Improve the update report message
- Only enumerate Dell Docks if the type is known
- Only run certtool if a new enough gnutls is present
- Prevent a client crash if the daemon somehow sends invalid data
- Reboot after scheduling using logind not systemd
- Use the right encoding for the label in make-images
- Added/backported enable_pkcs7_when_testing_only.patch:
+ needed to disable pkcs7 test during build (can be removed for
fwupd >= 1.0.9)
2018-04-04 - dimstar@opensuse.org
- Update hasbang in installed files from /usr/bin/env python3 to
/usr/bin/python3.
2018-04-03 - mpluskal@suse.com
- Update url
- Small packaging cleanup with spec-cleaner

See Also

Package Description
fwupd-lang-1.0.9-lp151.1.6.noarch.rpm Translations for package fwupd
fwupdate-12-lp151.3.21.x86_64.rpm Tools to manage UEFI firmware updates
fwupdate-devel-12-lp151.3.21.x86_64.rpm Development headers for libfwup
fwupdate-efi-12-lp151.3.21.x86_64.rpm UEFI binaries used by libfwup
fwzs-0.5-lp151.2.1.noarch.rpm Tray applet that allows to switch firewall zones of interfaces
fxload-2008_10_13-lp151.2.3.x86_64.rpm Download Firmware into USB FX and FX2 Devices
fzy-0.9-lp151.2.3.x86_64.rpm A fuzzy text selector
g3utils-1.1.37-lp151.3.29.x86_64.rpm Tools for the G3 (Fax) Graphics Format
gaa-1.6.6-lp151.2.3.x86_64.rpm GAA Argument Analyzer and Code Generator
gajim-1.0.3-lp151.2.2.noarch.rpm XMPP client written in Python and Gtk3
gajim-lang-1.0.3-lp151.2.2.noarch.rpm Translations for package gajim
galaxis-1.9-lp151.2.2.x86_64.rpm Clone of the nifty little Macintosh game
galculator-2.1.4-lp151.2.3.x86_64.rpm A GTK 3 based calculator
galculator-lang-2.1.4-lp151.2.3.noarch.rpm Translations for package galculator
gama-1.22-lp151.2.5.x86_64.rpm Adjustment of geodetic networks
Advertisement
Advertisement