frameworkintegration-plugin-5.55.0-lp151.1.3.x86_64.rpm


Advertisement

Description

frameworkintegration-plugin - Plugins responsible for better integration of Qt applications in KDE Workspace

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename frameworkintegration-plugin-5.55.0-lp151.1.3.x86_64.rpm
Package name frameworkintegration-plugin
Package version 5.55.0
Package release lp151.1.3
Package architecture x86_64
Package type rpm
Category System/GUI/KDE
Homepage https://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 1.57 MB
Installed size 1.69 MB
Framework Integration is a set of plugins responsible for better
integration of Qt applications when running on a
KDE Plasma workspace.
Applications do not need to link to this directly.

Alternatives

Package Version Architecture Repository
frameworkintegration-plugin-5.58.2-lp151.194.1.x86_64.rpm 5.58.2 x86_64 KDE Frameworks 5
frameworkintegration-plugin - - -

Requires

Name Value
libAppStreamQt.so.2()(64bit) -
libKF5ConfigCore.so.5()(64bit) -
libKF5I18n.so.5()(64bit) -
libKF5NewStuffCore.so.5()(64bit) -
libKF5Notifications.so.5()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.9)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libpackagekitqt5.so.1()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
plasma5-integration-plugin -

Provides

Name Value
frameworkintegration-plugin = 5.55.0-lp151.1.3
frameworkintegration-plugin(x86-64) = 5.55.0-lp151.1.3

Conflicts

Name Value
libKF5Style5 < 5.6.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package frameworkintegration-plugin-5.55.0-lp151.1.3.x86_64.rpm
Source Package frameworkintegration-5.55.0-lp151.1.3.src.rpm

Install Howto

Install frameworkintegration-plugin rpm package:

# zypper install frameworkintegration-plugin

Files

Path
/usr/lib64/libexec/kf5/
/usr/lib64/libexec/kf5/kpackagehandlers/appstreamhandler
/usr/lib64/libexec/kf5/kpackagehandlers/knshandler
/usr/lib64/qt5/plugins/
/usr/lib64/qt5/plugins/kf5/FrameworkIntegrationPlugin.so
/usr/share/doc/packages/frameworkintegration-plugin/README.md
/usr/share/kf5/infopage/bar-bottom-left.png
/usr/share/kf5/infopage/bar-bottom-middle.png
/usr/share/kf5/infopage/bar-bottom-right.png
/usr/share/kf5/infopage/bar-middle-left.png
/usr/share/kf5/infopage/bar-middle-right.png
/usr/share/kf5/infopage/bar-top-left.png
/usr/share/kf5/infopage/bar-top-middle.png
/usr/share/kf5/infopage/bar-top-right.png
/usr/share/kf5/infopage/body-background.png
/usr/share/kf5/infopage/box-bottom-left.png
/usr/share/kf5/infopage/box-bottom-middle.png
/usr/share/kf5/infopage/box-bottom-right.png
/usr/share/kf5/infopage/box-center.png
/usr/share/kf5/infopage/box-middle-left.png
/usr/share/kf5/infopage/box-middle-right.png
/usr/share/kf5/infopage/box-top-left.png
/usr/share/kf5/infopage/box-top-middle.png
/usr/share/kf5/infopage/box-top-right.png
/usr/share/kf5/infopage/kde_infopage.css
/usr/share/kf5/infopage/kde_infopage_rtl.css
/usr/share/kf5/infopage/top-middle.png
/usr/share/knotifications5/plasma_workspace.notifyrc
/usr/share/licenses/frameworkintegration-plugin/COPYING.LGPL-2
/usr/share/licenses/frameworkintegration-plugin/COPYING.LIB

Changelog

2019-02-15 - alarrosa@suse.com
- Downgrade the Qt version requirement to build with 5.9
2019-02-10 - lbeltrame@kde.org
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0
2019-01-14 - lbeltrame@kde.org
- Update to 5.54.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.54.0.php
- Changes since 5.53.0:
* No code changes since 5.53.0
2018-12-09 - lbeltrame@kde.org
- Update to 5.53.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.53.0.php
- Changes since 5.52.0:
* Add option BUILD_KPACKAGE_INSTALL_HANDLERS to skip building install handlers
2018-11-11 - lbeltrame@kde.org
- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0
2018-10-16 - Luca Beltrame <lbeltrame@kde.org>
- Run spec-cleaner
2018-10-15 - lbeltrame@kde.org
- Update to 5.51.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.51.0.php
- Changes since 5.50.0:
* make sure that it builds with strict compile flags
2018-09-13 - lbeltrame@kde.org
- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* [KStyle] Use dialog-question for question icon
2018-08-19 - christophe@krop.fr
- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING
2018-07-16 - lbeltrame@kde.org
- Update to 5.48.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.48.0.php
- Changes since 5.47.0:
* None

See Also

Package Description
free-ttf-fonts-1.0-lp151.2.1.noarch.rpm Free TrueType Art Fonts
freealut-devel-1.1.0-lp151.3.3.x86_64.rpm Static libraries, header files and tests for openal library
freecell-solver-5.0.0-lp151.1.1.x86_64.rpm A Freecell Solver
freecell-solver-devel-5.0.0-lp151.1.1.x86_64.rpm Freecell Solver development package
freecell-solver-presets-5.0.0-lp151.1.1.noarch.rpm Freecell Solver presets
freeciv-2.5.10-lp151.2.5.x86_64.rpm Free Civilization Clone
freeciv-gtk3-2.5.10-lp151.2.5.x86_64.rpm Gtk3 client for freeciv
freeciv-qt-2.5.10-lp151.2.5.x86_64.rpm Qt client for freeciv
freedoom-0.11.3-lp151.2.1.noarch.rpm Replacement game files for Doom game engines
freedoom-freedm-0.11.3-lp151.2.1.noarch.rpm Deathmatch levels for Doom
freedup-1.6~3-lp151.2.3.x86_64.rpm Links substantially identical, duplicate files to save file system space
freeglut-demo-3.0.0-lp151.2.3.x86_64.rpm Demonstration applications for the freeglut library
freeglut-devel-3.0.0-lp151.2.3.x86_64.rpm Development libraries, includes and man pages for freeglut (GLUT Library)
freeglut-devel-32bit-3.0.0-lp151.2.3.x86_64.rpm Development libraries, includes and man pages for freeglut (GLUT Library)
freeimage-devel-3.17.0-lp151.3.3.x86_64.rpm Development Files for FreeImage
Advertisement
Advertisement