florence-devel-0.6.3-lp151.2.3.x86_64.rpm


Advertisement

Description

florence-devel - Development files for florence

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename florence-devel-0.6.3-lp151.2.3.x86_64.rpm
Package name florence-devel
Package version 0.6.3
Package release lp151.2.3
Package architecture x86_64
Package type rpm
Category Development/Libraries/X11
Homepage http://florence.sourceforge.net
License GPL-2.0+ and GFDL-1.2
Maintainer -
Download size 10.90 KB
Installed size 2.19 KB
This package contains libraries and header files for
developing applications that use florence.

Alternatives

Package Version Architecture Repository
florence-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
florence = 0.6.3-lp151.2.3
pkgconfig(gio-2.0) -

Provides

Name Value
florence-devel = 0.6.3-lp151.2.3
florence-devel(x86-64) = 0.6.3-lp151.2.3
pkgconfig(florence-1.0) = 0.6.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package florence-devel-0.6.3-lp151.2.3.x86_64.rpm
Source Package florence-0.6.3-lp151.2.3.src.rpm

Install Howto

Install florence-devel rpm package:

# zypper install florence-devel

Files

Path
/usr/include/florence-1.0/florence.h
/usr/lib64/libflorence-1.0.so
/usr/lib64/pkgconfig/florence-1.0.pc

Changelog

2016-04-02 - zaitor@opensuse.org
- Update to version 0.6.3:
+ Many bug fixes
- Changes from version 0.6.2:
+ Fix gradients.
+ Remove deprecated GTK3 functions.
- Changes from version 0.6.1:
+ A lot of bug fixes.
+ Add commands to the dbus interface.
+ Add command line options to control the keyboard.
+ Move at-spi2 handling to a new process in order to avoid
deadlocks.
+ Implement a floating icon for desktops with no systray.
- Remove la files, not needed in openSUSE.
- Disable parallel build, currently broken.
- Replace *-devel BuildRequires for their pkgconfig counterparts:
+ at-spi2-core-devel for pkgconfig(atspi-2).
+ libXtst-devel for pkgconfig(xtst).
+ librsvg2-devel for pkgconfig(librsvg-2.0).
- Drop pkgconfig(gstreamer-0.10) and add pkgconfig(gstreamer-1.0)
BuildRequires, upstream ported to current gstreamer.
- Add pkgconfig(cairo), pkgconfig(gio-2.0), pkgconfig(gmodule-2.0),
pkgconfig(x11) and pkgconfig(xext) BuildRequires: configure looks
for them.
- Add new devel and lib subpackages.
- Handle new so files in post/postun.
- Pass --disable-static to configure since we do not need them.
- Rebase and simplify florence-icondir.patch.
- Add libtool BuildRequires and call autoreconf: needed, as
florence-icondir.patch touches the build system.
- Add florence-implicit-definitions.patch: Do not use wait(), which
is implicit defined and has no function.
2013-12-15 - dap.darkness@gmail.com
- Added florence-icondir.patch: set correct svg icon directory in
order to not broke the app (bnc#855529).
- Add florence-rpmlintrc: filter warnings for duplicate files in
/usr/share/help/florence. Using fdupes could potentially cause
link targets to end up in the -lang package, not being installed
by default. As C lang help though is installed from the main
package, there is a chance of breakage.
2013-09-21 - zaitor@opensuse.org
- Add rarian-scrollkeeper-compat BuildRequires, due to
gnome-doc-utils no longer pulling in scrollkeeper. Configure
explicitly checks for scrollkeeper.
- Own %{_datadir}/omf because of the above change.
2013-07-06 - dap.darkness@gmail.com
- Initial build.

See Also

Package Description
florence-lang-0.6.3-lp151.2.3.noarch.rpm Translations for package florence
flowgrind-0.8.0-lp151.2.3.x86_64.rpm Network performance measurement
fltk-devel-1.3.4-lp151.3.5.x86_64.rpm Development files for the FLTK GUI toolkit
fltk-devel-32bit-1.3.4-lp151.3.5.x86_64.rpm Development files for the FLTK GUI toolkit
fltk-devel-static-1.3.4-lp151.3.5.x86_64.rpm Static libraries for the FLTK GUI toolkit
fluid-soundfont-gm-3.1-lp151.2.1.noarch.rpm Fluid (R3) General MIDI SoundFont (GM)
fluid-soundfont-gs-3.1-lp151.2.1.noarch.rpm Fluid (R3) General MIDI SoundFont (GS)
fluidsynth-1.1.11-lp151.2.3.x86_64.rpm A Real-Time Software Synthesizer That Uses Soundfont(tm)
fluidsynth-devel-1.1.11-lp151.2.3.x86_64.rpm Development package for the fluidsynth library
fluidsynth-dssi-1.0.0-lp151.2.3.x86_64.rpm Fluidsynth Plug-In for Disposable Soft Synth Interface
flute-1.3.0-lp151.3.43.noarch.rpm Java CSS parser using SAC
flute-javadoc-1.3.0-lp151.3.43.noarch.rpm Javadoc for flute
fluxbox-1.3.7-lp151.2.4.x86_64.rpm A window manager for X based on Blackbox 0.61.1
fluxbox-styles-upstream-1.3.7-lp151.2.4.noarch.rpm Upstream bundle of styles for fluxbox
flxmlrpc-devel-0.1.4-lp151.2.3.x86_64.rpm Flxmlrpc development libraries
Advertisement
Advertisement