finch-devel-2.13.0-lp151.4.4.x86_64.rpm


Advertisement

Description

finch-devel - Headers etc. for finch Stuffs

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename finch-devel-2.13.0-lp151.4.4.x86_64.rpm
Package name finch-devel
Package version 2.13.0
Package release lp151.4.4
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://pidgin.im/
License GPL-2.0-only
Maintainer -
Download size 113.09 KB
Installed size 177.24 KB
The finch-devel package contains the header files, developer
documentation, and libraries required for development of Finch
scripts and plugins.

Alternatives

Package Version Architecture Repository
finch-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
finch = 2.13.0
glibc-devel -
libpurple-devel = 2.13.0
ncurses-devel -
pkgconfig(glib-2.0) -
pkgconfig(gnt) -
pkgconfig(purple) -

Provides

Name Value
finch-devel = 2.13.0-lp151.4.4
finch-devel(x86-64) = 2.13.0-lp151.4.4
pkgconfig(finch) = 2.13.0
pkgconfig(gnt) = 2.13.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package finch-devel-2.13.0-lp151.4.4.x86_64.rpm
Source Package pidgin-2.13.0-lp151.4.4.src.rpm

Install Howto

Install finch-devel rpm package:

# zypper install finch-devel

Files

Path
/usr/include/finch/finch.h
/usr/include/finch/gntaccount.h
/usr/include/finch/gntblist.h
/usr/include/finch/gntcertmgr.h
/usr/include/finch/gntconn.h
/usr/include/finch/gntconv.h
/usr/include/finch/gntdebug.h
/usr/include/finch/gntft.h
/usr/include/finch/gntidle.h
/usr/include/finch/gntlog.h
/usr/include/finch/gntmedia.h
/usr/include/finch/gntnotify.h
/usr/include/finch/gntplugin.h
/usr/include/finch/gntpounce.h
/usr/include/finch/gntprefs.h
/usr/include/finch/gntrequest.h
/usr/include/finch/gntroomlist.h
/usr/include/finch/gntsound.h
/usr/include/finch/gntstatus.h
/usr/include/finch/gntui.h
/usr/include/gnt/gnt.h
/usr/include/gnt/gntbindable.h
/usr/include/gnt/gntbox.h
/usr/include/gnt/gntbutton.h
/usr/include/gnt/gntcheckbox.h
/usr/include/gnt/gntclipboard.h
/usr/include/gnt/gntcolors.h
/usr/include/gnt/gntcombobox.h
/usr/include/gnt/gntentry.h
/usr/include/gnt/gntfilesel.h
/usr/include/gnt/gntkeys.h
/usr/include/gnt/gntlabel.h
/usr/include/gnt/gntline.h
/usr/include/gnt/gntmarshal.h
/usr/include/gnt/gntmenu.h
/usr/include/gnt/gntmenuitem.h
/usr/include/gnt/gntmenuitemcheck.h
/usr/include/gnt/gntprogressbar.h
/usr/include/gnt/gntslider.h
/usr/include/gnt/gntstyle.h
/usr/include/gnt/gnttextview.h
/usr/include/gnt/gnttree.h
/usr/include/gnt/gntutils.h
/usr/include/gnt/gntwidget.h
/usr/include/gnt/gntwindow.h
/usr/include/gnt/gntwm.h
/usr/include/gnt/gntws.h
/usr/lib64/libgnt.so
/usr/lib64/pkgconfig/finch.pc
/usr/lib64/pkgconfig/gnt.pc

Changelog

2018-04-12 - fezhang@suse.com
- Add pidgin-enable-sni-gnutls.patch: Enable SNI for gnutls to
avoid SSL handshake failure, patch written by Tiago Herrmann
(therrmann@suse.com) (bsc#1086439, pidgin.im#17300).
2018-03-15 - sor.alexei@meowr.ru
- Instead of removing the libjabber.so, liboscar.so symlinks, move
them to the devel package.
2018-03-09 - sor.alexei@meowr.ru
- Update to version 2.13.0:
+ libpurple:
* Unified string comparison.
* Properlly shell escape URI's when opening them.
* Fix a one byte buffer overread in function
purple_markup_linkify.
* Fix an issue were utf8 was incorrectly truncated which could
lead to crashes as we were potentially feeding garbage into
glib/gtk.
+ libgnt:
* Partially fix building against curses 6.0 with opaque
structs set (pidgin.im#16764).
* Fix a crash when resizing the window (pidgin.im#16680).
+ General:
* Fix a bashism in autotools (pidgin.im#16836).
+ XMPP:
* Show XEP-0066 OOB URLs in any message, not just headlines.
* Fix a user after free (pidgin.im#17200).
* Remove pipelining from BOSH connections (pidgin.im#17025).
* Don't try to TLS already secured BOSH connections
(pidgin.im#17270).
+ IRC:
* Fix "Registration timeout" on SASL auth with InspIRCd
servers (and possibly others not based on
charybdis/ratbox/ircd-seven).
* Fix issues with plugins that modify outgoing messages (such
as the custom PART/QUIT feature of the IRC More plugin).
* Fix IRC buffer handling (pidgin.im#12562).
* Properly handle AUTHENTICATE as a normal command with server
prefix.
* Fix a crash caused by a use after free of the MOTD.
* Fix an out of bounds read in irc_nick_skip_mode.
* Fix a write of a single byte before the start of a buffer in
irc_parse_ctcp.
+ Pidgin:
* Better support for dark themes (pidgin.im#12572).
* Fix IPv6 links by not escaping []'s. (pidgin.im#16391).
* Only write buddy icons to the cache if they're not already
cached.
* Rejoin persistent chats after reconnect (pidgin.im#15687).
* Make the WIN32 Transparency plugin work on all platforms
(pidgin.im#3124).
* Ensure search results buttons are labelled.
* Fix matching unicode emoticons (pidgin.im#17232).
* Correctly update mute/unmute status when the remote side
mutes/unmutes us (pidgin.im#17273).
* Rework the status icon blinking to not use deprecated API
(pidgin.im#17174).
* Do not allow adding a buddy to protocols that don't have an
add_buddy callback.
+ Finch:
* Fix handling of search results (pidgin.im#17238).
+ Voice & Video:
* Port backend-fs to newer api for farstream relay-info
property (pidgin.im#17274).
- Rebase pidgin-ncurses-6.0-accessors.patch.
- Remove pidgin-2.10.11-purple-remote-python3.patch: fixed
upstream.
2018-03-06 - mgorse@suse.com
- Add pidgin-2.10.11-purple-remote-python3.patch: port
purple-remote to python 3 (bsc#1084147).
- Export PYTHON=python3 in %build.
- Adjust scripts to invoke python3, not python2.
2018-03-06 - sor.alexei@meowr.ru
- Drop support for SLE 11 and openSUSE older than 42.x.
- Remove pidgin-gnome-keyring.patch: was only useful for SLE 11.
2018-03-06 - dimstar@opensuse.org
- Update pidgin-ncurses-6.0-accessors.patch to cope with ncurses
enabling opaque-panels. Pidgin should not access internal
structures of ncurses.
2017-12-29 - sor.alexei@meowr.ru
- Remove pidgin-crash-missing-gst-registry.patch: is useless now
and is potentially harmful.
- Merge pidgin-nonblock-common2.patch to
pidgin-nonblock-common.patch.
2017-11-21 - fezhang@suse.com
- Add purple-import-empathy Recommends for SLE15 (FATE#322984).
2017-11-07 - sor.alexei@meowr.ru
- Correct the licence to GPL-2.0.
2017-11-02 - mpluskal@suse.com
- Explicitly require python2

See Also

Package Description
findbugs-1.3.9-lp151.2.49.noarch.rpm Bug Pattern Detector for Java
findbugs-bcel-5.2-lp151.2.44.noarch.rpm Byte Code Engineering Library with findbugs extensions
findbugs-bcel-javadoc-5.2-lp151.2.44.noarch.rpm Javadoc for findbugs-bcel
findbugs-javadoc-1.3.9-lp151.2.49.noarch.rpm Javadoc for findbugs
findbugs-tools-1.3.9-lp151.2.49.noarch.rpm Addon tools for findbugs
findutils-4.6.0-lp151.3.71.x86_64.rpm The GNU versions of find utilities (find and xargs)
findutils-lang-4.6.0-lp151.3.71.noarch.rpm Translations for package findutils
finger-1.3-lp151.2.3.x86_64.rpm Show User Information (Client)
finger-server-1.3-lp151.2.3.x86_64.rpm A Server for Showing User Information
fio-3.4-lp151.4.6.x86_64.rpm Flexible I/O tester
fips-3.3.1-lp151.1.1.x86_64.rpm OpenGL-based FITS image viewer
fipscheck-1.4.1-lp151.2.36.x86_64.rpm A library for integrity verification of FIPS validated modules
fipscheck-devel-1.4.1-lp151.2.36.x86_64.rpm Development files for fipscheck
firebird-3.0.2.32703-lp151.4.34.x86_64.rpm Database system (common files)
firebird-doc-3.0.2.32703-lp151.4.34.noarch.rpm Documentation for Firebird RDBMS
Advertisement
Advertisement