ffnvcodec-devel-8.2.15.7-lp151.1.1.x86_64.rpm


Advertisement

Description

ffnvcodec-devel - FFmpeg version of NVIDIA codec API headers

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename ffnvcodec-devel-8.2.15.7-lp151.1.1.x86_64.rpm
Package name ffnvcodec-devel
Package version 8.2.15.7
Package release lp151.1.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://git.videolan.org/?p=ffmpeg/nv-codec-headers.git
License MIT
Maintainer -
Download size 56.33 KB
Installed size 294.90 KB
This package contains the headers required for FFmpeg to interface
with NVIDIA codec APIs.

Alternatives

Package Version Architecture Repository
ffnvcodec-devel - - -

Requires

Name Value
/usr/bin/pkg-config -

Provides

Name Value
ffnvcodec-devel = 8.2.15.7-lp151.1.1
ffnvcodec-devel(x86-64) = 8.2.15.7-lp151.1.1
pkgconfig(ffnvcodec) = 8.2.15.7

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ffnvcodec-devel-8.2.15.7-lp151.1.1.x86_64.rpm
Source Package ffnvcodec-8.2.15.7-lp151.1.1.src.rpm

Install Howto

Install ffnvcodec-devel rpm package:

# zypper install ffnvcodec-devel

Files

Path
/usr/include/ffnvcodec/dynlink_cuda.h
/usr/include/ffnvcodec/dynlink_cuviddec.h
/usr/include/ffnvcodec/dynlink_loader.h
/usr/include/ffnvcodec/dynlink_nvcuvid.h
/usr/include/ffnvcodec/nvEncodeAPI.h
/usr/lib64/pkgconfig/ffnvcodec.pc
/usr/share/doc/packages/ffnvcodec-devel/README

Changelog

2019-02-23 - Martin Herkt <9+suse@cirno.systems>
- Update to version 8.2.15.7
* Add cuMipmappedArrayDestroy
2018-12-05 - Martin Herkt <9+suse@cirno.systems>
- Update to version 8.2.15.6
* CUDA 10: Add external semaphore API
* Add a subset of CUDA kernel interaction API
* Add CUDA function cuMemAllocPitch
2018-11-06 - Martin Herkt <9+suse@cirno.systems>
- Update to version 8.2.15.5
* Add CUDA function cuDeviceGetAttribute V2
* Guard against multiple definitions of CUuuid
* Add cuGetDeviceUuid, load as optional function
2018-10-07 - Martin Herkt <9+suse@cirno.systems>
- Update to version 8.2.15.1
* Update for CUDA 10
This adds support for the CUDA/Vulkan interop API, which
requires very new driver versions. As such, we allow the
symbols to be optionally loaded.
2018-06-29 - 9+suse@cirno.systems
- Update to version 8.1.24.2
* SDK 8.1
2018-06-29 - 9+suse@cirno.systems
- Init, 8.0.14.2

See Also

Package Description
ffsb-6.0_rc2-lp151.2.3.x86_64.rpm Flexible File System Benchmark
fftw3-devel-3.3.6-lp151.5.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3-gnu-hpc-devel-3.3.6-lp151.5.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-hpc-devel
fftw3-gnu-mpich-hpc-devel-3.3.6-lp151.5.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-mpich-hpc-devel
fftw3-gnu-mvapich2-hpc-devel-3.3.6-lp151.5.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-mvapich2-hpc-devel
fftw3-gnu-openmpi1-hpc-devel-3.3.6-lp151.5.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-openmpi1-hpc-devel
fftw3-gnu-openmpi2-hpc-devel-3.3.6-lp151.5.2.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-openmpi2-hpc-devel
fftw3-gnu-openmpi3-hpc-devel-3.3.6-lp151.5.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-openmpi3-hpc-devel
fftw3-mpi-devel-3.3.6-lp151.5.1.x86_64.rpm Discrete Fourier Transform (DFT) C subroutine library
fftw3-openmp-devel-3.3.6-lp151.5.1.x86_64.rpm Discrete Fourier Transform (DFT) C subroutine library
fftw3-threads-devel-3.3.6-lp151.5.1.x86_64.rpm Discrete Fourier Transform (DFT) C subroutine library
fftw3_3_3_6-gnu-hpc-devel-3.3.6-lp151.5.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-hpc-devel-static-3.3.6-lp151.5.1.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-mpich-hpc-devel-3.3.6-lp151.5.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-lp151.5.1.x86_64.rpm Static libraries for fftw3
Advertisement
Advertisement