fcitx-config-gtk3-0.4.10-lp151.2.3.x86_64.rpm


Advertisement

Description

fcitx-config-gtk3 - GTK GUI Config tool for FCITX

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename fcitx-config-gtk3-0.4.10-lp151.2.3.x86_64.rpm
Package name fcitx-config-gtk3
Package version 0.4.10
Package release lp151.2.3
Package architecture x86_64
Package type rpm
Category System/I18n/Chinese
Homepage https://github.com/fcitx/fcitx-configtool
License GPL-2.0+
Maintainer -
Download size 58.76 KB
Installed size 152.89 KB
fcitx-config GTK based configure tool for fcitx.
KDE Version see fcitx-config-kde4 or kcm-fcitx.

Alternatives

Package Version Architecture Repository
fcitx-config-gtk3 - - -

Requires

Name Value
fcitx -
libc.so.6(GLIBC_2.8)(64bit) -
libfcitx-config.so.4()(64bit) -
libfcitx-core.so.0()(64bit) -
libfcitx-gclient.so.1()(64bit) -
libfcitx-utils.so.0()(64bit) -
libgdk-3.so.0()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-3.so.0()(64bit) -

Provides

Name Value
fcitx-config-gtk = 0.4.10
fcitx-config-gtk2 = 0.4.10
fcitx-config-gtk3 = 0.4.10-lp151.2.3
fcitx-config-gtk3(x86-64) = 0.4.10-lp151.2.3
fcitx-configtool = 0.4.10
locale(libgnome:ko;zh_CN;zh_SG) -

Obsoletes

Name Value
fcitx-config-gtk < 0.4.10
fcitx-config-gtk2 < 0.4.10
fcitx-configtool < 0.4.10

Download

Type URL
Mirror widehat.opensuse.org
Binary Package fcitx-config-gtk3-0.4.10-lp151.2.3.x86_64.rpm
Source Package fcitx-configtool-0.4.10-lp151.2.3.src.rpm

Install Howto

Install fcitx-config-gtk3 rpm package:

# zypper install fcitx-config-gtk3

Files

Path
/usr/bin/fcitx-config-gtk3
/usr/share/doc/packages/fcitx-config-gtk3/COPYING
/usr/share/locale/ca/LC_MESSAGES/fcitx-configtool.mo
/usr/share/locale/da/LC_MESSAGES/fcitx-configtool.mo
/usr/share/locale/de/LC_MESSAGES/fcitx-configtool.mo
/usr/share/locale/ja/LC_MESSAGES/fcitx-configtool.mo
/usr/share/locale/ko/LC_MESSAGES/fcitx-configtool.mo
/usr/share/locale/ru/LC_MESSAGES/fcitx-configtool.mo
/usr/share/locale/tr/LC_MESSAGES/fcitx-configtool.mo
/usr/share/locale/zh_CN/LC_MESSAGES/fcitx-configtool.mo
/usr/share/locale/zh_TW/LC_MESSAGES/fcitx-configtool.mo

Changelog

2017-11-24 - i@marguerite.su
- update version 0.4.10
* enforce c99
* remove usage of deprecated gtk3 api
2017-08-20 - zaitor@opensuse.org
- Drop conditional libunique-devel, libunique1-devel,
dbus-glib-devel and unique-devel BuildRequires: Obsolete and
unused, keeping just dbus-1-glib-devel is sufficient.
2017-02-11 - i@marguerite.su
- update version 0.4.9
* shouldn't create dummy config when cfdesc doesn't exist
* remove usage of some deprecated gtk3 functions and bump
requirement to 3.12
* add qt5 wrapper support to use qt5's webengine since qt4's
webkiti is no longer maintained upstream
- add patch: fcitx-configtool-0.4.9-for-loop-init-declaration-c99.patch
* for loop initial declarations are only allowed in C99 mode
2016-11-13 - toddrme2178@gmail.com
- Fix accidental use of ":" isntead of ";" as locale delimeter
in "Provides"
- Update year
2014-02-14 - fcrozat@suse.com
- Package COPYING as %doc
2013-10-26 - i@marguerite.su
- update version 0.4.8
* This version fixes some look & feel issue caused by gtk 3.8
* Now toolbar icon not shown issue should be fixed
* Removed some outdated function in gtk 3.8 and 3.10
* Other fixes include bnc#846037
- remove patch: fcitx-configtool-gnome-3.10-fixes.patch, upstreamed
2013-10-18 - i@marguerite.su
- fix bnc#846037
* New: Too narrow window in fcitx-config-gtk3 input method
addition dialog
* gtk_scrolled_window_add_with_viewport has been deprecated
since version 3.8, now gtk_container_add() will now
automatically add a GtkViewport if the child doesn't
implement GtkScrollable
- GTK_STOCK_* is also depreciated
- Add patch:fcitx-configtool-gnome-3.10-fixes.patch
2013-07-01 - i@marguerite.su
- update version 0.4.7
* Support for new SubConfig Type
* Support for Modifier Only Key Grab
- drop fcitx-config-gtk2
* New fcitx-configtool requires gtk3-devel to build
2013-01-26 - i@marguerite.su
- update version 0.4.6
* Add support for new custom configuration ui.
2013-01-13 - i@marguerite.su
- update version 0.4.5.2
* bugfix release, fix some possible crash.

See Also

Package Description
fcitx-devel-4.2.9.6-lp151.2.5.x86_64.rpm Development files for fcitx
fcitx-fbterm-0.2.0-lp151.2.2.x86_64.rpm Fbterm Support for Fcitx
fcitx-googlepinyin-0.1.6-lp151.2.2.x86_64.rpm Googlepinyin module for fcitx
fcitx-gtk2-32bit-4.2.9.6-lp151.2.5.x86_64.rpm Gtk2 IM module for fcitx
fcitx-gtk2-4.2.9.6-lp151.2.5.x86_64.rpm Gtk2 IM module for fcitx
fcitx-gtk3-32bit-4.2.9.6-lp151.2.5.x86_64.rpm Gtk3 IM module for fcitx
fcitx-gtk3-4.2.9.6-lp151.2.5.x86_64.rpm Gtk3 IM module for fcitx
fcitx-hangul-0.3.1-lp151.2.4.x86_64.rpm Hangul Module for Fcitx IM Framework
fcitx-kkc-0.1.4-lp151.2.3.x86_64.rpm Japanese KKC IME Wrapper for Fcitx
fcitx-libpinyin-0.5.3-lp151.3.63.x86_64.rpm Libpinyin Wrapper for Fcitx
fcitx-m17n-0.2.4-lp151.2.3.x86_64.rpm M17N engine for fcitx
fcitx-mozc-2.18.2612.102-lp151.5.1.x86_64.rpm The Mozc backend for Fcitx
fcitx-pinyin-4.2.9.6-lp151.2.5.x86_64.rpm Chinese Pinyin engine for fcitx
fcitx-pinyin-tools-4.2.9.6-lp151.2.5.x86_64.rpm Fcitx tools to make pinyin match list
fcitx-pylogger-1.0-lp151.2.2.x86_64.rpm A Fcitx Typo Tracking Tool
Advertisement
Advertisement