evmctl-1.1-lp151.2.3.x86_64.rpm


Advertisement

Description

evmctl - IMA/EVM signing utility

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename evmctl-1.1-lp151.2.3.x86_64.rpm
Package name evmctl
Package version 1.1
Package release lp151.2.3
Package architecture x86_64
Package type rpm
Category System/Kernel
Homepage http://sourceforge.net/projects/linux-ima/
License LGPL-2.1+
Maintainer -
Download size 30.69 KB
Installed size 45.44 KB
The evmctl utility can be used for producing and verifying digital signatures,
which are used by Linux kernel integrity subsystem (IMA/EVM). It can be also
used to import keys into the kernel keyring.

Alternatives

Package Version Architecture Repository
evmctl - - -

Requires

Name Value
libc.so.6(GLIBC_2.7)(64bit) -
libcrypto.so.1.1()(64bit) -
libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) -
libimaevm.so.0()(64bit) -
libkeyutils.so.1()(64bit) -
libkeyutils.so.1(KEYUTILS_0.3)(64bit) -

Provides

Name Value
evmctl = 1.1-lp151.2.3
evmctl(x86-64) = 1.1-lp151.2.3
ima-evm-utils = 1.1

Obsoletes

Name Value
ima-evm-utils < 1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package evmctl-1.1-lp151.2.3.x86_64.rpm
Source Package ima-evm-utils-1.1-lp151.2.3.src.rpm

Install Howto

Install evmctl rpm package:

# zypper install evmctl

Files

Path
/usr/bin/evmctl
/usr/share/man/man1/evmctl.1.gz

Changelog

2018-03-16 - pvorel@suse.cz
- Update to version 1.1 (fate#323906)
* Support the new openssl 1.1 api
* Support for validating multiple pcrs
* Verify the measurement list signature based on the list digest
* Verify the "ima-sig" measurement list using multiple keys
* Fixed parsing the measurement template data field length
* Portable & immutable EVM signatures (new format)
* Multiple fixes that have been lingering in the next branch. Some
are for experimental features that are not yet supported in the
kernel.
- Drop ima-evm-utils-openssl1.patch (not needed any more as IMA got
backward compatible support for openssl 1.1).
2017-11-21 - mpluskal@suse.com
- Small spec file cleanup with spec-cleaner
2017-11-08 - meissner@suse.com
- ima-evm-utils-openssl1.patch: allow building against openssl 1.1 (bsc#1066947)
2017-10-23 - matthias.gerstner@suse.com
- added openssl-devel dependency to ima-evm-utils-devel. otherwise the ima
header can't be included if the openssl headers are missing
2017-10-14 - jengelh@inai.de
- No need to remove .a files which don't exist.
- Drop extraneous ldconfig call on preun.
- Update RPM groups and descriptions.
2017-10-13 - matthias.gerstner@suse.com
- ima-evm-utils-fix-docbook-xsl-directory.patch: adjusted to refer to the
"current" version of stylesheet to make the build work again
- adjusted spec file to apply stylesheet patch to SLE12 as well
2017-05-08 - meissner@suse.com
- Add ima-evm-utils to SLES. (FATE#321603)
2016-01-19 - meissner@suse.com
- ima-evm-utils-fix-docbook-xsl-directory.patch:
fixed the nwalsh docbook directory again
2015-12-02 - p.drouand@gmail.com
- Update to version 1.0
* Recursive hashing
* Immutable EVM signatures (experimental)
* Command 'ima_clear' to remove xattrs
* Support for passing password to the library
* Support for asking password safely from the user
2015-01-21 - p.drouand@gmail.com
- Update to version 0.9
* Updated README
* man page generated and added to the package
* Use additional SMACK xattrs for EVM signature generation
* Signing functions moved to libimaevm for external use (RPM)
* Fixed setting of correct hash header
- Add additional requirements; asciidoc, docbook-xsl-stylesheets,
libattr-devel and libxslt-tools
- Remove COPYING from sources; upstream provides one now
- Remove automake.patch; "test" directory isn't provided by upstream
anymore
- Remove ima-evm-utils-xattr.patch; libimaevm0 does link against
libattr now
- Split package in three subpackage
* libimaevm0: contains shared library
* -devel: contains header and examples files
* evmctl: the kernel signing tool
- Add ima-evm-utils-fix-docbook-xsl-directory.patch; fix path
where Make is looking for docbook.xsl

See Also

Package Description
evolution-3.26.6-lp151.3.9.x86_64.rpm The Integrated GNOME Mail, Calendar, and Address Book Suite
evolution-data-server-3.26.6-lp151.2.29.x86_64.rpm Evolution Data Server
evolution-data-server-32bit-3.26.6-lp151.2.29.x86_64.rpm Evolution Data Server
evolution-data-server-devel-3.26.6-lp151.2.29.x86_64.rpm Development files for Evolution Data Server
evolution-data-server-doc-3.26.6-lp151.2.29.x86_64.rpm Developer documentation for Evolution Data Server
evolution-data-server-lang-3.26.6-lp151.2.29.noarch.rpm Translations for package evolution-data-server
evolution-devel-3.26.6-lp151.3.9.x86_64.rpm Include Files and Libraries mandatory for Development
evolution-ews-3.26.6-lp151.2.5.x86_64.rpm Exchange Connector for Evolution, compatible with Exchange 2007 and later
evolution-ews-lang-3.26.6-lp151.2.5.noarch.rpm Translations for package evolution-ews
evolution-lang-3.26.6-lp151.3.9.noarch.rpm Translations for package evolution
evolution-plugin-bogofilter-3.26.6-lp151.3.9.x86_64.rpm Evolution extension -- bogofilter
evolution-plugin-pst-import-3.26.6-lp151.3.9.x86_64.rpm Evolution extension -- Outlook PST Import
evolution-plugin-rss-0.3.95+git.20171129-lp151.3.3.x86_64.rpm Evolution Plugin for RSS Feeds Support
evolution-plugin-rss-lang-0.3.95+git.20171129-lp151.3.3.noarch.rpm Translations for package evolution-rss
evolution-plugin-spamassassin-3.26.6-lp151.3.9.x86_64.rpm Evolution extension -- spamassassin
Advertisement
Advertisement