etckeeper-zypp-plugin-1.18.7-lp151.2.1.x86_64.rpm


Advertisement

Description

etckeeper-zypp-plugin - The etckeeper integration function with ZYpp

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename etckeeper-zypp-plugin-1.18.7-lp151.2.1.x86_64.rpm
Package name etckeeper-zypp-plugin
Package version 1.18.7
Package release lp151.2.1
Package architecture x86_64
Package type rpm
Category System/Management
Homepage http://etckeeper.branchable.com/
License GPL-2.0+
Maintainer -
Download size 15.40 KB
Installed size 1.14 KB
The etckeeper-zypp-plugin calls etckeeper from ZYpp.

Alternatives

Package Version Architecture Repository
etckeeper-zypp-plugin - - -

Requires

Name Value
/usr/bin/python -
etckeeper = 1.18.7-lp151.2.1
zypp-plugin-python -

Provides

Name Value
etckeeper-pkgmanager-collabo = 1.18.7-lp151.2.1
etckeeper-zypp-plugin = 1.18.7-lp151.2.1
etckeeper-zypp-plugin(x86-64) = 1.18.7-lp151.2.1
etckeeper:/usr/lib/zypp/plugins/commit/zypper-etckeeper.py -

Obsoletes

Name Value
etckeeper-pkgmanager-collabo < 1.18.7-lp151.2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package etckeeper-zypp-plugin-1.18.7-lp151.2.1.x86_64.rpm
Source Package etckeeper-1.18.7-lp151.2.1.src.rpm

Install Howto

Install etckeeper-zypp-plugin rpm package:

# zypper install etckeeper-zypp-plugin

Files

Path
/usr/lib/zypp/plugins/commit/zypper-etckeeper.py

Changelog

2017-10-18 - aavindraa@gmail.com
- update to 1.18.7:
* Will work on systems that don't have perl. (Perl is still used
when available).
* Prevent LC_ALL overriding the LC_COLLATE used to sort metadata.
- includes changes from 1.18.6:
* Only show errors (no progress indicators) when pushing
Git/Mercurial repos to avoid unecessary cron mails.
* Fix regex in 20-warn-problem-files.
* Support added for apk (alpine linux)
- Lint spec file
- Point source URL to upstream tarball
- Mark dependency on python-base per rpmlint
- Patches / source modifications:
* Add 0001-Remove-env-from-shebang-in-zypper-plugin.patch
- fixes rpmlint warning about dependency detection
* Rebase etckeeeper-avoid-packagelist.patch
* Remove junk file caught by rpmlint (.mdwn)
2016-10-22 - jengelh@inai.de
- Remove redundant sections
2016-10-15 - ecsos@opensuse.org
- update Source to 1.18.5:
- Make etckeeper commit store metadata changes. The pre-commit
hook has always (and continues) to do that, but pre-commit is
only run when there are changes to tommit. This makes
metadata-only changes get committed.
- Move systemd files to /lib/systemd; /usr/lib/systemd is not
used on Debian.
- fix wrong path for systemd in rpm based distros with sed in spec
2016-07-03 - ecsos@opensuse.org
- update Source to 1.18.4:
- Optimised find for special and hard linked files.
- Adjust when Pacman 5 calls etckeeper hooks.
- Only run Pacman hooks when files in /etc have changed.
- Added systemd timer that can run etckeeper 10 minutes after boot, and also
daily. It's not enabled by default, partly because of overlap with the
cron job.
- update Source to 1.18.3:
- Added support for pacmatic, contributed by nicolaichuk.
- bzr: make sure EMAIL is defined
- Fix Makefile version patterns to ignore non-native version number
- Support ~/.config/git/config when determining the author name and email.
- Added support for Arch's pacman package manager version 5.
- Set HOME if it's not set, as is the case when using ubuntu's
update-manager.
- Move bash completion out of etc and into usr.
- update Source to 1.18.2:
- Use getent utility instead of perl. (Elan Ruusamäe)
- Initial FreeBSD support with pkgng plugin. (William Johansson)
- Fix README.md symlink in package (Sebastian Schmidt, Antoine Beaupré,
closes: #791566)
- Fix typo of GIT_COMMITTER_EMAIL.
- update Source to 1.18.1
- Add myself as maintainer (Closes: #768516)
- Keeping the package native as I do not intend to diverge from
upstream.
- Update git URL in control file.
- update to Sourcce to 1.18:
- Send yum pre-commit output to /dev/null
- Set LANG=C internally when doing some operations that have
been reported to fail in other locales.
- update Source to 1.17:
- Fix name of DNF plugin.
- Add --version
Thanks Andreas Wansner.
- New website, http://etckeeper.branchable.com/
- Add build-depends on dh-python.
- update Source to 1.16:
- Added support for Fedora's DNF highlevel package manager.
- Add architecture info to dpkg list-installed. Closes: #768145
- Orphaned the Debian package.
- rebase patch etckeeper-avoid-packagelist.patch
- change source url to github
- remove unnecessary file etckeeper-rpmlintrc
2016-06-03 - ecsos@opensuse.org
- update Source to 1.15:
- Recommend cron-daemon, rather than cron, as etckeeper only needs
cron.daily functionality. Closes: #762721
- update Source to 1.14:
- Handle failure to commit in post-install, pre-install by showing a
warning, rather than propigating the error to apt.
This avoids breaking the apt run when eg, git is misconfigured and
cannot commit.
pre-install already did this when it was able to use debconf to display a
message, but now debconf is not used, and it always behaves this way.
Closes: #760011
- change to new url

See Also

Package Description
etherape-0.9.15-lp151.2.3.x86_64.rpm A Graphical Network Monitor
etherape-lang-0.9.15-lp151.2.3.noarch.rpm Translations for package etherape
ethtool-4.13-lp151.4.2.x86_64.rpm Examine and Tune Ethernet-Based Network Interfaces
etrophy-0.5.1-lp151.2.3.x86_64.rpm Library managing scores, trophies and unlockables
etrophy-data-0.5.1-lp151.2.3.noarch.rpm Etrophy shared data
etrophy-devel-0.5.1-lp151.2.3.x86_64.rpm Etrophy development files
evas-generic-loaders-1.20.7-lp151.6.67.x86_64.rpm Set of generic loaders for Evas
evemu-2.7.0-lp151.2.3.x86_64.rpm Input Event Device Emulation Library
evemu-devel-2.7.0-lp151.2.3.x86_64.rpm Development files for evemu
eventstat-0.04.05-lp151.1.1.x86_64.rpm Kernel event states monitoring tool
eventviews-18.12.3-lp151.1.2.x86_64.rpm Eventviews Library
eventviews-devel-18.12.3-lp151.1.2.x86_64.rpm Library for messages
eventviews-lang-18.12.3-lp151.1.2.noarch.rpm Translations for package eventviews
evieproto-devel-1.1.1-lp151.2.1.x86_64.rpm The X11 Protocol: Event Interception extension
evince-3.26.0+20180128.1bd86963-lp151.3.5.x86_64.rpm GNOME Document Viewer
Advertisement
Advertisement