drumstick-1.1.2-lp151.1.2.x86_64.rpm


Advertisement

Description

drumstick - MIDI Sequencer C++ Library Bindings

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename drumstick-1.1.2-lp151.1.2.x86_64.rpm
Package name drumstick
Package version 1.1.2
Package release lp151.1.2
Package architecture x86_64
Package type rpm
Category Productivity/Multimedia/Sound/Midi
Homepage http://drumstick.sourceforge.net/
License GPL-2.0-or-later AND GPL-3.0-or-later
Maintainer -
Download size 284.50 KB
Installed size 1.23 MB
This package includes test and example programs for drumstick libraries.

Alternatives

Package Version Architecture Repository
drumstick - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.9)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libQt5Svg.so.5()(64bit) -
libQt5Svg.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libasound.so.2()(64bit) -
libasound.so.2(ALSA_0.9)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libdrumstick-alsa.so.1()(64bit) -
libdrumstick-file.so.1()(64bit) -
libdrumstick-rt.so.1()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
shared-mime-info -

Provides

Name Value
application() -
application(drumstick-drumgrid.desktop) -
application(drumstick-guiplayer.desktop) -
application(drumstick-vpiano.desktop) -
drumstick = 1.1.2-lp151.1.2
drumstick(x86-64) = 1.1.2-lp151.1.2
mimehandler(audio/cakewalk) -
mimehandler(audio/midi) -
mimehandler(audio/overture) -
mimehandler(audio/x-midi) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package drumstick-1.1.2-lp151.1.2.x86_64.rpm
Source Package drumstick-1.1.2-lp151.1.2.src.rpm

Install Howto

Install drumstick rpm package:

# zypper install drumstick

Files

Path
/usr/bin/drumstick-drumgrid
/usr/bin/drumstick-dumpmid
/usr/bin/drumstick-dumpove
/usr/bin/drumstick-dumpsmf
/usr/bin/drumstick-dumpwrk
/usr/bin/drumstick-guiplayer
/usr/bin/drumstick-metronome
/usr/bin/drumstick-playsmf
/usr/bin/drumstick-sysinfo
/usr/bin/drumstick-vpiano
/usr/share/applications/drumstick-drumgrid.desktop
/usr/share/applications/drumstick-guiplayer.desktop
/usr/share/applications/drumstick-vpiano.desktop
/usr/share/doc/packages/drumstick/AUTHORS
/usr/share/doc/packages/drumstick/ChangeLog
/usr/share/doc/packages/drumstick/NEWS
/usr/share/doc/packages/drumstick/README
/usr/share/doc/packages/drumstick/TODO
/usr/share/icons/hicolor/16x16/apps/drumstick.png
/usr/share/icons/hicolor/32x32/apps/drumstick.png
/usr/share/icons/hicolor/48x48/apps/drumstick.png
/usr/share/icons/hicolor/64x64/apps/drumstick.png
/usr/share/icons/hicolor/scalable/apps/drumstick.svgz
/usr/share/licenses/drumstick/COPYING
/usr/share/man/man1/drumstick-drumgrid.1.gz
/usr/share/man/man1/drumstick-dumpmid.1.gz
/usr/share/man/man1/drumstick-dumpove.1.gz
/usr/share/man/man1/drumstick-dumpsmf.1.gz
/usr/share/man/man1/drumstick-dumpwrk.1.gz
/usr/share/man/man1/drumstick-guiplayer.1.gz
/usr/share/man/man1/drumstick-metronome.1.gz
/usr/share/man/man1/drumstick-playsmf.1.gz
/usr/share/man/man1/drumstick-sysinfo.1.gz
/usr/share/man/man1/drumstick-vpiano.1.gz

Changelog

2018-12-18 - wbauer@tmo.at
- Add Dont-use-QOverload.patch to make it build on Leap 42.3
2018-12-18 - wbauer@tmo.at
- Update to 1.1.2
* Fix for ticket #13 - some macOS input events lost
* Added some bundle metadata for macOS
* Solution for ticket #8: Path for plugins hardcoded
- Add pkgconfig(libpulse-simple) BuildRequires to enable building
of libdrumstick-rt-eassynth.so (boo#1119734)
- Move rt input/output plugins to a separate
libdrumstick-rt-plugins package that's required by
libdrumstick-rt1
2018-05-25 - christophe@krop.fr
- Update to 1.1.1
* fixed tab order on forms
* rt: fixed pitch bend events on several output backends
* removed ALSA/Linux dependency where possible.
* disabled fluidsynth output driver
- Split libdrumstick-rt from the main package.
2017-12-18 - christophe@krop.fr
- Update to 1.1.0
* guiplayer accepts a single file argument in the command line:
mid, kar, wrk and ove
* documentation updated
Check the installed ChangeLog file for the complete changelog.
- Drop gcc6-fix.patch. Merged upstream.
2016-06-17 - jengelh@inai.de
- Drop archaic sections, set rpm groups
2016-06-17 - wbauer@tmo.at
- The devel package requires libQt5Core-devel now, not libqt4-devel
2016-06-17 - wbauer@tmo.at
- Add gcc6-fix.patch to fix build with gcc6
2016-06-15 - wbauer@tmo.at
- Use shared-mime-database macros (boo#979301)
2016-04-12 - tittiatcoke@gmail.com
- Update to version 1.0.2
* Qt5 port.
- Drop x11.diff. No longer required.
2011-11-13 - alinm.elena@gmail.com
- fixed x11 failure to link in 12.1 added x11.diff patch
- moved to cmake_kde4 macro

See Also

Package Description
drush-8.2.2-lp151.1.1.noarch.rpm Command line shell and scripting interface for Drupal
dssi-1.1.1-lp151.2.3.x86_64.rpm Disposable Soft Synth Interface
dssi-devel-1.1.1-lp151.2.3.x86_64.rpm Development Package for DSSI plugins
dssim-1.3.2-lp151.2.3.x86_64.rpm This tool computes (dis)similarity between two (or more) PNG images
dstat-0.7.3-lp151.3.1.noarch.rpm Versatile vmstat, iostat and ifstat Replacement
dt-18.32-lp151.2.3.x86_64.rpm Generic data test program
dtach-v0.9+2.748020b-lp151.2.2.x86_64.rpm Background processes and reattach to them
dtc-1.4.4-lp151.2.2.x86_64.rpm Device-tree compiler
dtdinst-20151127-lp151.2.45.noarch.rpm XML DTD to XML instance format converter
dtkcore-2.0.9.11-lp151.1.1.x86_64.rpm Deepin Tool Kit Core
dtkcore-devel-2.0.9.11-lp151.1.1.x86_64.rpm Development tools for dtkcore
dtksettings-0.1.7-lp151.2.4.x86_64.rpm Deepin Tool Kit Settings library
dtkwidget-2.0.9.11-lp151.1.1.x86_64.rpm Deepin graphical user interface library
dtkwidget-devel-2.0.9.11-lp151.1.1.x86_64.rpm Development tools for dtkwidget
dtkwm-devel-2.0.9-lp151.1.1.x86_64.rpm Development package for dtkwm
Advertisement
Advertisement