doomsday-2.0.3-lp151.5.5.x86_64.rpm


Advertisement

Description

doomsday - The Doomsday Engine: DOOM/Hertic/Hexen port with pretty graphics

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename doomsday-2.0.3-lp151.5.5.x86_64.rpm
Package name doomsday
Package version 2.0.3
Package release lp151.5.5
Package architecture x86_64
Package type rpm
Category Amusements/Games/3D/Shoot
Homepage http://dengine.net/
License GPL-2.0+ and GPL-2.0
Maintainer -
Download size 8.29 MB
Installed size 25.14 MB
The Doomsday Engine is a source port with support for Doom, Heretic,
and Hexen. It does not support BOOM extensions.

Alternatives

Package Version Architecture Repository
doomsday - - -

Requires

Name Value
/sbin/ldconfig -
Mesa-libGL1 >= 9.2
libGL.so.1()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.9)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libQt5X11Extras.so.5()(64bit) -
libQt5X11Extras.so.5(Qt_5)(64bit) -
libSDL2-2.0.so.0()(64bit) -
libSDL2_mixer-2.0.so.0()(64bit) -
libX11.so.6()(64bit) -
libXrandr.so.2()(64bit) -
libXxf86vm.so.1()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libfluidsynth.so.1()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libncurses.so.6()(64bit) -
libncurses.so.6(NCURSEST6_5.7.20081102)(64bit) -
libopenal.so.1()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libtinfo.so.6()(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.0.19991023)(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.7.20081102)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
application() -
application(net.dengine.Doomsday.desktop) -
application(net.dengine.Shell.desktop) -
bundled(assimp) = 3.1.1
config(doomsday) = 2.0.3-lp151.5.5
deng = 2.0.3-lp151.5.5
doomsday = 2.0.3-lp151.5.5
doomsday(x86-64) = 2.0.3-lp151.5.5
jdoom = 2.0.3-lp151.5.5
jheretic = 2.0.3-lp151.5.5
jhexen = 2.0.3-lp151.5.5
libaudio_fluidsynth.so()(64bit) -
libaudio_openal.so()(64bit) -
libdeng_appfw.so.2.0()(64bit) -
libdeng_core.so.2.0()(64bit) -
libdeng_doomsday.so.2.0()(64bit) -
libdeng_gamefw.so.2.0()(64bit) -
libdeng_gui.so.2.0()(64bit) -
libdeng_legacy.so.2.0()(64bit) -
libdeng_shell.so.2.0()(64bit) -
libdoom.so()(64bit) -
libdoom64.so()(64bit) -
libheretic.so()(64bit) -
libhexen.so()(64bit) -
libimportdeh.so()(64bit) -
libimportidtech1.so()(64bit) -
libimportsave.so()(64bit) -
libimportudmf.so()(64bit) -

Obsoletes

Name Value
deng < 2.0.3-lp151.5.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package doomsday-2.0.3-lp151.5.5.x86_64.rpm
Source Package doomsday-2.0.3-lp151.5.5.src.rpm

Install Howto

Install doomsday rpm package:

# zypper install doomsday

Files

Path
/etc/doomsday/paths
/usr/bin/doomsday
/usr/bin/doomsday-2.0.3
/usr/bin/doomsday-server
/usr/bin/doomsday-server-2.0.3
/usr/bin/doomsday-shell
/usr/bin/doomsday-shell-2.0.3
/usr/bin/doomsday-shell-text
/usr/bin/doomsday-shell-text-2.0.3
/usr/bin/doomsdayscript
/usr/bin/doomsdayscript-2.0.3
/usr/bin/md2tool
/usr/bin/savegametool
/usr/bin/savegametool-2.0.3
/usr/bin/texc
/usr/bin/wadtool
/usr/lib64/libdeng_appfw.so
/usr/lib64/libdeng_appfw.so.2.0
/usr/lib64/libdeng_appfw.so.2.0.3
/usr/lib64/libdeng_core.so
/usr/lib64/libdeng_core.so.2.0
/usr/lib64/libdeng_core.so.2.0.3
/usr/lib64/libdeng_doomsday.so
/usr/lib64/libdeng_doomsday.so.2.0
/usr/lib64/libdeng_doomsday.so.2.0.3
/usr/lib64/libdeng_gamefw.so
/usr/lib64/libdeng_gamefw.so.2.0
/usr/lib64/libdeng_gamefw.so.2.0.3
/usr/lib64/libdeng_gui.so
/usr/lib64/libdeng_gui.so.2.0
/usr/lib64/libdeng_gui.so.2.0.3
/usr/lib64/libdeng_legacy.so
/usr/lib64/libdeng_legacy.so.2.0
/usr/lib64/libdeng_legacy.so.2.0.3
/usr/lib64/libdeng_shell.so
/usr/lib64/libdeng_shell.so.2.0
/usr/lib64/libdeng_shell.so.2.0.3
/usr/lib64/doomsday/libaudio_fluidsynth.so
/usr/lib64/doomsday/libaudio_openal.so
/usr/lib64/doomsday/libdoom.so
/usr/lib64/doomsday/libdoom64.so
/usr/lib64/doomsday/libheretic.so
/usr/lib64/doomsday/libhexen.so
/usr/lib64/doomsday/libimportdeh.so
/usr/lib64/doomsday/libimportidtech1.so
/usr/lib64/doomsday/libimportsave.so
/usr/lib64/doomsday/libimportudmf.so
/usr/share/applications/net.dengine.Doomsday.desktop
/usr/share/applications/net.dengine.Shell.desktop
/usr/share/doomsday/deng-logo-256.png
/usr/share/doomsday/deng-shell-logo-256.png
/usr/share/doomsday/doomsday.pk3
/usr/share/doomsday/libdoom.pk3
/usr/share/doomsday/libdoom64.pk3
/usr/share/doomsday/libheretic.pk3
/usr/share/doomsday/libhexen.pk3
/usr/share/doomsday/net.dengine.base.pack
/usr/share/doomsday/net.dengine.client.pack
/usr/share/doomsday/net.dengine.stdlib.gui.pack
/usr/share/doomsday/net.dengine.stdlib.pack
/usr/share/pixmaps/deng-logo-256.png
/usr/share/pixmaps/deng-shell-logo-256.png

Changelog

2018-02-08 - jengelh@inai.de
- Get rid of BuildRequires: xorg-x11-devel.
2018-01-14 - jengelh@inai.de
- Add bundled() markers
2017-12-14 - jengelh@inai.de
- Update to new bugfix release 2.0.3
* Server had crashed during startup with error messages related
to threading
* Non-standard C++ code had led to crash when using gcc7
* Removed duplicate IWAD spec for Heretic 1.3 /
Shadow of the Serpent Riders
* Hexen: fix crash after returning to a different map in a hub
- Add doomsday-libs.diff, doomsday-notime.diff
2017-04-20 - jengelh@inai.de
- Update to new upstream release 2.0
* The Home Screen replaces the front-end app. The Python-based
Snowberry launcher application was created in 2005 and has been
used for starting Doomsday ever since. In version 2.0, the
launcher is no longer needed because Doomsday's Home Screen
(previously called "ring zero") replaces its functionality.
* Built-in support for packages. One of the launcher's key features
was add-on management. This is now also part of Doomsday itself
in the form of packages. Anything that Doomsday can load ? WADs,
resource packs, 3D models, etc. ? is now handled via the same
package management system. This enables Doomsday to track which
files are in use in saved games and multiplayer games, and makes
it possible to automatically ensure that the correct files are
loaded at any given time.
* New 3D model renderer. Doomsday's graphics code is undergoing a
transition to a newer version of OpenGL, namely "OpenGL3/4 Core
Profile"). Certain parts like the engine UI have already
completed this transition, however the game renderer itself has
not. In version 2.0, the new version of the 3D model renderer has
reached a state where it is useful for actual gameplay. This new
renderer supports FBX and MD5 models (among other formats),
skeletal animation, GLSL shaders, and Doomsday Script.
2016-06-18 - jengelh@inai.de
- Update to new upstream release 1.15.8
* Custom episodes. Episode (DED) definitions specify the structure of
game episodes (including hubs) enabling entirely new episodes and
modifying the originals.
* MAPINFO support. MAPINFO (Hexen) definitions are now supported in
Doom and Heretic, as well as Hexen. Note that, presently, only the
Hexen dialect of MAPINFO is supported (ZDoom uses its own MAPINFO
dialect).
* Adjustable pixel density. If your GPU is on the slower side, you
can improve performance by reducing game view resolution. The rest
of the UI remains sharp since the display mode is not changed. As a
bonus, you can also get a nice nostalgic aesthetic similar to the
original Doom on a CRT display.
- If you get a blank screen instead of the game title screen
after selecting the IWAD to play, you may need to reset your
settings (~/.doomsday)!
- Added doomsday-ncurses.diff (work around absence of ncurses.pc
in not-too-new ncurses)
2016-06-16 - jengelh@inai.de
- Add -Wno-narrowing to let gcc6 build pass
2015-03-30 - dimstar@opensuse.org
- Add doomsday-no-abs-icon.patch: Do not use absolute path to
icons. Applicatio containerisation requires the icons to be below
/usr/share/icons or /usr/share/pixmaps.
- Copy the icons from the app directory to /usr/share/pixmaps.
2014-10-12 - jengelh@inai.de
- Update to new upstream release 1.14.5, which fixes:
* Hexen: Loading autosaved progress on a previously visited map
loads an out of date save state
* Hexen: Number of inventory items increases when going through
a portal
* Hexen: Puzzle progress in main hub not showing up
2014-05-20 - jengelh@inai.de
- Update to new upstream release 1.14.3, which fixes:
* Hexen: Hub maps reset after saving, causing invalid game world
state
* Doom 2: Crash playing sci2.wad MAP13
* Better compatibility with vanilla Doom renderer: dynamic
map hacks dependent on non-neighbor planes
* Hexen: Saving error ? "already exists"

See Also

Package Description
dos2unix-7.4.0-lp151.2.3.x86_64.rpm Text converters to and from DOS/MAC to UNIX
dosbox-0.74-lp151.2.4.x86_64.rpm DOS Emulator Well-Suited for Playing Games
dosemu-1.4.0.1.r2065-lp151.4.2.x86_64.rpm The DOS Emulator
dosfstools-4.1-lp151.2.3.x86_64.rpm Utilities for Making and Checking MS-DOS FAT File Systems on Linux
dotconf-devel-1.3-lp151.2.3.x86_64.rpm Configuration file parser library
double-conversion-devel-2.0.1-lp151.2.3.x86_64.rpm Development files for BCD/DCB routines for IEEE doubles
dovecot-2.3-lp151.2.1.noarch.rpm IMAP and POP3 Server Written Primarily with Security in Mind
dovecot23-2.3.3-lp151.1.3.x86_64.rpm IMAP and POP3 Server Written Primarily with Security in Mind
dovecot23-backend-mysql-2.3.3-lp151.1.3.x86_64.rpm MySQL support for Dovecot
dovecot23-backend-pgsql-2.3.3-lp151.1.3.x86_64.rpm PostgreSQL support for Dovecot
dovecot23-backend-sqlite-2.3.3-lp151.1.3.x86_64.rpm SQLite support for Dovecot
dovecot23-devel-2.3.3-lp151.1.3.x86_64.rpm Development files for Dovecot plugins
dovecot23-fts-2.3.3-lp151.1.3.x86_64.rpm Fulltext search support base plugin
dovecot23-fts-lucene-2.3.3-lp151.1.3.x86_64.rpm Fulltext search support via CLucene
dovecot23-fts-solr-2.3.3-lp151.1.3.x86_64.rpm Fulltext search support via solr
Advertisement
Advertisement