docker-compose-1.17.0-lp151.3.2.noarch.rpm


Advertisement

Description

docker-compose - Define and run complex applications using Docker

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename docker-compose-1.17.0-lp151.3.2.noarch.rpm
Package name docker-compose
Package version 1.17.0
Package release lp151.3.2
Package architecture noarch
Package type rpm
Category System/Management
Homepage https://pypi.python.org/pypi/docker-compose
License Apache-2.0
Maintainer -
Download size 169.44 KB
Installed size 762.76 KB
Compose is a tool for defining and running complex applications with Docker.
With Compose, you define a multi-container application in a single file, then
spin your application up in a single command which does everything that needs
to be done to get it running.
Compose is great for development environments, staging servers, and CI. We
don't recommend that you use it in production yet.
Previously known as Fig.

Alternatives

Package Version Architecture Repository
docker-compose - - -

Requires

Name Value
/usr/bin/python -
docker -
python >= 2.7
python(abi) = 2.7
python-PySocks >= 1.5.6
python-PyYAML >= 3.11
python-cached-property >= 1.2.0
python-docker >= 2.5.1
python-dockerpty >= 0.4.1
python-docopt >= 0.6.1
python-enum34 >= 1.0
python-ipaddress >= 1.0.16
python-jsonschema >= 2.5.1
python-requests >= 2.7.0
python-setuptools -
python-six >= 1.7.3
python-texttable >= 0.8.1
python-websocket-client >= 0.32.0

Provides

Name Value
docker-compose = 1.17.0-lp151.3.2

Conflicts

Name Value
python-PySocks >= 2
python-PyYAML >= 4
python-cached-property >= 2
python-docker >= 3
python-dockerpty >= 0.5
python-docopt >= 0.7
python-enum34 >= 2
python-jsonschema >= 3
python-six >= 2
python-websocket-client >= 1.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package docker-compose-1.17.0-lp151.3.2.noarch.rpm
Source Package docker-compose-1.17.0-lp151.3.2.src.rpm

Install Howto

Install docker-compose rpm package:

# zypper install docker-compose

Files

Path
/usr/bin/docker-compose
/usr/lib/python2.7/site-packages/compose/__init__.py
/usr/lib/python2.7/site-packages/compose/__init__.pyc
/usr/lib/python2.7/site-packages/compose/__main__.py
/usr/lib/python2.7/site-packages/compose/__main__.pyc
/usr/lib/python2.7/site-packages/compose/bundle.py
/usr/lib/python2.7/site-packages/compose/bundle.pyc
/usr/lib/python2.7/site-packages/compose/const.py
/usr/lib/python2.7/site-packages/compose/const.pyc
/usr/lib/python2.7/site-packages/compose/container.py
/usr/lib/python2.7/site-packages/compose/container.pyc
/usr/lib/python2.7/site-packages/compose/errors.py
/usr/lib/python2.7/site-packages/compose/errors.pyc
/usr/lib/python2.7/site-packages/compose/network.py
/usr/lib/python2.7/site-packages/compose/network.pyc
/usr/lib/python2.7/site-packages/compose/parallel.py
/usr/lib/python2.7/site-packages/compose/parallel.pyc
/usr/lib/python2.7/site-packages/compose/progress_stream.py
/usr/lib/python2.7/site-packages/compose/progress_stream.pyc
/usr/lib/python2.7/site-packages/compose/project.py
/usr/lib/python2.7/site-packages/compose/project.pyc
/usr/lib/python2.7/site-packages/compose/service.py
/usr/lib/python2.7/site-packages/compose/service.pyc
/usr/lib/python2.7/site-packages/compose/state.py
/usr/lib/python2.7/site-packages/compose/state.pyc
/usr/lib/python2.7/site-packages/compose/timeparse.py
/usr/lib/python2.7/site-packages/compose/timeparse.pyc
/usr/lib/python2.7/site-packages/compose/utils.py
/usr/lib/python2.7/site-packages/compose/utils.pyc
/usr/lib/python2.7/site-packages/compose/version.py
/usr/lib/python2.7/site-packages/compose/version.pyc
/usr/lib/python2.7/site-packages/compose/volume.py
/usr/lib/python2.7/site-packages/compose/volume.pyc
/usr/lib/python2.7/site-packages/compose/cli/__init__.py
/usr/lib/python2.7/site-packages/compose/cli/__init__.pyc
/usr/lib/python2.7/site-packages/compose/cli/colors.py
/usr/lib/python2.7/site-packages/compose/cli/colors.pyc
/usr/lib/python2.7/site-packages/compose/cli/command.py
/usr/lib/python2.7/site-packages/compose/cli/command.pyc
/usr/lib/python2.7/site-packages/compose/cli/docker_client.py
/usr/lib/python2.7/site-packages/compose/cli/docker_client.pyc
/usr/lib/python2.7/site-packages/compose/cli/docopt_command.py
/usr/lib/python2.7/site-packages/compose/cli/docopt_command.pyc
/usr/lib/python2.7/site-packages/compose/cli/errors.py
/usr/lib/python2.7/site-packages/compose/cli/errors.pyc
/usr/lib/python2.7/site-packages/compose/cli/formatter.py
/usr/lib/python2.7/site-packages/compose/cli/formatter.pyc
/usr/lib/python2.7/site-packages/compose/cli/log_printer.py
/usr/lib/python2.7/site-packages/compose/cli/log_printer.pyc
/usr/lib/python2.7/site-packages/compose/cli/main.py
/usr/lib/python2.7/site-packages/compose/cli/main.pyc
/usr/lib/python2.7/site-packages/compose/cli/signals.py
/usr/lib/python2.7/site-packages/compose/cli/signals.pyc
/usr/lib/python2.7/site-packages/compose/cli/utils.py
/usr/lib/python2.7/site-packages/compose/cli/utils.pyc
/usr/lib/python2.7/site-packages/compose/cli/verbose_proxy.py
/usr/lib/python2.7/site-packages/compose/cli/verbose_proxy.pyc
/usr/lib/python2.7/site-packages/compose/config/__init__.py
/usr/lib/python2.7/site-packages/compose/config/__init__.pyc
/usr/lib/python2.7/site-packages/compose/config/config.py
/usr/lib/python2.7/site-packages/compose/config/config.pyc
/usr/lib/python2.7/site-packages/compose/config/config_schema_v1.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v2.0.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v2.1.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v2.2.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v2.3.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v3.0.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v3.1.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v3.2.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v3.3.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v3.4.json
/usr/lib/python2.7/site-packages/compose/config/config_schema_v3.5.json
/usr/lib/python2.7/site-packages/compose/config/environment.py
/usr/lib/python2.7/site-packages/compose/config/environment.pyc
/usr/lib/python2.7/site-packages/compose/config/errors.py
/usr/lib/python2.7/site-packages/compose/config/errors.pyc
/usr/lib/python2.7/site-packages/compose/config/interpolation.py
/usr/lib/python2.7/site-packages/compose/config/interpolation.pyc
/usr/lib/python2.7/site-packages/compose/config/serialize.py
/usr/lib/python2.7/site-packages/compose/config/serialize.pyc
/usr/lib/python2.7/site-packages/compose/config/sort_services.py
/usr/lib/python2.7/site-packages/compose/config/sort_services.pyc
/usr/lib/python2.7/site-packages/compose/config/types.py
/usr/lib/python2.7/site-packages/compose/config/types.pyc
/usr/lib/python2.7/site-packages/compose/config/validation.py
/usr/lib/python2.7/site-packages/compose/config/validation.pyc
/usr/lib/python2.7/site-packages/docker_compose-1.17.0-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/docker_compose-1.17.0-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/docker_compose-1.17.0-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/docker_compose-1.17.0-py2.7.egg-info/entry_points.txt
/usr/lib/python2.7/site-packages/docker_compose-1.17.0-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/docker_compose-1.17.0-py2.7.egg-info/top_level.txt
/usr/share/doc/packages/docker-compose/CHANGES.md
/usr/share/doc/packages/docker-compose/LICENSE
/usr/share/doc/packages/docker-compose/README.SUSE
/usr/share/doc/packages/docker-compose/README.md
/usr/share/doc/packages/docker-compose/SWARM.md

Changelog

2017-12-22 - wolfgang.engel@suse.com
- Fix requirement of python-texttable (boo#1072403)
2017-11-03 - cobexer@gmail.com
- Update to version 1.17.0:
* Bump 1.17.0
* Miscellaneous test fixes
* Add flake8 to dev requirements
* flake8 error on master branch (fixes #5298)
* Add bash completion for `up --no-start`
* Bump 1.17.0-rc1
* flake8
* Add check_duplicate=True when creating network
* Add specific handling for pywintypes.error
* Config command generates invalid volumes (fixes #5176)
2017-10-15 - carmen@carmenbianca.eu
- Rename python-docker-py requirement to python-docker. (bsc#1062084)
2016-10-24 - jmassaguerpla@suse.com
- fix-requirements.patch: update this patch
2016-10-24 - opensuse-packaging@opensuse.org
- Update to version 1.8.1 to be in sync with latest docker (bsc#1004927):
* Remove surrounding quotes from TLS paths, if present
* Fix command hint in bundle to pull services instead of images
* Improve volumespec parsing on windows platforms
* Update docker-py dependency to latest release
* Catch APIError while printing container logs
* Only allow log streaming if logdriver is json-file or journald
* Fix integration test on Docker for Mac
* Force default host on windows to the default TCP host (instead of npipe)
* Bump docker-py dependency
* Bump 1.8.1
2016-09-15 - jmassaguerpla@suse.com
- Remove the conflict with python-requests
I am tired of this kind of errors. I am relaxing this requirement.
fix bsc#997918: TW 20160901: unable to dup since docker-compose
conflicts with python-requests
2016-08-10 - jmassaguerpla@suse.com
- add python as a requirement, otherwise python is not installed
and then you get the error
AttributeError: 'module' object has no attribute 'ssl'

See Also

Package Description
docker-distribution-registry-2.6.2-lp151.3.5.x86_64.rpm Registry server for Docker
docker-libnetwork-0.7.0.1+gitr2711_2cfbf9b1f981-lp151.1.2.x86_64.rpm Docker Networking
docker-machine-driver-kvm2-1.0.0-lp151.1.8.x86_64.rpm KVM driver for docker-machine
docker-runc-1.0.0rc6+gitr3748_96ec2177ae84-lp151.2.2.x86_64.rpm Tool for spawning and running OCI containers
docker-runc-test-1.0.0rc6+gitr3748_96ec2177ae84-lp151.2.2.noarch.rpm Test package for runc
docker-test-18.09.1_ce-lp151.1.2.x86_64.rpm Test package for docker
docker-zsh-completion-18.09.1_ce-lp151.1.2.noarch.rpm Zsh Completion for docker
docky-2.2.1.1-lp151.2.62.x86_64.rpm A Dock Application
docky-devel-2.2.1.1-lp151.2.62.x86_64.rpm A Dock Application
docky-lang-2.2.1.1-lp151.2.62.noarch.rpm Translations for package docky
dogtail-0.9.0-lp151.2.2.noarch.rpm GUI test tool and automation framework
dolphin-18.12.3-lp151.1.16.x86_64.rpm KDE File Manager
dolphin-devel-18.12.3-lp151.1.16.x86_64.rpm KDE File Manager
dolphin-part-18.12.3-lp151.1.16.x86_64.rpm KDE File Manager
dolphin-part-lang-18.12.3-lp151.1.16.noarch.rpm Translations for package dolphin
Advertisement
Advertisement