dnf-4.2.6-lp151.1.1.noarch.rpm


Advertisement

Description

dnf - Package manager forked from Yum, using libsolv as a dependency resolver

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename dnf-4.2.6-lp151.1.1.noarch.rpm
Package name dnf
Package version 4.2.6
Package release lp151.1.1
Package architecture noarch
Package type rpm
Category System/Packages
Homepage https://github.com/rpm-software-management/dnf
License GPL-2.0-or-later AND GPL-2.0-only
Maintainer -
Download size 50.61 KB
Installed size 49.29 KB
DNF is an package manager for RPM systems that was forked from Yum. Among the
many improvements, it uses libsolv as a dependency resolver.

Alternatives

Package Version Architecture Repository
dnf - - -

Requires

Name Value
python3-dnf = 4.2.6-lp151.1.1
systemd -

Provides

Name Value
dnf = 4.2.6-lp151.1.1
dnf-command(autoremove) -
dnf-command(check-update) -
dnf-command(clean) -
dnf-command(distro-sync) -
dnf-command(downgrade) -
dnf-command(group) -
dnf-command(history) -
dnf-command(info) -
dnf-command(install) -
dnf-command(list) -
dnf-command(makecache) -
dnf-command(mark) -
dnf-command(provides) -
dnf-command(reinstall) -
dnf-command(remove) -
dnf-command(repolist) -
dnf-command(repoquery) -
dnf-command(repository-packages) -
dnf-command(search) -
dnf-command(updateinfo) -
dnf-command(upgrade) -
dnf-command(upgrade-to) -

Conflicts

Name Value
dnf-plugins-core < 4.0.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package dnf-4.2.6-lp151.1.1.noarch.rpm
Source Package dnf-4.2.6-lp151.1.1.src.rpm

Install Howto

Install dnf rpm package:

# zypper install dnf

Files

Path
/usr/bin/dnf
/usr/lib/systemd/system/dnf-makecache.service
/usr/lib/systemd/system/dnf-makecache.timer
/usr/share/doc/packages/dnf/AUTHORS
/usr/share/doc/packages/dnf/README.rst
/usr/share/licenses/dnf/COPYING
/usr/share/licenses/dnf/PACKAGE-LICENSING
/usr/share/man/man8/dnf.8.gz
/usr/share/man/man8/yum2dnf.8.gz
/var/cache/dnf/

Changelog

2019-05-10 - Neal Gompa <ngompa13@gmail.com>
- Update to version 4.2.6
+ Turn on debug logging only if debuglevel is greater than 2 (rh#1355764, rh#1580022)
+ Fix issues with terminal hangs when attempting bash completion (rh#1702854)
+ Better detecting of file provides (rh#1702621)
+ Rename man page from dnf.automatic to dnf-automatic to match command name (rh#1703609)
- Drop patch included in this release
* 0001-Python2-3-compatibility-for-exceptions-representatio.patch
2019-04-26 - Neal Gompa <ngompa13@gmail.com>
- Update to version 4.2.5
+ Fix multilib obsoletes (rh#1672947)
+ Do not remove group package if other packages depend on it
+ Remove duplicates from "dnf list" and "dnf info" outputs
+ Installroot now requires absolute path
+ Allow globs in setopt in repoid part
+ Fix formatting of message about free space required
+ [doc] Add info of relation update_cache with fill_sack (rh#1658694)
+ Fix installation failiure when duplicate RPMs are specified (rh#1687286)
+ Add command abbreviations (rh#1634232)
+ Allow plugins to terminate dnf (rh#1701807)
+ Fix installation of bash completion helper (rh#1695853)
- Drop patches that are part of this release
* 0001-Add-command-abbreviations-RhBug-1634232.patch
* 0002-CMake-Actually-install-aliases.patch
* 0001-Fix-the-installation-of-completion_helper.py.patch
- Backport fix for rendering exception messages in Python 3
* 0001-Python2-3-compatibility-for-exceptions-representatio.patch
2019-04-20 - Neal Gompa <ngompa13@gmail.com>
- Ship systemd units and enable dnf-automatic subpackage
- Backport fix to reintroduce subcommand abbreviations (rh#1634232)
* Patch: 0001-Add-command-abbreviations-RhBug-1634232.patch
* Patch: 0002-CMake-Actually-install-aliases.patch
- Backport fix to correctly install the bash completion helper (rh#1695853)
* Patch: 0001-Fix-the-installation-of-completion_helper.py.patch
2019-03-31 - Neal Gompa <ngompa13@gmail.com>
- Update to version 4.2.2
+ Allow to enable modules that break default modules (rh#1648839)
+ Enhance documentation - API examples
+ Add --nobest option
+ Do not allow direct module switch (rh#1669491)
+ Use improved config parser that preserves order of data
+ Fix alias list command (rh#1666325)
+ Update documentation: implemented plugins; options; deprecated commands (rh#1670835, rh#1673278)
+ Support zchunk (".zck") compression
+ Fix behavior  of ``--bz`` option when specifying more values
+ Follow RPM security policy for package verification
+ Update modules regardless of installed profiles
+ Fix ``list --showduplicates`` (rh#1655605)
+ [conf] Use environment variables prefixed with DNF_VAR_
+ Enhance documentation of --whatdepends option (rh#1687070)
+ Allow adjustment of repo from --repofrompath (rh#1689591)
+ Document cachedir option (rh#1691365)
+ Retain order of headers in search results (rh#1613860)
+ Solve traceback with the "dnf install @module" (rh#1688823)
- Drop upstreamed patch that is part of this release
* 0001-doc-Use-the-correct-sphinx-build-binary-for-Python-2.patch
2019-02-07 - Jan Engelhardt <jengelh@inai.de>
- Reduce generated boilerplate by joining %systemd_* calls.
2019-02-07 - Neal Gompa <ngompa13@gmail.com>
- Rebase to version 4.0.10:
+ Migrated large amounts of code to libdnf
+ Add support for RH/Fedora modules
+ Migrate from YUMDB to new SWDB
+ Add dnssec extension for repodata
+ Add support for aliases
- Drop Python 2 subpackage
- Drop unneeded patches
* 0001-Add-additional-default-distroverpkg-and-installonlyp.patch
* dnf-2.6.3-Switch-default-reposdir-to-etc-dnf-repos.d.patch
* dnf-2.7.5-Fix-detection-of-Python-2.patch
- Add patch to fix detecting Sphinx in a Python 3 only build
* 0001-doc-Use-the-correct-sphinx-build-binary-for-Python-2.patch
2018-04-30 - Neal Gompa <ngompa13@gmail.com>
- Re-enable boolean dependencies now that Leap 15.0 and Tumbleweed
both only use rpm-md repository metadata, which supports this
properly.
- Adjust changes entries to use full author identities

See Also

Package Description
dnf-automatic-4.2.6-lp151.1.1.noarch.rpm Alternative CLI to "dnf upgrade" suitable for automatic, regular execution
dnf-conf-4.2.6-lp151.1.1.noarch.rpm Configuration files for DNF
dnf-lang-4.2.6-lp151.1.1.noarch.rpm Translations for package dnf
dnf-plugins-core-4.0.6-lp151.2.1.noarch.rpm Core Plugins for DNF
dnf-plugins-core-lang-4.0.6-lp151.2.1.noarch.rpm Translations for package dnf-plugins-core
dnf-utils-4.0.6-lp151.2.1.noarch.rpm Yum-utils CLI compatibility layer
dnf-yum-4.2.6-lp151.1.1.noarch.rpm As a Yum CLI compatibility layer, supplies /usr/bin/yum redirecting to DNF
dns24-update-1.0-lp151.1.1.noarch.rpm Simple update client for the dns24.ch DynDNS service
dnscrypt-proxy-1.9.5-lp151.2.3.x86_64.rpm A tool for securing communications between a client and a DNS resolver
dnscrypt-proxy-devel-1.9.5-lp151.2.3.x86_64.rpm Header files for development of DNSCrypt plugins
dnsmasq-2.78-lp151.4.1.x86_64.rpm Lightweight, Easy-to-Configure DNS Forwarder and DHCP Server
dnsmasq-utils-2.78-lp151.4.1.x86_64.rpm Utilities for manipulating DHCP server leases
dnstracer-1.9-lp151.2.3.x86_64.rpm Trace a DNS record to its start of authority
docbook-css-stylesheets-0.4-lp151.2.1.noarch.rpm DocBook CSS Stylesheets
docbook-dsssl-stylesheets-1.79-lp151.3.1.noarch.rpm DSSSL Stylesheets for the DocBook DTD
Advertisement
Advertisement