deltarpm-3.6.1-lp151.4.4.x86_64.rpm


Advertisement

Description

deltarpm - Tools to Create and Apply deltarpms

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename deltarpm-3.6.1-lp151.4.4.x86_64.rpm
Package name deltarpm
Package version 3.6.1
Package release lp151.4.4
Package architecture x86_64
Package type rpm
Category System/Packages
Homepage https://github.com/rpm-software-management/deltarpm/
License BSD-3-Clause
Maintainer -
Download size 211.66 KB
Installed size 814.75 KB
This package contains tools to create and apply deltarpms. A deltarpm
contains the difference between an old and a new version of an RPM,
which makes it possible to recreate the new RPM from the deltarpm and
the old one. You do not need to have a copy of the old RPM, because
deltarpms can also work with installed RPMs.

Alternatives

Package Version Architecture Repository
deltarpm - - -

Requires

Name Value
/usr/bin/perl -
libbz2.so.1()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
liblzma.so.5()(64bit) -
liblzma.so.5(XZ_5.0)(64bit) -
librpm.so.8()(64bit) -
librpmio.so.8()(64bit) -

Provides

Name Value
deltarpm = 3.6.1-lp151.4.4
deltarpm(x86-64) = 3.6.1-lp151.4.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package deltarpm-3.6.1-lp151.4.4.x86_64.rpm
Source Package deltarpm-3.6.1-lp151.4.4.src.rpm

Install Howto

Install deltarpm rpm package:

# zypper install deltarpm

Files

Path
/usr/bin/applydeltaiso
/usr/bin/applydeltarpm
/usr/bin/combinedeltarpm
/usr/bin/drpmsync
/usr/bin/fragiso
/usr/bin/makedeltaiso
/usr/bin/makedeltarpm
/usr/lib/rpm/rpmdumpheader
/usr/share/doc/packages/deltarpm/LICENSE.BSD
/usr/share/doc/packages/deltarpm/README
/usr/share/man/man8/applydeltaiso.8.gz
/usr/share/man/man8/applydeltarpm.8.gz
/usr/share/man/man8/combinedeltarpm.8.gz
/usr/share/man/man8/drpmsync.8.gz
/usr/share/man/man8/fragiso.8.gz
/usr/share/man/man8/makedeltaiso.8.gz
/usr/share/man/man8/makedeltarpm.8.gz

Changelog

2018-01-05 - tchvatal@suse.com
- Make python2 and python3 conditional to ensure we can build with
python3 only
2017-11-10 - mpluskal@suse.com
- Correct provides/obsoletes for python2 subpackage
2017-11-07 - mpluskal@suse.com
- Build python3 bindings as well
- Rename python2 subpackage to name consistent with current python
packaging
- Drop patch.sles8 - there does not seem to be any reason for it
2015-11-24 - ro@suse.de
- update to version 3.6.1
- remove upstreamed patch deltarpm-zlibcppflags.diff
- fix off-by-one error in delta generation code (bnc#948504)
This could lead to a segfault in rare circumstances.
- Return error rather than crashing if we can't allocate memory
- add newline in missing prelink error
- do not finish applydeltarpm jobs when in the middle of a request
- fix zlibcppflags typo
2013-06-10 - mls@suse.de
- update to deltarpm-3.6
* fixes failing applydeltarpm with gzip -9 compression
* adds a couple of manpages
2012-01-25 - saschpe@suse.de
- Package binary Python module, python-deltarpm isn't noarch any more
2012-01-23 - saschpe@suse.de
- Run spec-cleaner
- Add python-deltarpm subpackage
2011-09-30 - uli@suse.com
- cross-build fix: use %__cc macro
2011-09-18 - jengelh@medozas.de
- Remove redundant tags/sections from specfile
(cf. packaging guidelines)
- Use %_smp_mflags for parallel build
2010-10-15 - mls@suse.de
- update to current git to get support for the '-m' option,
which limits memory consumption

See Also

Package Description
deluge-1.3.15-lp151.2.48.noarch.rpm BitTorrent Client
deluge-lang-1.3.15-lp151.2.48.noarch.rpm Translations for package deluge
desktop-data-openSUSE-15.0.20171024-lp151.3.1.noarch.rpm Shared Desktop Files for openSUSE
desktop-data-openSUSE-extra-15.0.20171024-lp151.3.1.noarch.rpm Additional wallpapers
desktop-file-utils-0.23-lp151.3.3.x86_64.rpm Utilities for Manipulating Desktop Files
desktop-translations-84.87.20190508.853b49d2-lp151.1.1.noarch.rpm Desktop Files Translations
desktopfolder-1.0.5-lp151.2.2.x86_64.rpm Organize your desktop with panels, notes and photos
desktopfolder-lang-1.0.5-lp151.2.2.noarch.rpm Translations for package desktopfolder
deutex-5.1.1-lp151.2.3.x86_64.rpm WAD composer for Doom and related games
dev86-0.16.21-lp151.2.3.x86_64.rpm 8086 Development Suite
devhelp-3.26.1-lp151.3.5.x86_64.rpm Developer's Help Program for GNOME
devhelp-devel-3.26.1-lp151.3.5.x86_64.rpm Development files for the GNOME Developer Help program
devhelp-lang-3.26.1-lp151.3.5.noarch.rpm Translations for package devhelp
device-mapper-1.02.149-lp151.3.1.x86_64.rpm Device Mapper Tools
device-mapper-devel-1.02.149-lp151.3.1.x86_64.rpm Development package for the device mapper
Advertisement
Advertisement