darts-0.32-lp151.2.3.x86_64.rpm


Advertisement

Description

darts - Double Array Trie System

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename darts-0.32-lp151.2.3.x86_64.rpm
Package name darts
Package version 0.32
Package release lp151.2.3
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://chasen.org/~taku/software/darts/
License LGPL-2.1+
Maintainer -
Download size 23.15 KB
Installed size 48.50 KB
Darts is a simple C++ template library to construct
Double-Arrays [Aoe 1989]. Double-Arrays are data
structures to represent Trie. These are faster than
other Trie implementations.
Darts is used by Chasen.

Alternatives

Package Version Architecture Repository
darts - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
darts = 0.32-lp151.2.3
darts(x86-64) = 0.32-lp151.2.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package darts-0.32-lp151.2.3.x86_64.rpm
Source Package darts-0.32-lp151.2.3.src.rpm

Install Howto

Install darts rpm package:

# zypper install darts

Files

Path
/usr/include/darts.h
/usr/lib/darts/darts
/usr/lib/darts/mkdarts
/usr/share/doc/packages/darts/AUTHORS
/usr/share/doc/packages/darts/COPYING
/usr/share/doc/packages/darts/ChangeLog
/usr/share/doc/packages/darts/README

Changelog

2014-04-29 - pgajdos@suse.com
- fix url
2012-09-24 - i@marguerite.su
- update 0.32
* Fixed a problem that the license file has not been enclosed
* Small code cleanup
2012-09-24 - i@marguerite.su
- run spec-cleaner and format_spec_file service.
2012-09-22 - schwab@linux-m68k.org
- Force use of %{optflags}
- Spec file cleanup
2011-12-01 - coolo@suse.com
- add automake as buildrequire to avoid implicit dependency
2007-12-12 - uli@suse.de
- update -> 0.31 (required by new chasen)
- license change (LGPL -> dual LGPL/BSD)
- lots of entirely undocumented changes
2007-03-31 - rguenther@suse.de
- add zlib-devel BuildRequires
2006-01-25 - mls@suse.de
- converted neededforbuild to BuildRequires
2004-05-04 - hmacht@suse.de
- added norootforbuild in specfile
2003-09-09 - schwab@suse.de
- Add workaround for gcc bug.

See Also

Package Description
dash-0.5.8-lp151.2.3.x86_64.rpm POSIX-compliant Implementation of /bin/sh
dasher-4.11-lp151.2.4.x86_64.rpm Zooming Predictive Text Entry System
dasher-data-extras-4.11-lp151.2.4.noarch.rpm Zooming Predictive Text Entry System -- Data files for additional languages
dasher-data-recommended-4.11-lp151.2.4.noarch.rpm Zooming Predictive Text Entry System -- Data files for common languages
dasher-lang-4.11-lp151.2.4.noarch.rpm Translations for package dasher
data-partition-service-0.1-lp151.1.1.noarch.rpm A service that creates a data partition
datamash-1.3-lp151.2.36.x86_64.rpm Statistical, numerical and textual operations in the command line
dataquay-devel-0.9.1-lp151.2.4.x86_64.rpm Development files for dataquay, an RDF data store library
datefudge-1.22-lp151.2.3.x86_64.rpm A preload library to fake system time
dateutils-0.4.3-lp151.2.4.x86_64.rpm Nifty command line date and time utilities
dateutils-octave-0.4.3-lp151.2.4.x86_64.rpm Dateutils functions for matlab and octave
datovka-4.13.0-lp151.1.1.x86_64.rpm Library to access Czech eGov system "Datove schranky"
davfs2-1.5.4-lp151.2.3.x86_64.rpm FUSE-Filesystem to access WebDAV servers
db48-doc-4.8.30-lp151.6.70.noarch.rpm Documentation for Berkeley DB
db48-utils-4.8.30-lp151.6.70.x86_64.rpm Command Line tools for Managing Berkeley DB Databases
Advertisement
Advertisement