nwipe-0.22-lp150.1.2.x86_64.rpm


Advertisement

Description

nwipe - Standalone secure disk eraser

Property Value
Distribution openSUSE Leap 15.0
Repository Security all
Package name nwipe
Package version 0.22
Package release lp150.1.2
Package architecture x86_64
Package type rpm
Installed size 69.46 KB
Download size 35.44 KB
Official Mirror widehat.opensuse.org
This program will securely erase disks using a variety of recognised methods.
It is a fork of the dwipe command used by Darik's Boot and Nuke (dban).

Alternatives

Package Version Architecture Repository
nwipe - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libncurses.so.6()(64bit) -
libncurses.so.6(NCURSEST6_5.7.20081102)(64bit) -
libpanel.so.6()(64bit) -
libpanel.so.6(NCURSESTW6_5.7.20081102)(64bit) -
libparted.so.2()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libtinfo.so.6()(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.0.19991023)(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.7.20081102)(64bit) -

Provides

Name Value
nwipe = 0.22-lp150.1.2
nwipe(x86-64) = 0.22-lp150.1.2

Download

Type URL
Binary Package nwipe-0.22-lp150.1.2.x86_64.rpm
Source Package nwipe-0.22-lp150.1.2.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Leap_15.0/ security
  2. Install nwipe rpm package:
    # zypper install nwipe

Files

Path
/usr/bin/nwipe
/usr/share/man/man1/nwipe.1.gz

Changelog

2017-12-05 - opensuse-packaging@opensuse.org
- Update to version 0.22:
* include version.h
* fix 32bit issues
* add gitignore file
* add friendly disk size
* remove testfile
* update version in manpage
* change spelling fixes github bug #31
* change version year to 2017
* add test file
* place files in normal location
2017-12-05 - erico.mendonca@suse.com
- 0.22: updating to latest version.
2016-04-18 - erico.mendonca@suse.com
- panel_library_check.patch: there is no need to check for panel.h, as it is part of the ncurses library already.
- autoconf_version_required.patch: lowering the required autoconf version so it can be compiled on as much distros as possible.
- fix_function_returns.patch: fix missing function returns.
- nwipe-fix-uninitialized.patch: c2 was random sized as the variable is only set later.
2015-03-16 - emendonca@suse.com
- Initial version based on latest source.

See Also

Package Description
oath-toolkit-2.6.2-lp150.21.1.i586.rpm Toolkit for one-time password authentication systems
oath-toolkit-2.6.2-lp150.21.1.x86_64.rpm Toolkit for one-time password authentication systems
oath-toolkit-xml-2.6.2-lp150.21.1.noarch.rpm XML data files needed by liboath
openCryptoki-3.11.0-lp150.128.1.x86_64.rpm An Implementation of PKCS#11 (Cryptoki) v2.11 for IBM Cryptographic Hardware
openCryptoki-64bit-3.11.0-lp150.128.1.x86_64.rpm An Implementation of PKCS#11 (Cryptoki) v2.11 for IBM Cryptographic Hardware
openCryptoki-devel-3.11.0-lp150.128.1.x86_64.rpm An Implementation of PKCS#11 (Cryptoki) v2.01 for IBM Cryptographic Hardware
openscap-1.2.17-lp150.213.1.x86_64.rpm A Set of Libraries for Integration with SCAP
openscap-content-1.2.17-lp150.213.1.x86_64.rpm SCAP content
openscap-devel-1.2.17-lp150.213.1.x86_64.rpm Development Files for OpenSCAP
openscap-docker-1.2.17-lp150.213.1.x86_64.rpm Docker plugin for OpenSCAP
openscap-engine-sce-1.2.17-lp150.213.1.x86_64.rpm Script Checking Engine for OpenSCAP
openscap-extra-probes-1.2.17-lp150.213.1.x86_64.rpm SCAP probes
openscap-utils-1.2.17-lp150.213.1.x86_64.rpm Openscap utilities
owasp-modsecurity-crs-2.2.9-lp150.13.1.noarch.rpm OWASP ModSecurity Common Rule Set (CRS)
owasp-modsecurity-crs-base_rules-2.2.9-lp150.13.1.noarch.rpm Base rules for OWASP ModSecurity CRS
Advertisement
Advertisement