scilab-modules-doc-lang-6.0.1-lp150.78.1.noarch.rpm


Advertisement

Description

scilab-modules-doc-lang - Translations for package scilab

Property Value
Distribution openSUSE Leap 15.0
Repository Science all
Package filename scilab-modules-doc-lang-6.0.1-lp150.78.1.noarch.rpm
Package name scilab-modules-doc-lang
Package version 6.0.1
Package release lp150.78.1
Package architecture noarch
Package type rpm
Category System/Localization
Homepage http://www.scilab.org
License GPL-2.0-only AND BSD-3-Clause
Maintainer -
Download size 27.93 MB
Installed size 29.83 MB
Provides translations for the "scilab" package.

Alternatives

Package Version Architecture Repository
scilab-modules-doc-lang-6.0.1-lp150.4.10.noarch.rpm 6.0.1 noarch openSUSE Oss
scilab-modules-doc-lang - - -

Requires

Name Value
scilab-modules-doc = 6.0.1

Provides

Name Value
scilab-modules-doc-lang = 6.0.1-lp150.78.1
scilab-modules-doc-lang-all = 6.0.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package scilab-modules-doc-lang-6.0.1-lp150.78.1.noarch.rpm
Source Package scilab-6.0.1-lp150.78.1.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Leap_15.0/ science
  2. Install scilab-modules-doc-lang rpm package:
    # zypper install scilab-modules-doc-lang

Files

Path
/usr/share/scilab/modules/helptools/jar/scilab_fr_FR_help.jar
/usr/share/scilab/modules/helptools/jar/scilab_ja_JP_help.jar
/usr/share/scilab/modules/helptools/jar/scilab_pt_BR_help.jar
/usr/share/scilab/modules/helptools/jar/scilab_ru_RU_help.jar

Changelog

2018-10-12 - badshah400@gmail.com
- Require java 10 stringently, as java >= 11 has dropped JAF (Java
Activation Framework) and scilab does not build without it.
- Add scilab-gfortran8-errors.patch: Fix size mismatch between
function arguments and variables; these crop up as errors when
compiling against gfortran >= 8.
2018-04-20 - badshah400@gmail.com
- Explicitly add Requires: java >= 9 to make sure the correct
version of java is installed in the system.
2018-04-04 - fstrba@suse.com
- Add scilab-java_source_target.patch: Build with source and target
6 in order to avoid runtime errors with unrecognized class
version.
- Make build with any java-devel >= 9 for openSUSE >= 1500, in
order not to depend on a particular exact java version.
2018-03-12 - badshah400@gmail.com
- Drop scilab-self-closing-br.patch: No longer required as the
offending issues have been fixed upstream and we don't care for
the minor pieces enough to carry around this patch; see
https://bugzilla.scilab.org/show_bug.cgi?id=14695.
- Require xterm for scilab since the desktop launchers now launch
the executable via xterm.
2018-02-26 - badshah400@gmail.com
- Update License in keeping with upstream: Scilab is now
distributed under the terms of GPL-2.0.
- Modify scilab-launch-from-xterm.patch: also add scinotes and
xcos desktop launchers to patch, and make them launch via xterm;
add xterm to Requires.
- Modify scilab-openjdk9-no-javah.patch: enclose JAVAH variable
declaration in quotes.
- Document the addition of jaf = 1.1 to [Build]Requires; added in
previous commit, and required for building documentation in
conjunction with scilab-java9-ClassLoader.patch; not required
for openSUSE < 1500 where jdk 1.8 is used.
- Restore sed commands to clear Class-Path from Manifest files;
this was erroneously removed in previous commit.
- Use jdk 9 only for openSUSE >= 1500; disable patches relating
to jdk 9+ for older openSUSE.
- Enforce minimum version on eigen3-devel BuildRequires: at least
version 3.3.2 required.
- Add i586 to ExcludeArch, building no longer supported by
upstream.
2018-02-22 - badshah400@gmail.com
- Enforce java 9 for building, as there are runtime error when
java 10 is used
- Add scilab-xcos-java9.patch: Fix xcos compilation against
openjdk-java 9; enable building xcos during configure.
- Add scilab-java9-ClassLoader.patch: Hack frontloading of all
necessary jar classpaths by passing them to _JAVA_OPTIONS since
dynamic classpath loading doesn not work any more; see
http://mailinglists.scilab.org/Scilab-GUI-and-adv-cli-fail-to-launch-with-java-9-td4037645.html
- Enable documentation; building fixed due to above patch.
- Add scilab-bin-correct-java9-path.patch
- Drop scilab-batik-1.8.patch

See Also

Package Description
scilab-tests-6.0.1-lp150.78.1.noarch.rpm Provides test files for Scilab
scotch-6.0.6-lp150.10.1.x86_64.rpm Graph, mesh and hypergraph partitioning library
scotch-6.0.6-lp150.3.1.x86_64.rpm Graph, mesh and hypergraph partitioning library
scotch-devel-6.0.6-lp150.10.1.x86_64.rpm Development libraries for scotch
scotch-devel-6.0.6-lp150.3.1.x86_64.rpm Development libraries for scotch
scotch-devel-static-6.0.6-lp150.10.1.x86_64.rpm Development libraries for scotch
scotch-devel-static-6.0.6-lp150.3.1.x86_64.rpm Development libraries for scotch
scotch-metis-devel-6.0.6-lp150.10.1.x86_64.rpm Development libraries for scotch
scotch-metis-devel-6.0.6-lp150.3.1.x86_64.rpm Development libraries for scotch
sfcgal-1.3.2-lp150.3.8.x86_64.rpm C++ wrapper library around CGAL
sfcgal-devel-1.3.2-lp150.3.8.x86_64.rpm Development files and tools for SFCGAL applications
silo-4.8-lp150.3.54.x86_64.rpm A library for reading and writing a wide variety of scientific data
silo-devel-4.8-lp150.3.54.x86_64.rpm A library for reading and writing a wide variety of scientific data
singular-3.1.91-lp150.9.1.x86_64.rpm Singular CAS
singular-emacs-3.1.91-lp150.9.1.noarch.rpm Singular integration for Emacs
Advertisement
Advertisement