python3-splinter-3.0-lp150.10.1.x86_64.rpm


Advertisement

Description

python3-splinter - Python3 bindings for splinter

Property Value
Distribution openSUSE Leap 15.0
Repository Science all
Package filename python3-splinter-3.0-lp150.10.1.x86_64.rpm
Package name python3-splinter
Package version 3.0
Package release lp150.10.1
Package architecture x86_64
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/bgrimstad/splinter
License MPL-2.0
Maintainer -
Download size 22.17 KB
Installed size 46.44 KB
SPLINTER (SPLine INTERpolation) is a library for multivariate function
approximation implemented in C++. The library can be used for function
approximation, regression and data smoothing.
This package provides the python bindings for splinter.

Alternatives

Package Version Architecture Repository
python3-splinter-3.0-lp150.2.1.x86_64.rpm 3.0 x86_64 openSUSE Oss
python3-splinter - - -

Requires

Name Value
python(abi) = 3.6

Provides

Name Value
python3-splinter = 3.0-lp150.10.1
python3-splinter(x86-64) = 3.0-lp150.10.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-splinter-3.0-lp150.10.1.x86_64.rpm
Source Package splinter-3.0-lp150.10.1.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Leap_15.0/ science
  2. Install python3-splinter rpm package:
    # zypper install python3-splinter

Files

Path
/usr/lib/python3.6/site-packages/splinter/__init__.py
/usr/lib/python3.6/site-packages/splinter/bspline.py
/usr/lib/python3.6/site-packages/splinter/bsplinebuilder.py
/usr/lib/python3.6/site-packages/splinter/datatable.py
/usr/lib/python3.6/site-packages/splinter/function.py
/usr/lib/python3.6/site-packages/splinter/splinter.py
/usr/lib/python3.6/site-packages/splinter/utilities.py
/usr/lib/python3.6/site-packages/splinter-3.0-py3.6.egg-info/PKG-INFO
/usr/lib/python3.6/site-packages/splinter-3.0-py3.6.egg-info/SOURCES.txt
/usr/lib/python3.6/site-packages/splinter-3.0-py3.6.egg-info/dependency_links.txt
/usr/lib/python3.6/site-packages/splinter-3.0-py3.6.egg-info/not-zip-safe
/usr/lib/python3.6/site-packages/splinter-3.0-py3.6.egg-info/top_level.txt
/usr/lib/python3.6/site-packages/splinter/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/splinter/__pycache__/bspline.cpython-36.pyc
/usr/lib/python3.6/site-packages/splinter/__pycache__/bsplinebuilder.cpython-36.pyc
/usr/lib/python3.6/site-packages/splinter/__pycache__/datatable.cpython-36.pyc
/usr/lib/python3.6/site-packages/splinter/__pycache__/function.cpython-36.pyc
/usr/lib/python3.6/site-packages/splinter/__pycache__/splinter.cpython-36.pyc
/usr/lib/python3.6/site-packages/splinter/__pycache__/utilities.cpython-36.pyc

Changelog

2018-04-17 - guillaume.gardet@opensuse.org
- Add upstream_add_armv8.patch and update spec to fix build for aarch64
- Restrict build to x86* and aarch64
2017-08-29 - jengelh@inai.de
- Upgrade RPM groups; trim descriptions.
2017-08-25 - badshah400@gmail.com
- Fix package groups: shared library -> System/Libraries, devel
package -> Productivity/Scientific/Math.
2017-08-08 - badshah400@gmail.com
- Properly implement shared library packaging policy.
- Use fdupes to link duplicated files.
- Correct packaging groups.
- Use cmake macros for build, make and install stages.
2017-03-28 - badshah400@gmail.com
- Update to version 3.0.
2016-01-14 - badshah400@gmail.com
- Initial package.

See Also

Package Description
python3-ufl-2016.2.0-lp150.1.6.noarch.rpm A domain specific language for declaration of finite element discretizations
python3-utils-2.3.0-lp150.1.1.noarch.rpm numpy-stl Supporting Utilities
python3-vtk-8.2.0-lp150.135.1.x86_64.rpm Python bindings for VTK
python3-vtk-openmpi-8.2.0-lp150.135.1.x86_64.rpm Python bindings for VTK
python3-vtk-openmpi2-8.2.0-lp150.135.1.x86_64.rpm Python bindings for VTK
python3-webcolors-1.8.1-lp150.9.1.noarch.rpm Support for color names and value formats defined by the HTML
python3-xrootd-4.8.5-lp150.53.1.x86_64.rpm Python 3 bindings for XRootD
pyxplot-0.9.2-lp150.1.13.x86_64.rpm Graph plotting tool
qcas-0.5.3-lp150.2.1.x86_64.rpm Giac/Xcas Qt user interface
qcoan-2.0-lp150.1.1.x86_64.rpm Automaton and Turing Machine Simulator
qcustomplot-devel-2.0.1-lp150.8.1.x86_64.rpm Development files for QCustomPlot
qcustomplot-doc-2.0.1-lp150.8.1.noarch.rpm Documentation and examples for QCustomPlot
qd-devel-2.3.22-lp150.4.1.x86_64.rpm Development files for qd
qgis-2.18.16-lp150.2.3.x86_64.rpm QGIS is a Geographic Information System (GIS)
qgis-devel-2.18.16-lp150.2.3.x86_64.rpm Development Libraries for the QGIS
Advertisement
Advertisement