ogre-tools-1.9.0-lp150.24.6.x86_64.rpm


Advertisement

Description

ogre-tools - Additional utilities for working with the Ogre 3D engine

Property Value
Distribution openSUSE Leap 15.0
Repository Science all
Package filename ogre-tools-1.9.0-lp150.24.6.x86_64.rpm
Package name ogre-tools
Package version 1.9.0
Package release lp150.24.6
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.ogre3d.org/
License LGPL-2.1
Maintainer -
Download size 116.33 KB
Installed size 382.64 KB
OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible
3D engine written in C++ designed to make it easier and more intuitive for
developers to produce applications utilising hardware-accelerated 3D graphics.
The class library abstracts all the details of using the underlying system
libraries like Direct3D and OpenGL and provides an interface based on world
objects and other intuitive classes.
This package contains various tools that make working with ogre easier.

Alternatives

Package Version Architecture Repository
ogre-tools-1.9.0-lp150.17.10.x86_64.rpm 1.9.0 x86_64 Games
ogre-tools-1.9.0-lp150.1.5.x86_64.rpm 1.9.0 x86_64 openSUSE Oss
ogre-tools - - -

Requires

Name Value
libOgreMain.so.1.9.0()(64bit) -
libboost_system.so.1.66.0()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libtinyxml.so.0()(64bit) -

Provides

Name Value
ogre-tools = 1.9.0-lp150.24.6
ogre-tools(x86-64) = 1.9.0-lp150.24.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ogre-tools-1.9.0-lp150.24.6.x86_64.rpm
Source Package ogre-1.9.0-lp150.24.6.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Leap_15.0/ science
  2. Install ogre-tools rpm package:
    # zypper install ogre-tools

Files

Path
/usr/bin/OgreMeshUpgrader
/usr/bin/OgreXMLConverter

Changelog

2018-01-02 - stefan.bruens@rwth-aachen.de
- Fix aarch64 build, add fix-aarch64-detection.patch
- Fix armv{6,7}l build, set flags for zzip (same as i586)
2017-12-08 - mimi.vx@gmail.com
- fix boost BuildRequires
2016-09-25 - jengelh@inai.de
- Trim repetitive descriptions and include more details on what
the components do.
2016-09-15 - mimi.vx@gmail.com
- don't build Cg plugin.
2016-09-10 - mimi.vx@gmail.com
- change macro for _version, obs-source-validator can't expand
complex macros
2015-11-24 - rpm@fthiessen.de
- Added fix-template-function.patch from fedora to resolve link
errors due to incorrect template creation.
Needed for openSUSE Factory.
2014-03-11 - Rene.vanPaassen@gmail.com
- removing the platform inttypes patch, did not solve anything
- correcting the unsigned long long constants in
OgrePixelFormatDescriptions.h, this tripped on sles 11 (older gcc)
2014-03-10 - Rene.vanPaassen@gmail.com
- use platform inttypes.h for sles
2014-03-10 - Rene.vanPaassen@gmail.com
- fixed Samples/Browser/CMakeLists.txt for new cmake 3.0.0 (does
not permit [ ] in command
- added explicit template instantiation to
OgreMain/src/OgreProgressiveMeshGenerator.cpp for sled/sles
- explicitly indicate source of uint in
Samples/TextureArray/include/TextureArray.h
2014-01-06 - Rene.vanPaassen@gmail.com
- fix UTF-8 BOM problem for older gcc (sles 11)

See Also

Package Description
openEMS-0.0.35-lp150.30.4.x86_64.rpm Electromagnetic field solver using the EC-FDTD method
openEMS-devel-0.0.35-lp150.30.4.x86_64.rpm openEMS development files
openEMS-matlab-0.0.35-lp150.30.4.x86_64.rpm MATLAB interface for openEMS
openbabel-2.4.1-lp150.14.2.x86_64.rpm A chemistry toolbox
openbabel-devel-2.4.1-lp150.14.2.x86_64.rpm Development files for Open Babel
openblas-devel-0.3.5-lp150.64.1.x86_64.rpm Development headers and libraries for OpenBLAS
openblas-devel-headers-0.3.5-lp150.64.1.noarch.rpm Development headers for OpenBLAS
openblas-pthreads_0_3_5-gnu-hpc-devel-static-0.3.5-lp150.64.1.x86_64.rpm Static version of OpenBLAS
openblas_0_3_5-gnu-hpc-devel-static-0.3.5-lp150.64.1.x86_64.rpm Static version of OpenBLAS
openblas_openmp-devel-static-0.3.5-lp150.64.1.x86_64.rpm Static version of OpenBLAS
openblas_pthreads-devel-static-0.3.5-lp150.64.1.x86_64.rpm Static version of OpenBLAS
openblas_serial-devel-static-0.3.5-lp150.64.1.x86_64.rpm Static version of OpenBLAS
opencl-cpp-headers-2.0.10-lp150.4.3.noarch.rpm OpenCL C++ headers
opencl-headers-1_2-1.2_20150303-lp150.7.6.noarch.rpm OpenCL (Open Computing Language) headers
opencl-headers-2.2+git.20181211-lp150.16.1.noarch.rpm OpenCL (Open Computing Language) headers
Advertisement
Advertisement