netcdf-cxx4-tools-4.3.0-lp150.41.2.noarch.rpm


Advertisement

Description

netcdf-cxx4-tools - Tools for working with the netcdf4 C++ library

Property Value
Distribution openSUSE Leap 15.0
Repository Science all
Package filename netcdf-cxx4-tools-4.3.0-lp150.41.2.noarch.rpm
Package name netcdf-cxx4-tools
Package version 4.3.0
Package release lp150.41.2
Package architecture noarch
Package type rpm
Category Productivity/Scientific/Other
Homepage http://www.unidata.ucar.edu/software/netcdf/
License NetCDF
Maintainer -
Download size 11.14 KB
Installed size 4.61 KB
NetCDF4 (network Common Data Form) is a set of software libraries and
machine-independent data formats that support the creation, access, and sharing
of array-oriented scientific data.
This package provides tools for working with the C++ API.

Alternatives

Package Version Architecture Repository
netcdf-cxx4-tools-4.3.0-lp150.8.1.noarch.rpm 4.3.0 noarch openSUSE Oss
netcdf-cxx4-tools - - -

Provides

Name Value
netcdf-cxx4-tools = 4.3.0-lp150.41.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package netcdf-cxx4-tools-4.3.0-lp150.41.2.noarch.rpm
Source Package netcdf-cxx4-4.3.0-lp150.41.2.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Leap_15.0/ science
  2. Install netcdf-cxx4-tools rpm package:
    # zypper install netcdf-cxx4-tools

Files

Path
/usr/bin/ncxx4-config
/usr/share/doc/packages/netcdf-cxx4-tools/COPYRIGHT

Changelog

2018-04-30 - eich@suse.com
- (Temporarily) disable fpr S390* as a check test for netcdf fails
currently on BE (bsc#1091474).
2018-04-27 - eich@suse.com
- Disable non-HPC builds on non-openSUSE systems:
a. currently only SUSE products/projects are supported/
b. non-HPC builds are not and have never been supported on SLE,
on openSUSE they are provided for compatibility reasons
(bsc#1091223).
2018-03-22 - ro@suse.de
- add netcdf-cxx4-testsuite_bigendian.patch (bsc#1086393)
skip problematic testcases on bigendian architectures for now
looks like netcdf-4.4.X is lacking proper support
- output test log in case of error in check section of specfile
2018-02-09 - eich@suse.com
- Fix summary in module files (bnc#1080259).
2018-01-05 - eich@suse.com
- Switch from gcc6 to gcc7 as additional compiler flavor for HPC on SLES.
- Fix library package requires - use HPC macro (boo#1074890).
2017-11-14 - eich@suse.com
- Fix modules file: only use %hpc_bindir if it really exists
- installing the tool package is optional.
- Translate '-' to '_' for env-variable.
- Require lua-lmod.
- Add Requires for library package to tools package.
2017-11-10 - eich@suse.com
- Add Requires: for the netcdf library/devel package to the
netcdf-cxx4 library/devel package for HPC.
2017-10-30 - eich@suse.com
- Add and fix 'standard' build.
2017-10-25 - eich@suse.com
- Fix Requires for the devel package.
2017-10-23 - eich@suse.com
- Fix buildrequires for compiler_families where c_f_ver is set.

See Also

Package Description
netcdf-cxx4_4_3_0-gnu-hpc-tools-4.3.0-lp150.41.1.noarch.rpm Tools for working with the netcdf4 C++ library
netcdf-devel-4.6.1-lp150.84.1.x86_64.rpm Development files for netcdf
netcdf-devel-data-4.6.1-lp150.84.1.x86_64.rpm Development data files for netcdf
netcdf-devel-static-4.6.1-lp150.84.1.x86_64.rpm Static development files for netcdf
netcdf-fortran-gnu-mpich-hpc-4.4.4-lp150.31.1.noarch.rpm Dependency package for netcdf-fortran_4_4_4-gnu-mpich-hpc
netcdf-fortran-gnu-mpich-hpc-devel-4.4.4-lp150.31.1.noarch.rpm Dependency package for netcdf-fortran_4_4_4-gnu-mpich-hpc-devel
netcdf-fortran-gnu-openmpi1-hpc-4.4.4-lp150.31.1.noarch.rpm Dependency package for netcdf-fortran_4_4_4-gnu-openmpi1-hpc
netcdf-fortran-gnu-openmpi1-hpc-devel-4.4.4-lp150.31.1.noarch.rpm Dependency package for netcdf-fortran_4_4_4-gnu-openmpi1-hpc-devel
netcdf-fortran-gnu-openmpi2-hpc-4.4.4-lp150.31.1.noarch.rpm Dependency package for netcdf-fortran_4_4_4-gnu-openmpi2-hpc
netcdf-fortran-gnu-openmpi2-hpc-devel-4.4.4-lp150.31.1.noarch.rpm Dependency package for netcdf-fortran_4_4_4-gnu-openmpi2-hpc-devel
netcdf-fortran-gnu-openmpi3-hpc-4.4.4-lp150.31.1.noarch.rpm Dependency package for netcdf-fortran_4_4_4-gnu-openmpi3-hpc
netcdf-fortran-gnu-openmpi3-hpc-devel-4.4.4-lp150.31.1.noarch.rpm Dependency package for netcdf-fortran_4_4_4-gnu-openmpi3-hpc-devel
netcdf-fortran_4_4_4-gnu-mpich-hpc-4.4.4-lp150.31.1.x86_64.rpm Command-line programs for the NetCDF scientific data format
netcdf-fortran_4_4_4-gnu-mpich-hpc-devel-4.4.4-lp150.31.1.x86_64.rpm Development files for netcdf-fortran_4_4_4-gnu-mpich-hpc
netcdf-fortran_4_4_4-gnu-mpich-hpc-devel-static-4.4.4-lp150.31.1.x86_64.rpm Static development files for netcdf-fortran_4_4_4-gnu-mpich-hpc
Advertisement
Advertisement