mpfi-devel-1.5.3-lp150.10.6.x86_64.rpm


Advertisement

Description

mpfi-devel - Development files for the MPFI interval arithmetic computation library

Property Value
Distribution openSUSE Leap 15.0
Repository Science all
Package filename mpfi-devel-1.5.3-lp150.10.6.x86_64.rpm
Package name mpfi-devel
Package version 1.5.3
Package release lp150.10.6
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://mpfi.gforge.inria.fr/
License LGPL-2.1+
Maintainer -
Download size 28.14 KB
Installed size 32.37 KB
MPFI is a C library for arbitrary precision interval arithmetic with
intervals represented using MPFR reliable floating-point numbers.
This subpackage provides the development headers and libraries for it.

Alternatives

Package Version Architecture Repository
mpfi-devel-1.5.3-lp150.1.4.x86_64.rpm 1.5.3 x86_64 openSUSE Oss
mpfi-devel - - -

Requires

Name Value
libmpfi0 = 1.5.3

Provides

Name Value
mpfi-devel = 1.5.3-lp150.10.6
mpfi-devel(x86-64) = 1.5.3-lp150.10.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package mpfi-devel-1.5.3-lp150.10.6.x86_64.rpm
Source Package mpfi-1.5.3-lp150.10.6.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Leap_15.0/ science
  2. Install mpfi-devel rpm package:
    # zypper install mpfi-devel

Files

Path
/usr/include/mpfi.h
/usr/include/mpfi_io.h
/usr/lib64/libmpfi.so
/usr/share/info/mpfi.info.gz

Changelog

2018-01-19 - jengelh@inai.de
- Update to new upstream release 1.5.3
* be compatible with MPFR version 4.0.0
- Changes introduced with 1.5.2
* fix documentation of comparison functions
* fix bug in mpfi_sub_fr
* new symbols MPFI_VERSION_MAJOR, MPFI_VERSION_MINOR,
MPFI_VERSION_PATCHLEVEL, and MPFI_VERSION_STRING in mpfi.h
* detect availability of mpfr_z_sub, mpfr_z_div, and mpfr_q_sub
and use a custom implementation for the ones not provided by
MPFR (mpfr_z_sub appeared in MPFR 3.1.0, the other ones are
used in tests only)
* tadd_q does no more check overflow by default (required too
much memory)
* sign of zeros choice documented
2012-12-13 - jengelh@inai.de
- Initial package (version 1.5.1) for build.opensuse.org

See Also

Package Description
mumps-devel-5.1.2-lp150.21.1.x86_64.rpm Files needed for developing mumps based applications
mumps-devel-static-5.1.2-lp150.21.1.x86_64.rpm Files needed for developing mumps based applications
mumps-doc-5.1.2-lp150.21.1.noarch.rpm A MUltifrontal Massively Parallel Sparse direct Solver
mumps-examples-5.1.2-lp150.21.1.x86_64.rpm Test programs and examples for mumps
mumps-gnu-mpich-hpc-devel-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-mpich-hpc-devel
mumps-gnu-mpich-hpc-doc-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-mpich-hpc-doc
mumps-gnu-mpich-hpc-examples-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-mpich-hpc-examples
mumps-gnu-mvapich2-hpc-devel-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-mvapich2-hpc-devel
mumps-gnu-mvapich2-hpc-doc-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-mvapich2-hpc-doc
mumps-gnu-mvapich2-hpc-examples-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-mvapich2-hpc-examples
mumps-gnu-openmpi1-hpc-devel-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-openmpi1-hpc-devel
mumps-gnu-openmpi1-hpc-doc-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-openmpi1-hpc-doc
mumps-gnu-openmpi1-hpc-examples-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-openmpi1-hpc-examples
mumps-gnu-openmpi2-hpc-devel-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-openmpi2-hpc-devel
mumps-gnu-openmpi2-hpc-doc-5.1.2-lp150.21.1.noarch.rpm Dependency package for mumps_5_1_2-gnu-openmpi2-hpc-doc
Advertisement
Advertisement