qt3-3.3.8c-lp150.157.1.armv7hl.rpm


Advertisement

Description

qt3 - A library for developing applications with graphical user interfaces

Property Value
Distribution openSUSE Leap 15.0
Repository Packman all
Package filename qt3-3.3.8c-lp150.157.1.armv7hl.rpm
Package name qt3
Package version 3.3.8c
Package release lp150.157.1
Package architecture armv7hl
Package type rpm
Category System/Libraries
Homepage http://www.trolltech.com/
License GPL-2.0-only OR GPL-3.0-only OR QPL-1.0
Maintainer -
Download size 2.44 MB
Installed size 8.17 MB
Qt is a program library for developing applications with graphical user
interfaces. It allows you to rapidly develop professional programs. The
Qt library is available not only for Linux but for a great number of
Unices and even for Windows. Thus it is possible to write programs that
may be easily ported to those platforms.
You need a license for using Qt with a non-GPL application, which can
be acquired from sales@trolltech.com.
See /usr/share/doc/packages/qt3 for details about the new features of
the current Qt library!

Alternatives

Package Version Architecture Repository
qt3-3.3.8c-lp150.157.1.x86_64.rpm 3.3.8c x86_64 Packman
qt3 - - -

Requires

Name Value
/bin/grep -
/sbin/ldconfig -
config(qt3) = 3.3.8c-lp150.157.1
ld-linux-armhf.so.3 -
ld-linux-armhf.so.3(GLIBC_2.4) -
libICE.so.6 -
libSM.so.6 -
libX11.so.6 -
libXcursor.so.1 -
libXext.so.6 -
libXft.so.2 -
libXi.so.6 -
libXinerama.so.1 -
libXrandr.so.2 -
libXrender.so.1 -
libc.so.6 -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.4) -
libdl.so.2 -
libdl.so.2(GLIBC_2.4) -
libfontconfig.so.1 -
libfreetype.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.5) -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libm.so.6 -
libm.so.6(GLIBC_2.4) -
libmng.so.2 -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.4) -
libqt-mt.so.3 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(CXXABI_ARM_1.3.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libz.so.1 -

Provides

Name Value
config(qt3) = 3.3.8c-lp150.157.1
libqimsw-multi.so -
libqimsw-none.so -
libqjpeg.so -
libqmng.so -
libqsimple.so -
libqt-mt.so.3 -
libqui.so.1 -
libqxim.so -
qt3 = 3.3.8c-lp150.157.1
qt3(armv7hl-32) = 3.3.8c-lp150.157.1
qt_library_3.3.8c -

Download

Type URL
Mirror packman.inode.at
Binary Package qt3-3.3.8c-lp150.157.1.armv7hl.rpm
Source Package qt3-3.3.8c-lp150.157.1.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_15.0/ packman
  2. Install qt3 rpm package:
    # zypper install qt3

Files

Path
/etc/X11/qtrc
/usr/lib/libqt-mt.so.3
/usr/lib/libqui.so.1
/usr/lib/qt3/
/usr/lib/qt3/bin/assistant
/usr/lib/qt3/bin/qtconfig
/usr/lib/qt3/etc/settings
/usr/lib/qt3/lib/libqt-mt.so.3
/usr/lib/qt3/lib/libqt-mt.so.3.3
/usr/lib/qt3/lib/libqt-mt.so.3.3.8
/usr/lib/qt3/lib/libqui.so.1
/usr/lib/qt3/lib/libqui.so.1.0
/usr/lib/qt3/lib/libqui.so.1.0.0
/usr/lib/qt3/plugins/
/usr/lib/qt3/plugins/imageformats/libqjpeg.so
/usr/lib/qt3/plugins/imageformats/libqmng.so
/usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
/usr/lib/qt3/plugins/inputmethods/libqimsw-none.so
/usr/lib/qt3/plugins/inputmethods/libqsimple.so
/usr/lib/qt3/plugins/inputmethods/libqxim.so
/usr/lib/qt3/translations/assistant_de.qm
/usr/lib/qt3/translations/qt_ar.qm
/usr/lib/qt3/translations/qt_ca.qm
/usr/lib/qt3/translations/qt_cs.qm
/usr/lib/qt3/translations/qt_de.qm
/usr/lib/qt3/translations/qt_es.qm
/usr/lib/qt3/translations/qt_fr.qm
/usr/lib/qt3/translations/qt_he.qm
/usr/lib/qt3/translations/qt_it.qm
/usr/lib/qt3/translations/qt_ja.qm
/usr/lib/qt3/translations/qt_nb.qm
/usr/lib/qt3/translations/qt_pl.qm
/usr/lib/qt3/translations/qt_pt-br.qm
/usr/lib/qt3/translations/qt_pt.qm
/usr/lib/qt3/translations/qt_ru.qm
/usr/lib/qt3/translations/qt_sk.qm
/usr/lib/qt3/translations/qt_zh-cn.qm
/usr/lib/qt3/translations/qt_zh-tw.qm
/usr/share/doc/packages/qt3/FAQ
/usr/share/doc/packages/qt3/LICENSE.GPL2
/usr/share/doc/packages/qt3/LICENSE.GPL3
/usr/share/doc/packages/qt3/LICENSE.QPL
/usr/share/doc/packages/qt3/MANIFEST
/usr/share/doc/packages/qt3/README
/usr/share/doc/packages/qt3/README-QT.TXT
/usr/share/doc/packages/qt3/README.immodule
/usr/share/doc/packages/qt3/changes-3.3.8b

Changelog

2019-08-21 - olaf@aepfle.de
- Disable LTO instead
2019-08-02 - olaf@aepfle.de
- Use FAT LTO objects in order to provide proper static library.
2018-03-01 - crrodriguez@opensuse.org
- Remove xorg-x11-devel from Requires and BuildRequires,
replaced by individual pkgconfig() deps, including the -devel
package where they are not needed but kept anyway to avoid
breaking tons of legacy software that expected xorg-x11-devel
to be pulled in.
2017-10-13 - dimstar@opensuse.org
- BuildRequire libnsl-devel: yp headers have been split out.
2015-09-14 - anixx@opensuse.org
- Further fix to iconview widget. Patch from Trinity
qt3-trinity-fix-iconview-widget2.patch
2015-07-15 - anixx@opensuse.org
- Fixed search algorithm for iconview widget. Patch from Trinity.
Trinity bug 420, KDE bug 79370.
qt3-trinity-fix-iconview-widget.patch
2015-06-05 - anixx@opensuse.org
- A set of security patches from Fedora:
qt-x11-free-3.3.8b-CVE-2013-4549.patch
qt-x11-free-3.3.8b-CVE-2015-0295.patch
qt-x11-free-3.3.8b-CVE-2015-1860.patch
2014-03-26 - anixx@opensuse.org
- disable the wholeglib main loop patch for now because it causes
kdebindings to fail, disabling the configure option is not enough
2014-03-22 - anixx@opensuse.org
- disable glib main loop for now because it causes kdebindings to fail
2014-01-28 - anixx@opensuse.org
- enable the glib mainloop (forgot to do so in the previous commit)

See Also

Package Description
qt3-devel-3.3.8c-lp150.157.1.armv7hl.rpm Include Files and Libraries mandatory for Development
qt3-devel-3.3.8c-lp150.157.1.x86_64.rpm Include Files and Libraries mandatory for Development
qt4pas-devel-2.5-lp150.1.12.x86_64.rpm Development Files for qt4pas
qtsmbstatus-2.3.1-lp150.4.1.aarch64.rpm A GUI for smbstatus with Qt
qtsmbstatus-2.3.1-lp150.4.21.x86_64.rpm A GUI for smbstatus with Qt
qtsmbstatus-lang-2.3.1-lp150.4.1.aarch64.rpm Language files for qtsmbstatus
qtsmbstatus-lang-2.3.1-lp150.4.21.x86_64.rpm Language files for qtsmbstatus
qtsmbstatus-light-2.3.1-lp150.4.1.aarch64.rpm A GUI for smbstatus with Qt (light version)
qtsmbstatus-light-2.3.1-lp150.4.21.x86_64.rpm A GUI for smbstatus with Qt (light version)
qtsmbstatus-server-2.3.1-lp150.4.1.aarch64.rpm A GUI for smbstatus with Qt (Server)
qtsmbstatus-server-2.3.1-lp150.4.21.x86_64.rpm A GUI for smbstatus with Qt (Server)
qtweetlib-devel-0.5-lp150.2.2.aarch64.rpm C++ Qt based Twitter library
qtweetlib-devel-0.5-lp150.2.2.armv7hl.rpm C++ Qt based Twitter library
qtweetlib-devel-0.5-lp150.2.7.x86_64.rpm C++ Qt based Twitter library
quimup-1.4.4-lp150.5.2.aarch64.rpm A client for the music player daemon (MPD)
Advertisement
Advertisement