perl-mythtv-0.28.2+git20180529.ae037d012e-lp150.1.1.noarch.rpm


Advertisement

Description

perl-mythtv - Perl bindings for mythtv

Property Value
Distribution openSUSE Leap 15.0
Repository Packman all
Package name perl-mythtv
Package version 0.28.2+git20180529.ae037d012e
Package release lp150.1.1
Package architecture noarch
Package type rpm
Installed size 88.97 KB
Download size 65.47 KB
Official Mirror packman.inode.at
A personal video recorder (PVR/DVR) application.
Provides a perl-based interface to interacting with mythtv.

Alternatives

Package Version Architecture Repository
perl-mythtv - - -

Requires

Name Value
perl(:MODULE_COMPAT_5.26.1) -
perl(DBD::mysql) -
perl(Net::UPnP) -
perl(Net::UPnP::ControlPoint) -

Provides

Name Value
perl(IO::Socket::INET::MythTV) -
perl(MythTV) -
perl(MythTV::Channel) -
perl(MythTV::Program) -
perl(MythTV::Recording) -
perl(MythTV::StorageGroup) -
perl-MythTV-0_27 = 0.28.2+git20180529.ae037d012e
perl-mythtv = 0.28.2+git20180529.ae037d012e-lp150.1.1

Conflicts

Name Value
otherproviders(perl-mythtv) -

Obsoletes

Name Value
perl-MythTV-0_27 < 0.28.2+git20180529.ae037d012e

Download

Type URL
Binary Package perl-mythtv-0.28.2+git20180529.ae037d012e-lp150.1.1.noarch.rpm
Source Package mythtv-0.28.2+git20180529.ae037d012e-lp150.1.1.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_15.0/ packman
  2. Install perl-mythtv rpm package:
    # zypper install perl-mythtv

Files

Path
/usr/lib/perl5/vendor_perl/5.26.1/MythTV.pm
/usr/lib/perl5/vendor_perl/5.26.1/IO/
/usr/lib/perl5/vendor_perl/5.26.1/IO/Socket/
/usr/lib/perl5/vendor_perl/5.26.1/IO/Socket/INET/MythTV.pm
/usr/lib/perl5/vendor_perl/5.26.1/MythTV/Channel.pm
/usr/lib/perl5/vendor_perl/5.26.1/MythTV/Program.pm
/usr/lib/perl5/vendor_perl/5.26.1/MythTV/Recording.pm
/usr/lib/perl5/vendor_perl/5.26.1/MythTV/StorageGroup.pm

Changelog

2018-06-28 - avvissu@yandex.by
- Update to version 0.28.2+git20180529.ae037d012e:
* Fix crash during recording with newer compilers
* Revert "Fix crash in ProgramMapTable::Create"
* Fix crash in ProgramMapTable::Create
* Fix crash (abort) in MythSocket::ResetReal
* Raspberry Pi Openmax Audio: Fix swapped channels when using
PCM output
- Add pkgconfig(Qt5Sql)
- Fix: Unknown option in suse_update_desktop_file
- Fix: suse-filelist-forbidden-sysconfig
2018-04-10 - avvissu@yandex.by
- Add python-requests-cache
2018-03-07 - avvissu@yandex.by
- Update to version 0.28.2+git20180201.8238e839c9:
* Fix FTBFS due to ambiguous calls to endsWith and startsWith
* Fix cppcheck warning about unclear operator precedence.
* Fix compilation error in Fedora Rawhide.
* Remove extra closing brace in file.
* Update qmake project files for a minimum 5.2 version.
* Clean up Qt version checking in 'configure'.
* Clean up the checks for finding the qmake executable.
* ttvdb.py: Handle missing banners gracefully
* Convert monkey patch _cache_expire_after to timedelta if its not already
* Ignore .qmake.stash files
* Ignore vscode config directory
* Ignore moc_predefs.h files
* MythSystem: Make sure to clean up objects properly
* MainServer: Reinstate the event about disconnected sockets
* Fix miniplayer display issue when playing radio streams with no broadcaster
* Fixes #12029 Forced Subtitles (MKV) can stay onscreen indefinitely
* Check for an empty banner list before running it.
* Use mysql_options() to specify reconnection.
* Fix memory corruption on Raspberry Pi Playback
* MythMusic: stop the player on first error when playing radio streams
* Resynchronises mark types in the python bindings.
* The Perl bindings should ignore a blank LocalHostName tag in the config.
* ttvdb: Check if episodes are received before parsing them. Fixes #13152
* Make the Canadian weather scripts work again.
* Create all directories leading to the ttvdb/tmdb3 cache files.
* Use the define property flags when creating a RecordingInfo object.
* ttvdb: Various fixes
* Refs #13084 ttvdb fix runtime and genre
* Fixes #12950 - Update Mythmusic schema in python bindings
* Fix PPA Build error for ARM platforms.
* Fix OpenGL bug introduced recently
* Raspberry Pi: Support for Raspbian Stretch (fixes/0.28)
* Fix invocation of Previously Recorded from Recording Rules.
* ttvdb: Update to support new JSON API.
* Fix raspberry pi compile eror when using old header files
* Avoid busy looping in some cases in the scheduler when the time to
check on slaves that can be put to sleep has already passed.
* Restore SendAction operation, Fixes #12738
- Add python-future dependency
- Remove useless macros: frontend, backend
- Add Conflicts: otherproviders(): This is the LTS package. Provide the user
with a choice between versions
- Escape the usage of %{VERSION} when calling out to rpm
- Add the olddir directory for rotation
- Check python libraries
- Spec file cleanup

See Also

Package Description
perl-xmltv-0.5.69-lp150.1.2.noarch.rpm Perl modules for managing your TV viewing
perl-xmltv-0.5.69-lp150.1.3.noarch.rpm Perl modules for managing your TV viewing
php-mythtv-0.28.2+git20180529.ae037d012e-lp150.1.1.noarch.rpm PHP bindings for mythtv
pkg2zip-1.8-lp150.4.1.x86_64.rpm Decrypts PlayStation Vita pkg file and packages to zip archive
plasma5-radiotray-2016.12.18-lp150.1.3.aarch64.rpm Plasmoid to listen to online radio stations
plasma5-radiotray-2016.12.18-lp150.1.6.x86_64.rpm Plasmoid to listen to online radio stations
plasma5-radiotray-lang-2016.12.18-lp150.1.3.noarch.rpm Translations for package plasma5-radiotray
plasma5-radiotray-lang-2016.12.18-lp150.1.6.noarch.rpm Translations for package plasma5-radiotray
pmount-0.9.99-lp150.4.51.x86_64.rpm Mount removable devices as normal user
pmount-lang-0.9.99-lp150.4.51.noarch.rpm Translations for package pmount
pms-0.42.20160131.fcc4704-lp150.2.2.aarch64.rpm Curses Client for the Music Player Daemon
pms-0.42.20160131.fcc4704-lp150.2.2.x86_64.rpm Curses Client for the Music Player Daemon
pogo-0.8-lp150.2.1.noarch.rpm Simple Audio Player
polyglot-1.4.70b-lp150.1.34.x86_64.rpm A Xboard/Winboard protocol to UCI protocol adapter
ppsspp-1.0.1-lp150.4.101.x86_64.rpm A Fast and Portable High-Level PSP Emulator
Advertisement
Advertisement