gostcrypt-1.3-lp150.2.21.x86_64.rpm


Advertisement

Description

gostcrypt - Free Open-Source Disk Encryption Software

Property Value
Distribution openSUSE Leap 15.0
Repository Packman all
Package filename gostcrypt-1.3-lp150.2.21.x86_64.rpm
Package name gostcrypt
Package version 1.3
Package release lp150.2.21
Package architecture x86_64
Package type rpm
Category Productivity/Security
Homepage http://www.gostcrypt.org
License TrueCrypt Collective License and GPL-3.0
Maintainer -
Download size 2.73 MB
Installed size 4.98 MB
The Gostcrypt project has been launched at the end of 2013 as fork of the
(late) Truecrypt project.
Snowden's leaks have made clear more than ever that the massive use of
encryption by citizens must become a reality. This is possible only if
there is a vast, rich offer of trusted, open source products like
Truecrypt, with the strong support of the hacker community. However, at
that time we did not foresee the unprecedented upheaval of terrible shock
with the recent Truecrypt disappearance.
More than ever we all need more and more projects to replace it. Gostcrypt
is one among (we hope) many others.
The variety and richness of encryption solutions is THE solution.

Alternatives

Package Version Architecture Repository
gostcrypt-1.3-lp150.2.4.aarch64.rpm 1.3 aarch64 Packman
gostcrypt - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libfuse.so.2()(64bit) -
libfuse.so.2(FUSE_2.6)(64bit) -
libfuse.so.2(FUSE_2.8)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libwx_baseu-2.8.so.0()(64bit) -
libwx_baseu-2.8.so.0(WXU_2.8)(64bit) -
libwx_gtk2u_adv-2.8.so.0()(64bit) -
libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) -
libwx_gtk2u_core-2.8.so.0()(64bit) -
libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) -
libwx_gtk2u_core-2_8-0-compat-lib-wxcontainer -

Provides

Name Value
application() -
application(gostcrypt.desktop) -
gostcrypt = 1.3-lp150.2.21
gostcrypt(x86-64) = 1.3-lp150.2.21

Download

Type URL
Mirror packman.inode.at
Binary Package gostcrypt-1.3-lp150.2.21.x86_64.rpm
Source Package gostcrypt-1.3-lp150.2.21.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_15.0/ packman
  2. Install gostcrypt rpm package:
    # zypper install gostcrypt

Files

Path
/usr/bin/gostcrypt
/usr/share/applications/gostcrypt.desktop
/usr/share/doc/packages/gostcrypt/GostCryptUserGuide.pdf
/usr/share/doc/packages/gostcrypt/License.html
/usr/share/doc/packages/gostcrypt/License.txt
/usr/share/pixmaps/gostcrypt.xpm

Changelog

2016-01-23 - antoine.belvire@laposte.net
- Update to 1.3:
* Add Grasshopper algorithm
* Fix some bugs
* Attention: containers from 1.0 are not compatible with 1.3, you
have to create new containers and transfer your data to them.
- Remove gostcrypt-1.0-long-long-32bit.patch (upstreamed)
- Add gostcrypt-1.3-fix-inline-warnings.patch
2015-12-10 - antoine.belvire@laposte.net
- Add gostcrypt-1.0-fix-abi-gcc5.patch:
* Fix the Fuse "invalid characters" error when trying to mount
an encrypted file on Tumbleweed
2015-10-23 - antoine.belvire@laposte.net
- Improve spec file:
* Change copyright owner (now Packman Team)
* Add calls to desktop_database_{post,postun} macros
* Add calls to icon_theme_cache_{post,postun} macros
2015-04-02 - antoine.belvire@laposte.net
- Provide RPM compatibility with Fedora
* add conditionals in spec file
* add .desktop file as source instead of creating it with
%suse_update_desktop_file --create
2015-01-20 - antoine.belvire@laposte.net
- Clean spec file
2015-01-18 - antoine.belvire@laposte.net
- Add "Requires: libwx_gtk2u_core-2_8-0-compat-lib-wxcontainer" to
spec file in order to solve some installation problems
2015-01-16 - antoine.belvire@laposte.net
- New source file with pkcs included (no version change by upstream
though)
- Add gostcrypt-1.0-long-long-32bit.patch: fix compilation for i586
(change unsigned long into unsigned long long in Crypto/Stribog.c)
- Add GostCryptUserGuide.pdf to documentation
2015-01-09 - antoine.belvire@laposte.net
- Create rpm for GostCrypt 1.0

See Also

Package Description
gpac-0.8.0-lp150.1.1.aarch64.rpm A multimedia framework covering MPEG-4, VRML/X3D and SVG
gpac-0.8.0-lp150.1.1.armv7hl.rpm A multimedia framework covering MPEG-4, VRML/X3D and SVG
gpac-0.8.0-lp150.1.1.x86_64.rpm A multimedia framework covering MPEG-4, VRML/X3D and SVG
gpodder-2.20.3-lp150.2.3.noarch.rpm A free podcast aggregator for Linux
gpodder-2.20.3-lp150.2.9.noarch.rpm A free podcast aggregator for Linux
gpodder3-3.9.6-lp150.1.3.noarch.rpm A free podcast aggregator for Linux
gpodder3-3.9.6-lp150.1.9.noarch.rpm A free podcast aggregator for Linux
grip-3.10.1-lp150.1.1.aarch64.rpm An Audio CD Ripping Application
grip-3.10.1-lp150.1.1.armv7hl.rpm An Audio CD Ripping Application
grip-3.10.1-lp150.1.6.x86_64.rpm An Audio CD Ripping Application
grip-lang-3.10.1-lp150.1.1.noarch.rpm Translations for package grip
grip-lang-3.10.1-lp150.1.6.noarch.rpm Translations for package grip
groovebasin-1.5.1-lp150.5.152.x86_64.rpm Music player server with a web-based user interface
groovebasin-1.5.1-lp150.5.40.aarch64.rpm Music player server with a web-based user interface
groovebasin-1.5.1-lp150.5.49.armv7hl.rpm Music player server with a web-based user interface
Advertisement
Advertisement