MLDonkey-gui-3.1.6-lp150.1.83.x86_64.rpm


Advertisement

Description

MLDonkey-gui - Gtk2 GUI for mldonkey

Property Value
Distribution openSUSE Leap 15.0
Repository Packman all
Package filename MLDonkey-gui-3.1.6-lp150.1.83.x86_64.rpm
Package name MLDonkey-gui
Package version 3.1.6
Package release lp150.1.83
Package architecture x86_64
Package type rpm
Category Productivity/Networking/Other
Homepage http://mldonkey.sourceforge.net/Main_Page
License Other License(s), see package, GPL-2.0+
Maintainer -
Download size 6.48 MB
Installed size 28.88 MB
mldonkey gtk2 GUI for mldonkey.
This is the "new gui 2"

Alternatives

Package Version Architecture Repository
MLDonkey-gui-3.1.6-lp150.1.9.aarch64.rpm 3.1.6 aarch64 Packman
MLDonkey-gui - - -

Requires

Name Value
MLDonkey = 3.1.6
libX11.so.6()(64bit) -
libbz2.so.1()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.10)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libc.so.6(GLIBC_2.9)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgd.so.3()(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libmagic.so.1()(64bit) -
libpango-1.0.so.0()(64bit) -
libpng16.so.16()(64bit) -
libpng16.so.16(PNG16_0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
librsvg-2.so.2()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
MLDonkey-gui = 3.1.6-lp150.1.83
MLDonkey-gui(x86-64) = 3.1.6-lp150.1.83

Download

Type URL
Mirror packman.inode.at
Binary Package MLDonkey-gui-3.1.6-lp150.1.83.x86_64.rpm
Source Package MLDonkey-3.1.6-lp150.1.83.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_15.0/ packman
  2. Install MLDonkey-gui rpm package:
    # zypper install MLDonkey-gui

Files

Path
/usr/bin/mlbt+gui
/usr/bin/mldc+gui
/usr/bin/mldonkey+gui
/usr/bin/mldonkey_gui
/usr/bin/mlgnut+gui
/usr/bin/mlgui
/usr/bin/mlnet+gui
/usr/bin/mlslsk+gui

Changelog

2018-04-20 - aloisio@gmx.com
- Update to version 3.1.6
* BT: better diagnostics of wrong udp tracker reply
* BT/DHT: update public router addresses
* fix buffer overflows in DNS resolution
* update default blocklist url (Closes #4)
* fix build with OCaml 4.02 (closes #6)
* extend command conditions (pause, resume, priority) (ref #9)
* Fix compilation errors with gcc5 (closes #12)
(Christopher Meng)
* BT: relaxed parsing of bencoded numbers
* fix build with libminiupnpc 1.9 (closes #13)
* escape filename based on filesystem, not OS type
* Fix compilation with OCaml 4.03.0 (Bastien Dejean)
- Dropped mldonkey-fix-ocaml_unterminated_string.patch (merged
upstream)
- Dropped mldonkey-stdint.patch, mldonkey-caml_is_printable.patch,
mldonkey-zip.patch and mldonkey-ClientFound.patch
(relevant code was significantly refactored)
- New source URL
- Spec cleanup
2017-01-18 - olaf@aepfle.de
- Fix build with ocaml 4.03
2015-12-01 - aloisio@gmx.com
- Added mldonkey-fix-ocaml-unterminated-string.patch to
address build problem with OCaml 4.02.
2014-04-11 - i@margueirte.su
- update to 3.1.5
* Revert patch #8328 to fix GTK2 gui's compilation (ygrek)
2012-08-23 - seife+obs@b1-systems.com
- update to 3.1.3
- remove mldonkey-fix_missing_return_in_non_void_functions.patch,
instead just remove pentium asm optimization
* note: the code the compiler complains about is probably
correct albeit obscure (asm code that puts the return code
onto the stack), the easiest fix is to disable it.
2012-08-16 - seife+obs@b1-systems.com
- fix build for 12.2 (add --disable-option-checking to configure)
2012-05-29 - pascal.bleser@opensuse.org
- update to 3.1.2:
* minor fixes
2012-04-14 - pascal.bleser@opensuse.org
- update to 3.1.1:
* update options description of allow_local_network
* DC: show hashing progress in dcinfo
* DC: fix ownership for downloads by non-admin users
* less allocations
2012-01-01 - pascal.bleser@opensuse.org
- add mldonkey-link_against_libpng.patch to fix build on >= 12.1, as upstream
forgot to link against libpng when using libgd
2012-01-01 - pascal.bleser@opensuse.org
- update to 3.1.0:
* BT/DHT: fix logging in tools/bt_dht_node.ml
* http: better error reporting
* BT: better UI for subfile selection
* do not reload page when toggling subfiles
* http: fix XSS in error handler
* BT/DHT: show stats, choose random port
* options: disable Overnet by default and remove contact.dat from web_infos
* mail: multiple mail addresses for admin
* diskinfo: recognize BTRFS
* BT/DHT: fix logging
* BT/DHT: make token more robust against broken nodes
* HTML: mark not saved values in options
* BT: stop asking users to submit unknown client ids
* GTK2 GUI: fix too obtrusive splash window
* BT: open DHT port by UPnP
* BT: support for partial download
* partial files are not committed, location in temp dir is shown so that
users can easily locate downloaded subfiles
* BT: DHT support
- new options BT-dht_port, BT-use_trackers, BT-dht_bootstrap_nodes
- new verbosity level "dht"

See Also

Package Description
MP4Tools-3.6.1-lp150.2.1.aarch64.rpm Collection of free tools to manipulate MP4 files
MP4Tools-3.6.1-lp150.2.1.armv7hl.rpm Collection of free tools to manipulate MP4 files
MP4Tools-3.6.1-lp150.2.6.x86_64.rpm Collection of free tools to manipulate MP4 files
MP4Tools-lang-3.6.1-lp150.2.1.noarch.rpm Translations for package MP4Tools
MP4Tools-lang-3.6.1-lp150.2.6.noarch.rpm Translations for package MP4Tools
MPlayer-1.2.r38117-lp150.2.2.aarch64.rpm Multimedia Player
MPlayer-1.2.r38117-lp150.2.2.x86_64.rpm Multimedia Player
MPlayer-doc-1.2.r38117-lp150.2.2.aarch64.rpm Multimedia Player
MPlayer-doc-1.2.r38117-lp150.2.2.x86_64.rpm Multimedia Player
OpenOctaveMidi-2011.3.1-lp150.5.10.x86_64.rpm Open Octave Studio
OpenOctaveMidi-lang-2011.3.1-lp150.5.10.noarch.rpm Translations for package OpenOctaveMidi
OpenOctaveMidi-unstable-2012.1.0+20120403-lp150.4.10.x86_64.rpm Open Octave Studio
OpenOctaveMidi-unstable-lang-2012.1.0+20120403-lp150.4.10.noarch.rpm Languages for package OpenOctaveMidi-unstable
Osmo4-0.8.0-lp150.1.1.aarch64.rpm MPEG-4 Media player based on gpac
Osmo4-0.8.0-lp150.1.1.armv7hl.rpm MPEG-4 Media player based on gpac
Advertisement
Advertisement