ffmpeg-4-libavformat-devel-4.0.1-lp150.3.1.x86_64.rpm


Advertisement

Description

ffmpeg-4-libavformat-devel - Development files for FFmpeg's stream format library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Update Test all
Package filename ffmpeg-4-libavformat-devel-4.0.1-lp150.3.1.x86_64.rpm
Package name ffmpeg-4-libavformat-devel
Package version 4.0.1
Package release lp150.3.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://ffmpeg.org/
License LGPL-2.1-or-later AND GPL-2.0-or-later
Maintainer -
Download size 85.39 KB
Installed size 151.86 KB
The libavformat library provides a generic framework for multiplexing
and demultiplexing (muxing and demuxing) audio, video and subtitle
streams. It encompasses multiple muxers and demuxers for multimedia
container formats.
This subpackage contains the headers for FFmpeg libavformat.

Alternatives

Package Version Architecture Repository
ffmpeg-4-libavformat-devel-4.1.3-lp150.66.1.x86_64.rpm 4.1.3 x86_64 Multimedia Libs
ffmpeg-4-libavformat-devel-4.0.2-lp150.19.6.x86_64.rpm 4.0.2 x86_64 Packman
ffmpeg-4-libavformat-devel-4.0.2-lp150.19.5.armv7hl.rpm 4.0.2 armv7hl Packman
ffmpeg-4-libavformat-devel-4.0.2-lp150.19.5.aarch64.rpm 4.0.2 aarch64 Packman
ffmpeg-4-libavformat-devel-4.0.2-lp150.13.1.x86_64.rpm 4.0.2 x86_64 openSUSE Update Oss
ffmpeg-4-libavformat-devel-4.0.1-lp150.10.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
ffmpeg-4-libavformat-devel-4.0.1-lp150.7.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
ffmpeg-4-libavformat-devel-4.0.1-lp150.2.2.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
ffmpeg-4-libavformat-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
ffmpeg-4-libavcodec-devel = 4.0.1-lp150.3.1
ffmpeg-4-libavutil-devel = 4.0.1-lp150.3.1
ffmpeg-4-libswresample-devel = 4.0.1-lp150.3.1
libavformat58 = 4.0.1-lp150.3.1
pkgconfig(libavcodec) >= 58.18.100
pkgconfig(libavutil) >= 56.14.100
pkgconfig(libswresample) >= 3.1.100

Provides

Name Value
ffmpeg-4-libavformat-devel = 4.0.1-lp150.3.1
ffmpeg-4-libavformat-devel(x86-64) = 4.0.1-lp150.3.1
libavformat-devel = 4.0.1-lp150.3.1
pkgconfig(libavformat) = 58.12.100

Conflicts

Name Value
ffmpeg-private-devel < 4
ffmpeg-private-devel >= 5
libavcodec-devel < 4
libavcodec-devel >= 5
libavdevice-devel >= 5
libavdevice-devel < 4
libavfilter-devel < 4
libavfilter-devel >= 5
libavformat-devel -
libavformat-devel < 4
libavformat-devel >= 5
libavresample-devel < 4
libavresample-devel >= 5
libavutil-devel < 4
libavutil-devel >= 5
libpostproc-devel < 4
libpostproc-devel >= 5
libswresample-devel < 4
libswresample-devel >= 5
libswscale-devel < 4
libswscale-devel >= 5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ffmpeg-4-libavformat-devel-4.0.1-lp150.3.1.x86_64.rpm
Source Package ffmpeg-4-4.0.1-lp150.3.1.src.rpm

Install Howto

Install ffmpeg-4-libavformat-devel rpm package:

# zypper install ffmpeg-4-libavformat-devel

Files

Path
/usr/include/ffmpeg/
/usr/include/ffmpeg/libavformat/avformat.h
/usr/include/ffmpeg/libavformat/avio.h
/usr/include/ffmpeg/libavformat/version.h
/usr/lib64/libavformat.so
/usr/lib64/pkgconfig/libavformat.pc
/usr/share/man/man3/libavformat.3.gz

Changelog

2018-07-06 - tchvatal@suse.com
- Fix typo in swresample name
2018-07-04 - tchvatal@suse.com
- Conditionalize full build to be primary only on Leap15+
2018-07-03 - tchvatal@suse.com
- Add macros to allow conflicting with all other devel projects
to ensure we always install only one specific ffmpeg
2018-06-30 - tchvatal@suse.com
- Conditionalize the vidstab build to not pull it on old releases
- Conditionalize srt support to not pull it on older releases
- ------------------------------------------------------------------
2018-06-29 - 9+suse@cirno.systems
- Enable ffnvcodec when building with NVIDIA support
2018-06-29 - bjorn.lie@gmail.com
- Add pkgconfig(srt) BuildRequires and pass --enable-libsrt to
configure, enable srt support.
- Refresh patches with quilt:
* cve-2017-17555.diff
* ffmpeg-codec-choice.diff
* ffmpeg-libcdio_cdda-pkgconfig.patch
* ffmpeg-new-coder-errors.diff
2018-06-29 - 9+suse@cirno.systems
- Enable libxml2 (used by MPEG DASH demuxer)
2018-06-27 - jengelh@inai.de
- Update to new upstream release 4.0.1
* Fixed some integer overflows, undefined shifts, negative
shifts, division by 0, and a null pointer deref.
2018-06-18 - bjorn.lie@gmail.com
- Enable pkgconfig(vidstab) BuildRequires unconditionally, now
available in openSUSE.
2018-06-14 - tchvatal@suse.com
- Conditionalize openmpt build to be resolvable on Leap 42.3

See Also

Package Description
ffmpeg-4-libavresample-devel-4.0.1-lp150.3.1.x86_64.rpm Development files for libavresample as present in FFmpeg
ffmpeg-4-libavutil-devel-4.0.1-lp150.3.1.x86_64.rpm Development files for FFmpeg's utility library
ffmpeg-4-libpostproc-devel-4.0.1-lp150.3.1.x86_64.rpm Development files for the FFmpeg post-processing library
ffmpeg-4-libswresample-devel-4.0.1-lp150.3.1.x86_64.rpm Development files for the FFmpeg software resampling library
ffmpeg-4-libswscale-devel-4.0.1-lp150.3.1.x86_64.rpm Development files for FFmpeg's image scaling and colorspace library
ffmpeg-4-private-devel-4.0.1-lp150.3.1.x86_64.rpm Some FFmpeg private headers
fish3-3.0.0-lp150.2.1.x86_64.rpm The "friendly interactive shell"
fish3-devel-3.0.0-lp150.2.1.x86_64.rpm Devel files for the fish shell
freeradius-server-3.0.16-lp150.2.3.1.x86_64.rpm RADIUS Server
freeradius-server-devel-3.0.16-lp150.2.3.1.x86_64.rpm FreeRADIUS Development Files
freeradius-server-doc-3.0.16-lp150.2.3.1.x86_64.rpm FreeRADIUS Documentation
freeradius-server-krb5-3.0.16-lp150.2.3.1.x86_64.rpm Kerberos 5 support for freeradius
freeradius-server-ldap-3.0.16-lp150.2.3.1.x86_64.rpm LDAP support for freeradius
freeradius-server-libs-3.0.16-lp150.2.3.1.x86_64.rpm FreeRADIUS shared library
freeradius-server-mysql-3.0.16-lp150.2.3.1.x86_64.rpm MySQL support for freeradius
Advertisement
Advertisement