php7-posix-7.2.5-lp150.2.15.1.x86_64.rpm


Advertisement

Description

php7-posix - POSIX functions for PHP

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Update Oss all
Package filename php7-posix-7.2.5-lp150.2.15.1.x86_64.rpm
Package name php7-posix
Package version 7.2.5
Package release lp150.2.15.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/PHP
Homepage https://secure.php.net
License PHP-3.01
Maintainer -
Download size 67.21 KB
Installed size 35.06 KB
This module contains an interface to those functions defined in the
IEEE 1003.1 (POSIX.1) standards document which are not accessible
through other means.

Alternatives

Package Version Architecture Repository
php7-posix-7.3.5-lp150.199.1.x86_64.rpm 7.3.5 x86_64 Apache Modules
php7-posix-7.2.5-lp150.2.12.1.x86_64.rpm 7.2.5 x86_64 openSUSE Update Oss
php7-posix-7.2.5-lp150.2.9.1.x86_64.rpm 7.2.5 x86_64 openSUSE Update Oss
php7-posix-7.2.5-lp150.2.6.1.x86_64.rpm 7.2.5 x86_64 openSUSE Update Oss
php7-posix-7.2.5-lp150.2.3.1.x86_64.rpm 7.2.5 x86_64 openSUSE Update Oss
php7-posix-7.2.5-lp150.1.7.x86_64.rpm 7.2.5 x86_64 openSUSE Oss
php7-posix - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
php7 = 7.2.5

Provides

Name Value
config(php7-posix) = 7.2.5-lp150.2.15.1
php-posix = 7.2.5
php7-posix = 7.2.5-lp150.2.15.1
php7-posix(x86-64) = 7.2.5-lp150.2.15.1

Obsoletes

Name Value
php5-posix -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package php7-posix-7.2.5-lp150.2.15.1.x86_64.rpm
Source Package php7-7.2.5-lp150.2.15.1.src.rpm

Install Howto

Install php7-posix rpm package:

# zypper install php7-posix

Files

Path
/etc/php7/conf.d/posix.ini
/usr/lib64/php7/extensions/posix.so

Changelog

2018-09-19 - Petr Gajdos <pgajdos@suse.com>
- security update
* CVE-2018-17082 [bsc#1108753]
+ php-CVE-2018-17082.patch
2018-09-17 - Petr Gajdos <pgajdos@suse.com>
- reenable php7-dba support of Berkeley DB [bsc#1108554]
2018-08-28 - pgajdos@suse.com
- align patch names:
php7-CVE-2018-14851.patch -> php-CVE-2018-14851.patch
php7-CVE-2017-9120.patch -> php-CVE-2017-9120.patch
php7-CVE-2018-1000222.patch -> php-CVE-2018-1000222.patch
2018-08-27 - pgajdos@suse.com
- security update:
* CVE-2018-1000222 [bsc#1105434]
+ php-CVE-2018-1000222.patch
2018-08-04 - pgajdos@suse.com
- security update
* CVE-2018-14851 [bsc#1103659]
+ php-CVE-2018-14851.patch
* CVE-2017-9120 [bsc#1103661]
+ php-CVE-2017-9120.patch
2018-06-26 - pgajdos@suse.com
- security update
* CVE-2018-12882 [bsc#1099098]
+ php-CVE-2018-12882.patch
2018-05-15 - pgajdos@suse.com
- main package requires wwwrun:www user [bsc#1093025]
2018-05-10 - pgajdos@suse.com
- better workaround for [bsc#1089487]: build mod_phpN.so
instead of libphpN.so
2018-05-09 - pgajdos@suse.com
- rename freetype-pkgconfig.patch to php7-freetype-pkgconfig.patch
to align with the rest of patch names
2018-05-07 - idonmez@suse.com
- Add freetype-pkgconfig.patch to fix build with new Freetype:
use pkg-config to find Freetype libraries

See Also

Package Description
php7-readline-7.2.5-lp150.2.12.1.x86_64.rpm PHP7 readline extension
php7-readline-7.2.5-lp150.2.15.1.x86_64.rpm PHP7 readline extension
php7-readline-7.2.5-lp150.2.3.1.x86_64.rpm PHP7 readline extension
php7-readline-7.2.5-lp150.2.6.1.x86_64.rpm PHP7 readline extension
php7-readline-7.2.5-lp150.2.9.1.x86_64.rpm PHP7 readline extension
php7-shmop-7.2.5-lp150.2.12.1.x86_64.rpm Alternate, low-level shared memory implementation for PHP
php7-shmop-7.2.5-lp150.2.15.1.x86_64.rpm Alternate, low-level shared memory implementation for PHP
php7-shmop-7.2.5-lp150.2.3.1.x86_64.rpm Alternate, low-level shared memory implementation for PHP
php7-shmop-7.2.5-lp150.2.6.1.x86_64.rpm Alternate, low-level shared memory implementation for PHP
php7-shmop-7.2.5-lp150.2.9.1.x86_64.rpm Alternate, low-level shared memory implementation for PHP
php7-snmp-7.2.5-lp150.2.12.1.x86_64.rpm SNMP extension for PHP
php7-snmp-7.2.5-lp150.2.15.1.x86_64.rpm SNMP extension for PHP
php7-snmp-7.2.5-lp150.2.3.1.x86_64.rpm SNMP extension for PHP
php7-snmp-7.2.5-lp150.2.6.1.x86_64.rpm SNMP extension for PHP
php7-snmp-7.2.5-lp150.2.9.1.x86_64.rpm SNMP extension for PHP
Advertisement
Advertisement