pam-32bit-1.3.0-lp150.5.6.1.x86_64.rpm


Advertisement

Description

pam-32bit - A Security Tool that Provides Authentication for Applications

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Update Oss all
Package filename pam-32bit-1.3.0-lp150.5.6.1.x86_64.rpm
Package name pam-32bit
Package version 1.3.0
Package release lp150.5.6.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.linux-pam.org/
License GPL-2.0+ or BSD-3-Clause
Maintainer -
Download size 196.91 KB
Installed size 645.67 KB
PAM (Pluggable Authentication Modules) is a system security tool that
allows system administrators to set authentication policies without
having to recompile programs that do authentication.

Alternatives

Package Version Architecture Repository
pam-32bit-1.3.0-lp150.5.3.1.x86_64.rpm 1.3.0 x86_64 openSUSE Update Oss
pam-32bit-1.3.0-lp150.4.6.x86_64.rpm 1.3.0 x86_64 openSUSE Oss
pam-32bit - - -

Requires

Name Value
libaudit.so.1 -
libc.so.6(GLIBC_2.15) -
libcrack.so.2 -
libcrypt.so.1 -
libcrypt.so.1(GLIBC_2.0) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libnsl.so.2 -
libnsl.so.2(LIBNSL_1.0) -
libselinux.so.1 -
libtirpc.so.3 -
libtirpc.so.3(TIRPC_0.3.0) -
libutil.so.1 -
libutil.so.1(GLIBC_2.0) -

Provides

Name Value
libpam.so.0 -
libpam.so.0(LIBPAM_1.0) -
libpam.so.0(LIBPAM_EXTENSION_1.0) -
libpam.so.0(LIBPAM_EXTENSION_1.1) -
libpam.so.0(LIBPAM_EXTENSION_1.1.1) -
libpam.so.0(LIBPAM_MODUTIL_1.0) -
libpam.so.0(LIBPAM_MODUTIL_1.1) -
libpam.so.0(LIBPAM_MODUTIL_1.1.3) -
libpam.so.0(LIBPAM_MODUTIL_1.1.9) -
libpam_misc.so.0 -
libpam_misc.so.0(LIBPAM_MISC_1.0) -
libpamc.so.0 -
libpamc.so.0(LIBPAMC_1.0) -
pam-32bit = 1.3.0-lp150.5.6.1
pam-32bit(x86-32) = 1.3.0-lp150.5.6.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package pam-32bit-1.3.0-lp150.5.6.1.x86_64.rpm
Source Package pam-1.3.0-lp150.5.6.1.src.rpm

Install Howto

Install pam-32bit rpm package:

# zypper install pam-32bit

Files

Path
/lib/libpam.so.0
/lib/libpam.so.0.84.2
/lib/libpam_misc.so.0
/lib/libpam_misc.so.0.82.1
/lib/libpamc.so.0
/lib/libpamc.so.0.82.1
/lib/security/pam_access.so
/lib/security/pam_cracklib.so
/lib/security/pam_debug.so
/lib/security/pam_deny.so
/lib/security/pam_echo.so
/lib/security/pam_env.so
/lib/security/pam_exec.so
/lib/security/pam_faildelay.so
/lib/security/pam_filter.so
/lib/security/pam_ftp.so
/lib/security/pam_group.so
/lib/security/pam_issue.so
/lib/security/pam_keyinit.so
/lib/security/pam_lastlog.so
/lib/security/pam_limits.so
/lib/security/pam_listfile.so
/lib/security/pam_localuser.so
/lib/security/pam_loginuid.so
/lib/security/pam_mail.so
/lib/security/pam_mkhomedir.so
/lib/security/pam_motd.so
/lib/security/pam_namespace.so
/lib/security/pam_nologin.so
/lib/security/pam_permit.so
/lib/security/pam_pwhistory.so
/lib/security/pam_rhosts.so
/lib/security/pam_rootok.so
/lib/security/pam_securetty.so
/lib/security/pam_selinux.so
/lib/security/pam_sepermit.so
/lib/security/pam_shells.so
/lib/security/pam_stress.so
/lib/security/pam_succeed_if.so
/lib/security/pam_tally2.so
/lib/security/pam_time.so
/lib/security/pam_timestamp.so
/lib/security/pam_tty_audit.so
/lib/security/pam_umask.so
/lib/security/pam_unix.so
/lib/security/pam_unix_acct.so
/lib/security/pam_unix_auth.so
/lib/security/pam_unix_passwd.so
/lib/security/pam_unix_session.so
/lib/security/pam_warn.so
/lib/security/pam_wheel.so
/lib/security/pam_xauth.so

Changelog

2018-11-19 - josef.moellers@suse.com
- When comparing an incoming IP address with an entry in
access.conf that only specified a single host (ie no netmask),
the incoming IP address was used rather than the IP address from
access.conf, effectively comparing the incoming address with
itself.  (Also fixed a small typo while I was at it)
[bsc#1115640, use-correct-IP-address.patch, CVE-2018-17953]
2018-10-11 - josef.moellers@suse.com
- Remove limits for nproc from /etc/security/limits.conf
ie remove pam-limit-nproc.patch
[bsc#1110700, pam-limit-nproc.patch]
2018-05-03 - josef.moellers@suse.com
- pam_umask.8 needed to be patched as well.
[bsc#1089884, pam-fix-config-order-in-manpage.patch]
2018-05-02 - josef.moellers@suse.com
- Changed order of configuration files to reflect actual code.
[bsc#1089884, pam-fix-config-order-in-manpage.patch]
2018-02-22 - fvogt@suse.com
- Use %license (boo#1082318)
2017-10-12 - schwab@suse.de
- Prerequire group(shadow), user(root)
2017-01-27 - josef.moellers@suse.com
- Allow symbolic hostnames in access.conf file.
[pam-hostnames-in-access_conf.patch, boo#1019866]
2016-12-08 - josef.moellers@suse.com
- Increased nproc limits for non-privileged users to 4069/16384.
Removed limits for "root".
[pam-limit-nproc.patch, bsc#1012494, bsc#1013706]
2016-07-31 - develop7@develop7.info
- pam-limit-nproc.patch: increased process limit to help
Chrome/Chromuim users with really lots of tabs. New limit gets
closer to UserTasksMax parameter in logind.conf
2016-07-28 - kukuk@suse.de
- Add doc directory to filelist.

See Also

Package Description
pam-devel-1.3.0-lp150.5.3.1.x86_64.rpm Include Files and Libraries for PAM-Development
pam-devel-1.3.0-lp150.5.6.1.x86_64.rpm Include Files and Libraries for PAM-Development
pam-devel-32bit-1.3.0-lp150.5.3.1.x86_64.rpm Include Files and Libraries for PAM-Development
pam-devel-32bit-1.3.0-lp150.5.6.1.x86_64.rpm Include Files and Libraries for PAM-Development
pam-doc-1.3.0-lp150.5.3.1.noarch.rpm Documentation for Pluggable Authentication Modules
pam-doc-1.3.0-lp150.5.6.1.noarch.rpm Documentation for Pluggable Authentication Modules
pam_apparmor-2.12-lp150.6.3.1.x86_64.rpm PAM module for AppArmor change_hat
pam_apparmor-2.12-lp150.6.6.1.x86_64.rpm PAM module for AppArmor change_hat
pam_apparmor-2.12.2-lp150.6.11.2.x86_64.rpm PAM module for AppArmor change_hat
pam_apparmor-2.12.2-lp150.6.14.1.x86_64.rpm PAM module for AppArmor change_hat
pam_apparmor-32bit-2.12-lp150.6.3.1.x86_64.rpm PAM module for AppArmor change_hat
pam_apparmor-32bit-2.12-lp150.6.6.1.x86_64.rpm PAM module for AppArmor change_hat
pam_apparmor-32bit-2.12.2-lp150.6.11.2.x86_64.rpm PAM module for AppArmor change_hat
pam_apparmor-32bit-2.12.2-lp150.6.14.1.x86_64.rpm PAM module for AppArmor change_hat
pam_cgfs-3.1.0-lp150.2.10.1.x86_64.rpm PAM module to provide unprivileged cgroupfs
Advertisement
Advertisement