libpango-1_0-0-1.40.14-lp150.2.3.1.x86_64.rpm


Advertisement

Description

libpango-1_0-0 - Library for Layout and Rendering of Text

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Update Oss all
Package name libpango-1_0-0
Package version 1.40.14
Package release lp150.2.3.1
Package architecture x86_64
Package type rpm
Installed size 520.51 KB
Download size 202.69 KB
Official Mirror widehat.opensuse.org
Pango is a library for layout and rendering of text, with an emphasis
on internationalization. It can be used anywhere that text layout
is needed.
Pango forms the core of text and font handling for GTK+.

Alternatives

Package Version Architecture Repository
libpango-1_0-0-1.40.14-lp150.1.15.x86_64.rpm 1.40.14 x86_64 openSUSE Oss
libpango-1_0-0 - - -

Requires

Name Value
/sbin/ldconfig -
libX11.so.6()(64bit) -
libXft.so.2()(64bit) -
libXrender.so.1()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libcairo.so.2()(64bit) -
libfontconfig.so.1()(64bit) -
libfreetype.so.6()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libharfbuzz.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libthai.so.0()(64bit) -
libthai.so.0(LIBTHAI_0.1)(64bit) -

Provides

Name Value
libpango-1.0.so.0()(64bit) -
libpango-1_0-0 = 1.40.14-lp150.2.3.1
libpango-1_0-0(x86-64) = 1.40.14-lp150.2.3.1
libpangocairo-1.0.so.0()(64bit) -
libpangoft2-1.0.so.0()(64bit) -
libpangoxft-1.0.so.0()(64bit) -
pango = 1.40.14
pango-modules = 1.40.14

Obsoletes

Name Value
pango < 1.40.14
pango-modules < 1.40.14

Download

Type URL
Binary Package libpango-1_0-0-1.40.14-lp150.2.3.1.x86_64.rpm
Source Package pango-1.40.14-lp150.2.3.1.src.rpm

Install Howto

Install libpango-1_0-0 rpm package:

# zypper install libpango-1_0-0

Files

Path
/usr/lib64/libpango-1.0.so.0
/usr/lib64/libpango-1.0.so.0.4000.13
/usr/lib64/libpangocairo-1.0.so.0
/usr/lib64/libpangocairo-1.0.so.0.4000.13
/usr/lib64/libpangoft2-1.0.so.0
/usr/lib64/libpangoft2-1.0.so.0.4000.13
/usr/lib64/libpangoxft-1.0.so.0
/usr/lib64/libpangoxft-1.0.so.0.4000.13
/usr/share/licenses/libpango-1_0-0/COPYING

Changelog

2018-08-18 - sreeves@suse.com
- Add pango-emoji-bsc1103877.patch: Fix denial of service
when parsing emoji (bsc#1103877, CVE-2018-15120)
2017-11-17 - luc14n0@linuxmail.org
- Update to version 1.40.14:
+ Fix char break problem introduced in 1.40.13 (bgo#789625).
+ Add tests for char breaking.
2017-10-28 - badshah400@gmail.com
- Update to version 1.40.13:
+ Some performance improvements (bgo#788643).
+ Update pango_default_break for line breaks (bgo#788115).
+ Fix an introspection warning (bgo#781857).
2017-09-04 - zaitor@opensuse.org
- Update to version 1.40.12:
+ Fix pango_default_break for sentence start/end (bgo#785978).
+ Fix multilib issue in pango-enum-types.h (bgo#786887).
- Drop pango-fix-default-break-function.patch: Fixed upstream.
2017-08-31 - pmonrealgonzalez@suse.com
- Add pango-fix-default-break-function.patch: Fix
pango_default_break function for sentence start/end (bgo#785978).
2017-08-19 - zaitor@opensuse.org
- Update to version 1.40.11:
+ Fix backspacing for more Emoji sequences.
+ Make tests run faster.
2017-08-16 - zaitor@opensuse.org
- Update to version 1.40.10:
+ Update Emoji data to version 5.
+ Apply gravity across spans in markup (bgo#784243).
+ Support variation selectors for shaping.
+ CoreText: Rely on CGFont for scaling (bgo#782393).
+ Fix grapheme breaks and backspacing for Emoji.
- Add meson BuildRequires and switch autotools macros configure,
make and makeinstall to meson, meson_build and meson_install
following upstream switch to Meson build system.
- Add help2man BuildRequires, needed to build manpages.
- Minor spec file cleanup.
2017-08-09 - zaitor@opensuse.org
- Update to version 1.40.9:
+ Build and dist fixes.
+ Fix build on Windows with MSVC (bgo#783274).
2017-08-07 - zaitor@opensuse.org
- Update to version 1.40.8:
+ Support emoji sequences in boundary determination.
+ Choose emoji font for color emoji.
2017-07-18 - zaitor@opensuse.org
- Update to version 1.40.7:
+ Some fixes for meson build support.
+ Don't change fonts for variation selectors (bgo#781123).
+ Fix some bugs in the libthai glue layer.
+ Pass text along when calling into cairo (bgo#784394).

See Also

Package Description
libpango-1_0-0-32bit-1.40.14-lp150.2.3.1.x86_64.rpm Library for Layout and Rendering of Text
libply-boot-client4-0.9.3+git20181016.a588b3f-lp150.3.3.1.x86_64.rpm Plymouth core library
libply-splash-core4-0.9.3+git20181016.a588b3f-lp150.3.3.1.x86_64.rpm Plymouth core library
libply-splash-graphics4-0.9.3+git20181016.a588b3f-lp150.3.3.1.x86_64.rpm Plymouth graphics libraries
libply4-0.9.3+git20181016.a588b3f-lp150.3.3.1.x86_64.rpm Plymouth core library
libpmi0-17.11.7-lp150.5.7.1.x86_64.rpm Libraries for SLURM
libpmi0-17.11.9-lp150.5.11.1.x86_64.rpm Libraries for SLURM
libpmi0-17.11.9-lp150.5.15.1.x86_64.rpm Libraries for SLURM
libpolkit0-0.114-lp150.2.3.1.x86_64.rpm PolicyKit Authorization Framework -- Libraries
libpolkit0-32bit-0.114-lp150.2.3.1.x86_64.rpm PolicyKit Authorization Framework -- Libraries
libpostproc54-3.4.4-lp150.3.1.x86_64.rpm FFmpeg post-processing library
libpostproc54-3.4.4-lp150.6.1.x86_64.rpm FFmpeg post-processing library
libpostproc55-4.0.1-lp150.10.1.x86_64.rpm FFmpeg post-processing library
libpostproc55-4.0.1-lp150.2.2.x86_64.rpm FFmpeg post-processing library
libpostproc55-4.0.1-lp150.7.1.x86_64.rpm FFmpeg post-processing library
Advertisement
Advertisement