libobjc4-7.4.0+r266845-lp150.5.3.x86_64.rpm


Advertisement

Description

libobjc4 - Library for the GNU Objective C Compiler

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Update Oss all
Package filename libobjc4-7.4.0+r266845-lp150.5.3.x86_64.rpm
Package name libobjc4
Package version 7.4.0+r266845
Package release lp150.5.3
Package architecture x86_64
Package type rpm
Category Development/Libraries/Other
Homepage http://gcc.gnu.org/
License GPL-3.0-with-GCC-exception
Maintainer -
Download size 55.31 KB
Installed size 114.03 KB
The library for the GNU Objective C compiler.

Alternatives

Package Version Architecture Repository
libobjc4-7.4.1+r270528-lp150.9.2.x86_64.rpm 7.4.1+r270528 x86_64 openSUSE Update Test
libobjc4-7.3.1+r258812-lp150.2.10.x86_64.rpm 7.3.1+r258812 x86_64 openSUSE Oss
libobjc4 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -

Provides

Name Value
libobjc.so.4()(64bit) -
libobjc4 = 7.4.0+r266845-lp150.5.3
libobjc4(x86-64) = 7.4.0+r266845-lp150.5.3

Conflicts

Name Value
libobjc4 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libobjc4-7.4.0+r266845-lp150.5.3.x86_64.rpm
Source Package gcc7-7.4.0+r266845-lp150.5.3.src.rpm

Install Howto

Install libobjc4 rpm package:

# zypper install libobjc4

Files

Path
/usr/lib64/libobjc.so.4
/usr/lib64/libobjc.so.4.0.0

Changelog

2018-12-06 - rguenther@suse.com
- Update to GCC 7.4 release.
- Fix AVR configuration to not use __cxa_atexit or libstdc++ headers.
Point to /usr/avr/sys-root/include as system header include directory.
2018-08-17 - rguenther@suse.com
- Update to gcc-7-branch head (r263609).
* Includes fix for build with ISL 0.20.
2018-06-29 - rguenther@suse.com
- Update to gcc-7-branch head (r262243).
* Pulls fix for libcpp lexing bug on ppc64le manifesting during
build with gcc8.  [bnc#1099119]
* Pulls fix for forcing compile-time tuning even when building
with -march=z13 on s390x.  [bnc#1099192]
2018-06-07 - rguenther@suse.com
- Update to gcc-7-branch head (r261272).
* Fixes support for 32bit ASAN with glibc 2.27+
* Includes gcc7-bnc1087550.diff
2018-04-18 - rguenther@suse.com
- Update gcc7-bnc1087550.diff with latest changes.  [bnc#1087550]
2018-04-11 - rguenther@suse.com
- Update gcc7-bnc1087550.diff with fix from upstream that supports
both ABIs for ios_base::failure.  [bnc#1087550]
2018-04-09 - rguenther@suse.com
- Set SUSE_ASNEEDED to zero during %install so libasan keeps its
NEEDED entry for libstdc++.so.  [GCC#84428]
2018-04-06 - rguenther@suse.com
- Enable --enable-fix-cortex-a53-835769 for aarch64.
- Add gcc7-bnc1087550.diff to revert the ios_base::failure ABI
back to compatible behavior with the default ABI.  [bnc#1087550]
2018-04-03 - rguenther@suse.com
- Update to gcc-7-branch head (r258812).
* Picks fix to no longer enable -mpc-relative-literal-loads by default
with --enable-fix-cortex-a53-843419.
- Enable --enable-fix-cortex-a53-843419 on aarch64.  [bnc#1084812]
[bnc#1087930]
2018-03-07 - rguenther@suse.com
- Update to gcc-7-branch head (r258313).
* includes spectre V2 mitigation patch for s390x.  [bnc#1083946]

See Also

Package Description
libomp5-devel-5.0.1-lp150.7.3.1.x86_64.rpm MPI plugin for LLVM
libopamgt-devel-10.6.0-lp150.4.3.1.x86_64.rpm Omni-Path library development headers
libopamgt0-10.6.0-lp150.4.3.1.x86_64.rpm Omni-Path management API library
libopasadb1_0_0-10.6.0-lp150.4.3.1.x86_64.rpm OmniPath Subnet Administrator database library
libopencv3_3-3.3.1-lp150.4.3.1.x86_64.rpm Libraries to use OpenCV computer vision
libopeniscsiusr0_2_0-2.0.876-lp150.9.3.1.x86_64.rpm Userspace iSCSI API
libopeniscsiusr0_2_0-2.0.876-lp150.9.6.1.x86_64.rpm Userspace iSCSI API
libopeniscsiusr0_2_0-2.0.876-lp150.9.9.1.x86_64.rpm Userspace iSCSI API
libopenmpi1-gnu-hpc-1.10.7-lp150.9.3.1.x86_64.rpm Dependency package for openmpi_1_10_7-gnu-hpc
libopenmpi2-gnu-hpc-2.1.3-lp150.3.3.1.x86_64.rpm Dependency package for openmpi_2_1_3-gnu-hpc
libopenmpi2-gnu-hpc-2.1.3-lp150.3.6.1.x86_64.rpm Dependency package for openmpi_2_1_3-gnu-hpc
libopenmpi_1_10_7-gnu-hpc-1.10.7-lp150.9.3.1.x86_64.rpm OpenMPI runtime libraries for OpenMPI HPC version 1.10.7
libopenmpi_2_1_3-gnu-hpc-2.1.3-lp150.3.3.1.x86_64.rpm OpenMPI runtime libraries for OpenMPI HPC version 2.1.3
libopenmpi_2_1_3-gnu-hpc-2.1.3-lp150.3.6.1.x86_64.rpm OpenMPI runtime libraries for OpenMPI HPC version 2.1.3
libopenmpt-devel-0.3.9-lp150.2.3.1.x86_64.rpm Development files for libopenmpt
Advertisement
Advertisement