libndr-devel-4.7.10+git.124.8d97fe90926-lp150.3.9.1.x86_64.rpm


Advertisement

Description

libndr-devel - Development files for the Network Data Representation library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Update Oss all
Package filename libndr-devel-4.7.10+git.124.8d97fe90926-lp150.3.9.1.x86_64.rpm
Package name libndr-devel
Package version 4.7.10+git.124.8d97fe90926
Package release lp150.3.9.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://www.samba.org/
License GPL-3.0+
Maintainer -
Download size 254.62 KB
Installed size 38.42 KB
Network Data Representation (NDR) is an implementation of the
presentation layer in the OSI model.
This subpackage contains libraries and header files for developing
applications that want to make use of libndr.

Alternatives

Package Version Architecture Repository
libndr-devel-4.7.11+git.153.b36ceaf2235-lp150.3.14.1.x86_64.rpm 4.7.11+git.153.b36ceaf2235 x86_64 openSUSE Update Oss
libndr-devel-4.7.8+git.86.94b6d10f7dd-lp150.3.6.1.x86_64.rpm 4.7.8+git.86.94b6d10f7dd x86_64 openSUSE Update Oss
libndr-devel-4.7.8+git.62.c1052da2b4e-lp150.3.3.1.x86_64.rpm 4.7.8+git.62.c1052da2b4e x86_64 openSUSE Update Oss
libndr-devel-4.7.6+git.54.6e3276c9872-lp150.2.20.x86_64.rpm 4.7.6+git.54.6e3276c9872 x86_64 openSUSE Oss
libndr-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libndr0 = 4.7.10+git.124.8d97fe90926
pkgconfig(samba-util) -
pkgconfig(talloc) -
samba-core-devel = 4.7.10+git.124.8d97fe90926

Provides

Name Value
libndr-devel = 4.7.10+git.124.8d97fe90926-lp150.3.9.1
libndr-devel(x86-64) = 4.7.10+git.124.8d97fe90926-lp150.3.9.1
pkgconfig(ndr) = 0.1.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libndr-devel-4.7.10+git.124.8d97fe90926-lp150.3.9.1.x86_64.rpm
Source Package samba-4.7.10+git.124.8d97fe90926-lp150.3.9.1.src.rpm

Install Howto

Install libndr-devel rpm package:

# zypper install libndr-devel

Files

Path
/usr/include/samba-4.0/ndr.h
/usr/include/samba-4.0/gen_ndr/misc.h
/usr/include/samba-4.0/gen_ndr/ndr_misc.h
/usr/lib64/libndr.so
/usr/lib64/pkgconfig/ndr.pc

Changelog

2018-10-11 - aaptel@suse.com
- Update to 4.7.10; (bsc#1111528);
+ support the new v4 Performance Co-Pilot API; (bsc#1111374)
+ quotas don't work with SMB2; (bso#13553);
+ Build failure when quota support not detected; (bso#13563);
+ vfs_fruit can leave lock records when testing for netatalk share
mode locks - causing panic; (bso#13584);
+ vfs_time_audit is failing FSCTL_SRV_REQUEST_RESUME_KEY requests;
(bso#13568);
+ g_lock conflict detection broken when processing stale entries;
(bso#13195);
+ deadlock with ctdb_mutex_ceph_rados_helper; (bso#13540);
+ NTLM authentications using default domain/workgroup stopped
working; (bso#13126);
+ vfs_ceph lies about flock support; (bso#13506);
+ Using sendfile = yes with SMB2 can cause CPU spin; (bso#13537);
+ Durable Handle reconnect fails in
smbd_smb2_create_durable_lease_check(); (bso#13535);
+ cli_splice() fallback code reads wrong amount on termination
case; (bso#13527);
+ LDB 1.4.0 breaks Samba < 4.9; (bso#13519);
+ samba-tool trust: support discovery via netr_GetDcName;
(bso#13538);
+ samba-tool domain trust: fix trust compatibility to Windows Server
1709 and FreeIPA; (bso#13308);
+ conn->vuid is invalid after a SMB session reauth; (bso#13351);
+ Durable Handles reconnect fails in a cluster when the cluster fs
uses different device ids; (bso#13318);
+ cli_splice() doesn't correctly return written bytes as it's
uninitialized in libsmbclient code; (bso#13511);
+ Threading support in talloc_tos() crashes when enabled;
(bso#13505);
+ Incorrect talloc_stackframe handling in python ACL test code
(make_simple_acl); (bso#13474);
+ Fail renaming file if that file has open streams; (bso#13451);
+ vfs_fruit: delete 0 byte size streams if AAPL is enabled;
(bso#13441);
+ Creating missing remote databases during recovery can fail;
(bso#13500);
+ CTDB_BROADCAST_VNNMAP should not be used; (bso#13499);
+ Fix building Samba with gcc 8.1; (bso#13437);
+ Uncaught exception at ldb_modules/password_hash.c:2241 during new
domain provision; (bso#11573);
+ "net ads keytab add nfs" writes only one enctype with older
kerberos libraries; (bso#13478);
+ VFS modules that implement pread/pwrite must also implement
pread_send/pwrite_send; (bso#13425);
+ vfs_ceph is missing async fsync implementations; (bso#13412);
+ net ads keytab list fails with (smb_krb5_kt_open failed (Key table
name malformed); (bso#13166);
+ s390 and s390 needs to run with 'use mmap = no' by default;
(bso#10765);
2018-08-07 - aaptel@suse.com
- Disable NTLMv1 auth if smb.conf doesn't allow it; (bsc#1095048);
(bso#13360); (CVE-2018-1139);
- ldbsearch '(distinguishedName=abc)' and DNS query with escapes
crashes; (bsc#1095056); (bso#13374); (CVE-2018-1140);
- Confidential attribute disclosure via substring search;
(bsc#1095057); (bso#13434); (CVE-2018-10919);
- smbc_urlencode helper function is a subject to buffer overflow;
(bsc#1103411); (bso#13453); (CVE-2018-10858);
- Fix NULL ptr dereference in DsCrackNames on a user without a SPN;
(bsc#1103414); (bso#13552); (CVE-2018-10918);

See Also

Package Description
libndr-krb5pac-devel-4.7.10+git.124.8d97fe90926-lp150.3.9.1.x86_64.rpm Development files for the ndr-krb5pac library
libndr-krb5pac-devel-4.7.11+git.153.b36ceaf2235-lp150.3.14.1.x86_64.rpm Development files for the ndr-krb5pac library
libndr-krb5pac-devel-4.7.8+git.62.c1052da2b4e-lp150.3.3.1.x86_64.rpm Development files for the ndr-krb5pac library
libndr-krb5pac-devel-4.7.8+git.86.94b6d10f7dd-lp150.3.6.1.x86_64.rpm Development files for the ndr-krb5pac library
libndr-krb5pac0-32bit-4.7.10+git.124.8d97fe90926-lp150.3.9.1.x86_64.rpm NDR marshallers for the KRB5 PAC formats
libndr-krb5pac0-32bit-4.7.11+git.153.b36ceaf2235-lp150.3.14.1.x86_64.rpm NDR marshallers for the KRB5 PAC formats
libndr-krb5pac0-32bit-4.7.8+git.62.c1052da2b4e-lp150.3.3.1.x86_64.rpm NDR marshallers for the KRB5 PAC formats
libndr-krb5pac0-32bit-4.7.8+git.86.94b6d10f7dd-lp150.3.6.1.x86_64.rpm NDR marshallers for the KRB5 PAC formats
libndr-krb5pac0-4.7.10+git.124.8d97fe90926-lp150.3.9.1.x86_64.rpm NDR marshallers for the KRB5 PAC formats
libndr-krb5pac0-4.7.11+git.153.b36ceaf2235-lp150.3.14.1.x86_64.rpm NDR marshallers for the KRB5 PAC formats
libndr-krb5pac0-4.7.8+git.62.c1052da2b4e-lp150.3.3.1.x86_64.rpm NDR marshallers for the KRB5 PAC formats
libndr-krb5pac0-4.7.8+git.86.94b6d10f7dd-lp150.3.6.1.x86_64.rpm NDR marshallers for the KRB5 PAC formats
libndr-nbt-devel-4.7.10+git.124.8d97fe90926-lp150.3.9.1.x86_64.rpm Development files for the ndr-nbt library
libndr-nbt-devel-4.7.11+git.153.b36ceaf2235-lp150.3.14.1.x86_64.rpm Development files for the ndr-nbt library
libndr-nbt-devel-4.7.8+git.62.c1052da2b4e-lp150.3.3.1.x86_64.rpm Development files for the ndr-nbt library
Advertisement
Advertisement