libavresample4-4.0.1-lp150.2.2.x86_64.rpm


Advertisement

Description

libavresample4 - FFmpeg alternate audio resampling library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Update Oss all
Package name libavresample4
Package version 4.0.1
Package release lp150.2.2
Package architecture x86_64
Package type rpm
Installed size 148.37 KB
Download size 90.61 KB
Official Mirror ftp.gwdg.de
An audio resampling library that is being provided for drop-in
compatibility with libav.
It is advised to use libswresample for new code.

Alternatives

Package Version Architecture Repository
libavresample4-4.0.2-lp150.23.2.x86_64.rpm 4.0.2 x86_64 openSUSE Multimedia Libs
libavresample4-4.0.1-lp150.15.1.x86_64.rpm 4.0.1 x86_64 Packman
libavresample4-4.0.1-lp150.15.1.armv7hl.rpm 4.0.1 armv7hl Packman
libavresample4-4.0.1-lp150.15.1.aarch64.rpm 4.0.1 aarch64 Packman
libavresample4-4.0.1-lp150.10.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
libavresample4-4.0.1-lp150.7.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
libavresample4 - - -

Requires

Name Value
/sbin/ldconfig -
libavutil.so.56()(64bit) -
libavutil.so.56(LIBAVUTIL_56)(64bit) -
libavutil56 = 4.0.1-lp150.2.2
libc.so.6(GLIBC_2.14)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
libavresample.so.4()(64bit) -
libavresample.so.4(LIBAVRESAMPLE_4)(64bit) -
libavresample4 = 4.0.1-lp150.2.2
libavresample4(x86-64) = 4.0.1-lp150.2.2

Download

Type URL
Binary Package libavresample4-4.0.1-lp150.2.2.x86_64.rpm
Source Package ffmpeg-4-4.0.1-lp150.2.2.src.rpm

Install Howto

Install libavresample4 rpm package:

# zypper install libavresample4

Files

Path
/usr/lib64/libavresample.so.4
/usr/lib64/libavresample.so.4.0.0
/usr/share/licenses/libavresample4/COPYING.GPLv2
/usr/share/licenses/libavresample4/LICENSE.md

Changelog

2018-07-06 - tchvatal@suse.com
- Fix typo in swresample name
2018-07-04 - tchvatal@suse.com
- Conditionalize full build to be primary only on Leap15+
2018-07-03 - tchvatal@suse.com
- Add macros to allow conflicting with all other devel projects
to ensure we always install only one specific ffmpeg
2018-06-30 - tchvatal@suse.com
- Conditionalize the vidstab build to not pull it on old releases
- Conditionalize srt support to not pull it on older releases
- ------------------------------------------------------------------
2018-06-29 - 9+suse@cirno.systems
- Enable ffnvcodec when building with NVIDIA support
2018-06-29 - bjorn.lie@gmail.com
- Add pkgconfig(srt) BuildRequires and pass --enable-libsrt to
configure, enable srt support.
- Refresh patches with quilt:
* cve-2017-17555.diff
* ffmpeg-codec-choice.diff
* ffmpeg-libcdio_cdda-pkgconfig.patch
* ffmpeg-new-coder-errors.diff
2018-06-29 - 9+suse@cirno.systems
- Enable libxml2 (used by MPEG DASH demuxer)
2018-06-27 - jengelh@inai.de
- Update to new upstream release 4.0.1
* Fixed some integer overflows, undefined shifts, negative
shifts, division by 0, and a null pointer deref.
2018-06-18 - bjorn.lie@gmail.com
- Enable pkgconfig(vidstab) BuildRequires unconditionally, now
available in openSUSE.
2018-06-14 - tchvatal@suse.com
- Conditionalize openmpt build to be resolvable on Leap 42.3

See Also

Package Description
libavutil55-3.4.4-lp150.3.1.x86_64.rpm FFmpeg's utility library
libavutil55-3.4.4-lp150.6.1.x86_64.rpm FFmpeg's utility library
libavutil56-4.0.1-lp150.10.1.x86_64.rpm FFmpeg's utility library
libavutil56-4.0.1-lp150.2.2.x86_64.rpm FFmpeg's utility library
libavutil56-4.0.1-lp150.7.1.x86_64.rpm FFmpeg's utility library
libbind9-160-32bit-9.11.2-lp150.8.3.1.x86_64.rpm BIND9 shared library used by BIND
libbind9-160-32bit-9.11.2-lp150.8.6.1.x86_64.rpm BIND9 shared library used by BIND
libbind9-160-9.11.2-lp150.8.3.1.x86_64.rpm BIND9 shared library used by BIND
libbind9-160-9.11.2-lp150.8.6.1.x86_64.rpm BIND9 shared library used by BIND
libblas3-3.5.0-lp150.3.3.1.x86_64.rpm BLAS Shared Library
libblas3-32bit-3.5.0-lp150.3.3.1.x86_64.rpm BLAS Shared Library
libblkid-devel-2.31.1-lp150.7.3.1.x86_64.rpm Development files for the filesystem detection library
libblkid-devel-2.31.1-lp150.7.6.1.x86_64.rpm Development files for the filesystem detection library
libblkid-devel-32bit-2.31.1-lp150.7.3.1.x86_64.rpm Development files for the filesystem detection library
libblkid-devel-32bit-2.31.1-lp150.7.6.1.x86_64.rpm Development files for the filesystem detection library
Advertisement
Advertisement