ffmpeg-4-private-devel-4.0.1-lp150.2.2.x86_64.rpm


Advertisement

Description

ffmpeg-4-private-devel - Some FFmpeg private headers

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Update Oss all
Package name ffmpeg-4-private-devel
Package version 4.0.1
Package release lp150.2.2
Package architecture x86_64
Package type rpm
Installed size 138.34 KB
Download size 77.98 KB
Official Mirror ftp.gwdg.de
FFmpeg is a multimedia framework, able to decode, encode,
transcode, mux, demux, stream, filter and play several formats
that humans and machines have created.
This package contains some private headers for libavformat, libavcodec and
libavutil which are needed by libav-tools to build. No other package apart
from libav should depend on these private headers which are expected to
break compatibility without any notice.

Alternatives

Package Version Architecture Repository
ffmpeg-4-private-devel-4.0.2-lp150.23.2.x86_64.rpm 4.0.2 x86_64 openSUSE Multimedia Libs
ffmpeg-4-private-devel-4.0.1-lp150.15.1.x86_64.rpm 4.0.1 x86_64 Packman
ffmpeg-4-private-devel-4.0.1-lp150.15.1.armv7hl.rpm 4.0.1 armv7hl Packman
ffmpeg-4-private-devel-4.0.1-lp150.15.1.aarch64.rpm 4.0.1 aarch64 Packman
ffmpeg-4-private-devel-4.0.1-lp150.10.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
ffmpeg-4-private-devel-4.0.1-lp150.7.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
ffmpeg-4-private-devel - - -

Requires

Name Value
ffmpeg-4-libavcodec-devel = 4.0.1-lp150.2.2
ffmpeg-4-libavformat-devel = 4.0.1-lp150.2.2
ffmpeg-4-libavutil-devel = 4.0.1-lp150.2.2

Provides

Name Value
ffmpeg-4-private-devel = 4.0.1-lp150.2.2
ffmpeg-4-private-devel(x86-64) = 4.0.1-lp150.2.2
ffmpeg-private-devel = 4.0.1

Conflicts

Name Value
ffmpeg-private-devel -
ffmpeg-private-devel < 4
ffmpeg-private-devel >= 5
libavcodec-devel < 4
libavcodec-devel >= 5
libavdevice-devel < 4
libavdevice-devel >= 5
libavfilter-devel >= 5
libavfilter-devel < 4
libavformat-devel < 4
libavformat-devel >= 5
libavresample-devel < 4
libavresample-devel >= 5
libavutil-devel < 4
libavutil-devel >= 5
libpostproc-devel < 4
libpostproc-devel >= 5
libswresample-devel < 4
libswresample-devel >= 5
libswscale-devel < 4
libswscale-devel >= 5

Download

Type URL
Binary Package ffmpeg-4-private-devel-4.0.1-lp150.2.2.x86_64.rpm
Source Package ffmpeg-4-4.0.1-lp150.2.2.src.rpm

Install Howto

Install ffmpeg-4-private-devel rpm package:

# zypper install ffmpeg-4-private-devel

Files

Path
/usr/include/ffmpeg/private/
/usr/include/ffmpeg/private/libavcodec/options_table.h
/usr/include/ffmpeg/private/libavformat/internal.h
/usr/include/ffmpeg/private/libavformat/options_table.h
/usr/include/ffmpeg/private/libavformat/os_support.h
/usr/include/ffmpeg/private/libavutil/colorspace.h
/usr/include/ffmpeg/private/libavutil/internal.h
/usr/include/ffmpeg/private/libavutil/libm.h
/usr/include/ffmpeg/private/libavutil/timer.h
/usr/include/ffmpeg/private/libavutil/aarch64/timer.h
/usr/include/ffmpeg/private/libavutil/arm/timer.h
/usr/include/ffmpeg/private/libavutil/bfin/timer.h
/usr/include/ffmpeg/private/libavutil/ppc/timer.h
/usr/include/ffmpeg/private/libavutil/x86/emms.h
/usr/include/ffmpeg/private/libavutil/x86/timer.h

Changelog

2018-07-06 - tchvatal@suse.com
- Fix typo in swresample name
2018-07-04 - tchvatal@suse.com
- Conditionalize full build to be primary only on Leap15+
2018-07-03 - tchvatal@suse.com
- Add macros to allow conflicting with all other devel projects
to ensure we always install only one specific ffmpeg
2018-06-30 - tchvatal@suse.com
- Conditionalize the vidstab build to not pull it on old releases
- Conditionalize srt support to not pull it on older releases
- ------------------------------------------------------------------
2018-06-29 - 9+suse@cirno.systems
- Enable ffnvcodec when building with NVIDIA support
2018-06-29 - bjorn.lie@gmail.com
- Add pkgconfig(srt) BuildRequires and pass --enable-libsrt to
configure, enable srt support.
- Refresh patches with quilt:
* cve-2017-17555.diff
* ffmpeg-codec-choice.diff
* ffmpeg-libcdio_cdda-pkgconfig.patch
* ffmpeg-new-coder-errors.diff
2018-06-29 - 9+suse@cirno.systems
- Enable libxml2 (used by MPEG DASH demuxer)
2018-06-27 - jengelh@inai.de
- Update to new upstream release 4.0.1
* Fixed some integer overflows, undefined shifts, negative
shifts, division by 0, and a null pointer deref.
2018-06-18 - bjorn.lie@gmail.com
- Enable pkgconfig(vidstab) BuildRequires unconditionally, now
available in openSUSE.
2018-06-14 - tchvatal@suse.com
- Conditionalize openmpt build to be resolvable on Leap 42.3

See Also

Package Description
filesystem-15.0-lp150.8.3.1.x86_64.rpm Basic Directory Layout
firewall-applet-0.5.3-lp150.2.3.1.noarch.rpm Firewall panel applet
firewall-config-0.5.3-lp150.2.3.1.noarch.rpm Firewall configuration application
firewall-macros-0.5.3-lp150.2.3.1.noarch.rpm FirewallD RPM macros
firewalld-0.5.3-lp150.2.3.1.noarch.rpm A firewall daemon with D-Bus interface providing a dynamic firewall
firewalld-lang-0.5.3-lp150.2.3.1.noarch.rpm Translations for package firewalld
fvwm2-2.6.7-lp150.2.3.1.x86_64.rpm The F Virtual Window Manager
gajim-1.0.3-lp150.3.3.1.noarch.rpm XMPP client written in Python and Gtk3
gajim-lang-1.0.3-lp150.3.3.1.noarch.rpm Translations for package gajim
gcompris-qt-0.91-lp150.3.3.1.x86_64.rpm Multiactivity educational software for children aged 2?10 (Qt version)
gcompris-qt-activities-0.91-lp150.3.3.1.noarch.rpm Activity files for gcompris-qt
gcompris-qt-lang-0.91-lp150.3.3.1.noarch.rpm Translation files for gcompris-qt
gcompris-qt-voices-0~20180517-lp150.2.4.1.noarch.rpm Voice files for gcompris-qt
geotiff-1.4.2-lp150.2.3.1.x86_64.rpm Library to handle georeferenced TIFF
geotiff-devel-1.4.2-lp150.2.3.1.x86_64.rpm GeoTIFF header files
Advertisement
Advertisement