john-1.8.0-lp150.68.2.x86_64.rpm


Advertisement

Description

john - Detects Weak Passwords

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Security all
Package name john
Package version 1.8.0
Package release lp150.68.2
Package architecture x86_64
Package type rpm
Installed size 9.54 MB
Download size 4.98 MB
Official Mirror ftp.gwdg.de
John the Ripper is a fast password cracker (password security auditing
tool). Its primary purpose is to detect weak Unix passwords, but a
number of other hash types are supported as well.

Alternatives

Package Version Architecture Repository
john - - -

Requires

Name Value
/usr/bin/perl -
libc.so.6(GLIBC_2.14)(64bit) -
libcrypt.so.1()(64bit) -
libcrypt.so.1(GLIBC_2.2.5)(64bit) -
libcrypto.so.1.0.0()(64bit) -
libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libssl.so.1.0.0()(64bit) -
libssl.so.1.0.0(OPENSSL_1.0.0)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
config(john) = 1.8.0-lp150.68.2
john = 1.8.0-lp150.68.2
john(x86-64) = 1.8.0-lp150.68.2

Download

Type URL
Binary Package john-1.8.0-lp150.68.2.x86_64.rpm
Source Package john-1.8.0-lp150.68.2.src.rpm

Install Howto

  1. Add the openSUSE Security repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/security/openSUSE_Leap_15.0/ opensuse-security
  2. Install john rpm package:
    # zypper install john

Files

Path
/etc/john.conf
/usr/bin/john
/usr/bin/mailer
/usr/bin/relbench
/usr/bin/unafs
/usr/bin/undrop
/usr/bin/unique
/usr/bin/unshadow
/usr/share/doc/packages/john/BUGS
/usr/share/doc/packages/john/CHANGES
/usr/share/doc/packages/john/CHANGES-jumbo
/usr/share/doc/packages/john/CHANGES-jumbo.git
/usr/share/doc/packages/john/CONFIG
/usr/share/doc/packages/john/CONTACT
/usr/share/doc/packages/john/COPYING
/usr/share/doc/packages/john/CREDITS
/usr/share/doc/packages/john/CREDITS-jumbo
/usr/share/doc/packages/john/DYNAMIC
/usr/share/doc/packages/john/DYNAMIC_SCRIPTING
/usr/share/doc/packages/john/ENCODINGS
/usr/share/doc/packages/john/EPi.patch.README
/usr/share/doc/packages/john/EXAMPLES
/usr/share/doc/packages/john/EXTERNAL
/usr/share/doc/packages/john/FAQ
/usr/share/doc/packages/john/HDAA_README
/usr/share/doc/packages/john/LICENSE
/usr/share/doc/packages/john/LICENSE.mpi
/usr/share/doc/packages/john/MARKOV
/usr/share/doc/packages/john/MODES
/usr/share/doc/packages/john/NETNTLM_README
/usr/share/doc/packages/john/OFFICE
/usr/share/doc/packages/john/OPTIONS
/usr/share/doc/packages/john/README
/usr/share/doc/packages/john/README-CUDA
/usr/share/doc/packages/john/README-jumbo
/usr/share/doc/packages/john/README.bash-completion
/usr/share/doc/packages/john/README.mozilla
/usr/share/doc/packages/john/README.mpi
/usr/share/doc/packages/john/README.opencl
/usr/share/doc/packages/john/README.pwsafe
/usr/share/doc/packages/john/RULES
/usr/share/doc/packages/john/SIPcrack-LICENSE
/usr/share/doc/packages/john/pass_gen.Manifest
/usr/share/doc/packages/john/pdfcrack_README
/usr/share/doc/packages/john/pdfcrack_TODO
/usr/share/man/man8/john.8.gz
/usr/share/man/man8/mailer.8.gz
/usr/share/man/man8/relbench.8.gz
/var/lib/john/all.chr
/var/lib/john/alnum.chr
/var/lib/john/alpha.chr
/var/lib/john/ascii.chr
/var/lib/john/digits.chr
/var/lib/john/dumb16.conf
/var/lib/john/dumb32.conf
/var/lib/john/dynamic.conf
/var/lib/john/john.local.conf
/var/lib/john/lanman.chr
/var/lib/john/lm_ascii.chr
/var/lib/john/password.lst

Changelog

2018-03-27 - dimstar@opensuse.org
- Build against openSSL 1.0 until upstream catches up
(boo#1078844).
2017-05-27 - bwiedemann@suse.com
- Add reproducible.patch to sort input files to make build reproducible
(boo#1041090)
2016-12-08 - meissner@suse.com
- remove incorrect too large john.keyring ...
The signature of these tarballs is currently with a key with MD5 hash,
which is rejected by default.
2016-02-17 - normand@linux.vnet.ibm.com
- as follow on of previous "jumbo patch" need two powerpc changes:
new john-1.7.9-powerpc_BE_need_rhash_u32_swap_copy.patch
place ppc64le.patch after application of "jumbo patch" in spec
allow to solve partially boo #940498  for ppc64le
but still have 4 FAILED tests for ppc64 tracked upstream by
http://www.openwall.com/lists/john-dev/2016/02/16/1
2015-06-25 - astieger@suse.com
- fix SLE 11 SP3 build
2014-12-15 - lars@linux-schulserver.de
- include "jumbo patch" into the build - special thanks to
Mark Draheim for the specfile patch (closes bnc #839246)
2014-01-10 - dvaleev@suse.com
- Fix build on ppc64le
- added patches:
* ppc64le.patch
2013-10-28 - schwab@suse.de
- Use the generic target for m68k
2013-10-09 - lars@linux-schulserver.de
- update to 1.8.0:
+ Revised the incremental mode to let the current character counts
grow for each character position independently, with the aim to
improve efficiency in terms of successful guesses per candidate
passwords tested.
+ Revised the pre-defined incremental modes, as well as external
mode filters that are used to generate .chr files.
+ Added makechr, a script to (re-)generate .chr files.
+ Enhanced the status reporting to include four distinct speed
metrics (g/s, p/s, c/s, and C/s).
+ Added the "--fork=N" and "--node=MIN[-MAX]/TOTAL" options for
trivial parallel and distributed processing.
+ In the external mode compiler, treat character literals as unsigned.
+ Renamed many of the formats.
+ Updated the documentation.
+ Relaxed the license for many source files to cut-down BSD.
+ Relaxed the license for John the Ripper as a whole from GPLv2
(exact version) to GPLv2 or newer with optional OpenSSL and
unRAR exceptions.
+ Assorted other changes have been made.
- add simple man pages for relbench and mailer scripts
- disable jumbo patch for now until a version for 1.8.0 is out
2013-03-17 - schwab@suse.de
- Use the generic target for aarch64

See Also

Package Description
kbfs-2.8.0-lp150.4.1.x86_64.rpm Encrypted remote storage based on Keybase identities
kbfs-git-2.8.0-lp150.4.1.x86_64.rpm Git remote helper for repositories stored on Keybase
kbfs-tool-2.8.0-lp150.4.1.x86_64.rpm Keybase Filesystem command line utility
keepassx-2.0.3-lp150.43.1.x86_64.rpm Cross Platform Password Manager
keepassxc-2.3.4-lp150.39.1.x86_64.rpm Qt5-based Password Manager
keepassxc-lang-2.3.4-lp150.39.1.noarch.rpm Translations for package keepassxc
keybase-client-2.9.0-lp150.3.1.x86_64.rpm Keybase command line client
keychain-2.8.5-lp150.32.1.noarch.rpm A Key Management Application for SSH2 RSA/DSA and GnuPG Keys
keyutils-1.5.11-lp150.62.1.i586.rpm Linux Key Management Utilities
keyutils-1.5.11-lp150.62.1.x86_64.rpm Linux Key Management Utilities
keyutils-devel-1.5.11-lp150.62.1.i586.rpm Development package for building linux key management utilities
keyutils-devel-1.5.11-lp150.62.1.x86_64.rpm Development package for building linux key management utilities
keyutils-devel-32bit-1.5.11-lp150.62.1.x86_64.rpm Development package for building linux key management utilities
lastpass-cli-1.3.1-lp150.17.1.x86_64.rpm LastPass command line interface tool
libargon2-1-0.0+git20171227.670229c-lp150.19.1.i586.rpm The reference C implementation of Argon2
Advertisement
Advertisement