perl-Curses-1.32-lp150.1.6.x86_64.rpm


Advertisement

Description

perl-Curses - Terminal screen handling and optimization

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package filename perl-Curses-1.32-lp150.1.6.x86_64.rpm
Package name perl-Curses
Package version 1.32
Package release lp150.1.6
Package architecture x86_64
Package type rpm
Category Development/Libraries/Perl
Homepage http://cpan.org/modules/by-module/Curses/
License Artistic-1.0
Maintainer -
Download size 100.13 KB
Installed size 344.99 KB
Curses is the interface between Perl and your system's curses(3) library.
For descriptions on the usage of a given function, variable, or constant,
consult your system's documentation, as such information invariably varies
(:-) between different curses(3) libraries and operating systems. This
document describes the interface itself, and assumes that you already know
how your system's curses(3) library works.

Alternatives

Package Version Architecture Repository
perl-Curses - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libmenu.so.6()(64bit) -
libmenu.so.6(NCURSESTW6_5.7.20081102)(64bit) -
libncursesw.so.6()(64bit) -
libncursesw.so.6(NCURSESTW6_5.7.20081102)(64bit) -
libpanel.so.6()(64bit) -
libpanel.so.6(NCURSESTW6_5.7.20081102)(64bit) -
libtinfo.so.6()(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.0.19991023)(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.7.20081102)(64bit) -
perl(:MODULE_COMPAT_5.26.1) -

Provides

Name Value
Curses -
perl(Curses) = 1.32
perl(Curses::Field) -
perl(Curses::Form) -
perl(Curses::Item) -
perl(Curses::Menu) -
perl(Curses::Panel) -
perl(Curses::Screen) -
perl(Curses::Window) -
perl-Curses = 1.32-lp150.1.6
perl-Curses(x86-64) = 1.32-lp150.1.6
perl_cur -

Obsoletes

Name Value
perl_cur -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package perl-Curses-1.32-lp150.1.6.x86_64.rpm
Source Package perl-Curses-1.32-lp150.1.6.src.rpm

Install Howto

Install perl-Curses rpm package:

# zypper install perl-Curses

Files

Path
/usr/lib/perl5/vendor_perl/5.26.1/x86_64-linux-thread-multi/Curses.pm
/usr/lib/perl5/vendor_perl/5.26.1/x86_64-linux-thread-multi/auto/Curses/Curses.so
/usr/share/doc/packages/perl-Curses/Artistic
/usr/share/doc/packages/perl-Curses/Copying
/usr/share/doc/packages/perl-Curses/HISTORY
/usr/share/doc/packages/perl-Curses/MAINTENANCE
/usr/share/doc/packages/perl-Curses/README
/usr/share/doc/packages/perl-Curses/demo
/usr/share/doc/packages/perl-Curses/demo.form
/usr/share/doc/packages/perl-Curses/demo.menu
/usr/share/doc/packages/perl-Curses/demo.panel
/usr/share/doc/packages/perl-Curses/demo2
/usr/share/doc/packages/perl-Curses/list.syms
/usr/share/doc/packages/perl-Curses/test.syms
/usr/share/man/man3/Curses.3pm.gz

Changelog

2015-02-06 - coolo@suse.com
- updated to 1.32
Makefile.PL: if /usr/include/ncurses/ncurses.h exists, use Ncurses regardless
of what the $guess_cfg table says for the OS at hand.  This fixes the former
hybrid approach which didn't work for a Solaris 11 system that has both
Ncurses and BSD curses.
Typographical error in documentation fixed.
New in 1.31 (Released April 26, 2014)
Fix compile failure with some Curses libraries, introduced in
1.29 - undefined KEY_CODE_YES.
Fix documentation: wide character functions exist back to Perl 5.6,
not 5.16.
New in 1.30 (Released April 19, 2014)
Fix build failure: Use older substitutes if Perl is too old to have
the 'utf8_to_uvchr_buf' function they use; don't include the wide character
functions if Perl is even too old to have the substitutes.  Broken in 1.29.
Fix "constant not provided by your vendor" message when you refer to a
function that does not exist in the Curses module.
Minor fixes to documentation of new wide character functions.
Fix warning about extra argument to c_setmevent .
Fix documentation for "not defined in your Curses library" errors.
(broken in 1.28).
Fix demo programs' recognition of "not defined in your Curses library"
errors (broken in 1.28).
New in 1.29 (Released April 6, 2014)
Add an alternate set of functions (getchar, ungetchar, getstring,
instring, addstring, insstring) providing a more Perl-like interface,
converting from and to Perl strings (instead of passing data to the C
library verbatim) and using wide character functions if available in the
underlying curses library.
Written by Edgar Fu201337, Mathematisches Institut der Uni Bonn,
<ef@math.uni-bonn.de>
2011-11-18 - coolo@suse.com
- use original tar.gz
2010-11-30 - coolo@novell.com
- switch to perl_requires macro
2010-11-29 - coolo@novell.com
- remove /var/adm/perl-modules
2010-10-19 - coolo@novell.com
- add perl as explicit buildrequire
2010-02-09 - coolo@novell.com
- update to 1.28
* Disable Curses::Var::STORE.  It doesn't work (doesn't even compile) with
newer Ncurses (due to updates to make Ncurses reentrant).  One can
re-enable it by defining ALLOW_VARS_STORE in c-config.h.
* Improve "not provided by your vendor" message.
2010-01-10 - jengelh@medozas.de
- enable parallel build
2009-02-23 - anicka@suse.cz
- update to 1.27
* Extraneous .i and .s files in 1.26 removed.  'make clean' cleans
all .i and .s too.
* 'gen' directory is replaced by gen.tar file, so CPAN doesn't
index the stuff in there.  That directory is stuff for developing
the Curses package, not stuff for users.
* newterm() is available and putwin() and getwin() work in newer
Perl (with PerlIO). We now use PerlIO_findFile().
2008-09-10 - anicka@suse.cz
- update to 1.24
* Export KEY_RESIZE, KEY_EVENT.
* For Netbsd, allow both Netbsd and BSD guesses via CURSES_LIBTYPE,
and default to Ncurses.
* Add guess capability for Dragonfly.
2008-03-10 - anicka@suse.cz
- update to 1.23
* Fix crash of Makefile.PL on Windows.
* Don't undefine 'bool' macro in c-darwin hints file.
* Fix missing comment delimiter.

See Also

Package Description
perl-CursesWidgets-1.997-lp150.148.3.noarch.rpm CursesWidgets Perl module
perl-Cwd-Guard-0.05-lp150.1.3.noarch.rpm Temporary changing working directory (chdir)
perl-Cyrus-IMAP-2.4.19-lp150.1.13.x86_64.rpm Cyrus IMAP Perl Module
perl-Cyrus-SIEVE-managesieve-2.4.19-lp150.1.13.x86_64.rpm Cyrus SIEVE Perl Module
perl-DBD-CSV-0.49-lp150.1.3.noarch.rpm DBI driver for CSV files
perl-DBD-ODBC-1.58-lp150.1.1.x86_64.rpm ODBC Driver for DBI
perl-DBD-Pg-3.5.3-lp150.1.8.x86_64.rpm PostgreSQL database driver for the DBI module
perl-DBD-SQLite-1.54-lp150.1.11.x86_64.rpm Self-contained RDBMS in a DBI Driver
perl-DBD-XBase-1.08-lp150.1.3.noarch.rpm Reads and writes XBase (dbf) files, includes DBI support
perl-DBD-mysql-4.046-lp150.1.1.x86_64.rpm MySQL driver for the Perl5 Database Interface (DBI)
perl-DBI-1.639-lp150.1.3.x86_64.rpm Database independent interface for Perl
perl-DBICx-TestDatabase-0.05-lp150.1.3.noarch.rpm Create a Temporary Database From a Dbix::Class::Schema
perl-DBIx-Class-0.082841-lp150.1.2.noarch.rpm Extensible and flexible object <-> relational mapper
perl-DBIx-Class-DeploymentHandler-0.002222-lp150.1.3.noarch.rpm Extensible DBIx::Class deployment
perl-DBIx-Class-DynamicDefault-0.04-lp150.1.3.noarch.rpm Automatically set and update fields
Advertisement
Advertisement