libsystemd0-234-lp150.19.1.x86_64.rpm


Advertisement

Description

libsystemd0 - Component library for systemd

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package filename libsystemd0-234-lp150.19.1.x86_64.rpm
Package name libsystemd0
Package version 234
Package release lp150.19.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.freedesktop.org/wiki/Software/systemd
License LGPL-2.1-or-later
Maintainer -
Download size 528.29 KB
Installed size 592.15 KB
This library provides several of the systemd C APIs:
* sd-bus implements an alternative D-Bus client library that is
relatively easy to use, very efficient and supports both classic
D-Bus as well as kdbus as transport backend.
* sd-daemon(3): for system services (daemons) to report their status
to systemd and to make easy use of socket-based activation logic
* sd-event is a generic event loop abstraction that is built around
Linux epoll, but adds features such as event prioritization or
efficient timer handling.
* sd-id128(3): generation and processing of 128-bit IDs
* sd-journal(3): API to submit and query journal log entries
* sd-login(3): APIs to introspect and monitor seat, login session and
user status information on the local system.

Alternatives

Package Version Architecture Repository
libsystemd0-234-lp150.20.15.1.x86_64.rpm 234 x86_64 openSUSE Update Oss
libsystemd0-234-lp150.20.12.1.x86_64.rpm 234 x86_64 openSUSE Update Oss
libsystemd0-234-lp150.20.9.1.x86_64.rpm 234 x86_64 openSUSE Update Oss
libsystemd0-234-lp150.20.6.1.x86_64.rpm 234 x86_64 openSUSE Update Oss
libsystemd0-234-lp150.20.3.1.x86_64.rpm 234 x86_64 openSUSE Update Oss
libsystemd0 - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux-x86-64.so.2()(64bit) -
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libcap.so.2()(64bit) -
libdl.so.2()(64bit) -
libgcrypt.so.20()(64bit) -
libgcrypt.so.20(GCRYPT_1.6)(64bit) -
libgpg-error.so.0()(64bit) -
liblz4.so.1()(64bit) -
liblzma.so.5()(64bit) -
liblzma.so.5(XZ_5.0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libresolv.so.2()(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
librt.so.1(GLIBC_2.3.4)(64bit) -
libselinux.so.1()(64bit) -

Provides

Name Value
libsystemd.so.0()(64bit) -
libsystemd.so.0(LIBSYSTEMD_209)(64bit) -
libsystemd.so.0(LIBSYSTEMD_211)(64bit) -
libsystemd.so.0(LIBSYSTEMD_213)(64bit) -
libsystemd.so.0(LIBSYSTEMD_214)(64bit) -
libsystemd.so.0(LIBSYSTEMD_216)(64bit) -
libsystemd.so.0(LIBSYSTEMD_217)(64bit) -
libsystemd.so.0(LIBSYSTEMD_219)(64bit) -
libsystemd.so.0(LIBSYSTEMD_220)(64bit) -
libsystemd.so.0(LIBSYSTEMD_221)(64bit) -
libsystemd.so.0(LIBSYSTEMD_222)(64bit) -
libsystemd.so.0(LIBSYSTEMD_226)(64bit) -
libsystemd.so.0(LIBSYSTEMD_227)(64bit) -
libsystemd.so.0(LIBSYSTEMD_229)(64bit) -
libsystemd.so.0(LIBSYSTEMD_230)(64bit) -
libsystemd.so.0(LIBSYSTEMD_231)(64bit) -
libsystemd.so.0(LIBSYSTEMD_232)(64bit) -
libsystemd.so.0(LIBSYSTEMD_233)(64bit) -
libsystemd.so.0(LIBSYSTEMD_234)(64bit) -
libsystemd0 = 234-lp150.19.1
libsystemd0(x86-64) = 234-lp150.19.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libsystemd0-234-lp150.19.1.x86_64.rpm
Source Package systemd-234-lp150.19.1.src.rpm

Install Howto

Install libsystemd0 rpm package:

# zypper install libsystemd0

Files

Path
/usr/lib64/libsystemd.so.0
/usr/lib64/libsystemd.so.0.19.0

Changelog

2018-05-14 - fbui@suse.com
- Make sure /etc/machine-id has correct permissions (boo#1092269)
This should be only needed for those who keep a Beta/RC
installations.
2018-04-23 - fbui@suse.com
- Move 80-container-v[ez].network in systemd-container sub-package
- Move 80-container-host0.network from udev to systemd
2018-04-23 - fbui@suse.com
- Import commit d5dfab21f033c8af518e169a4cc79365a26974e2
92bf37b0a device: skip deserialization of device units when udevd is not running
0a8984996 device: make sure to always retroactively start device dependencies (bsc#1088052)
88df88129 cryptsetup-generator: do not bind to the decrypted device unit (#6538) (bsc#1089693)
2018-04-20 - fbui@suse.com
- Ship 99-sysctl.conf instead of creating it during package installation/update (bsc#1088769)
Previously this symlink was created in /etc/sysctl.d during %post
which made the symlink not owned and more importantly it was created
only if /etc/sysctl.conf is already installed which is not always
the case during the installation process it seems.
So ship the symlink unconditionally and put it in /usr/lib/sysctl.d
instead since it's a distro default behavior that might be overriden
by sysadmin later.
2018-04-18 - fbui@suse.com
- Import commit 9c35953dd19e90e4bfb03ad41380f3a5f9ae3ce7
a374ad328 Drop busname unit type (bsc#1089376)
85a01da56 shared/dissect-image: adapt to LUKS2 format
a0ac1823c dissect: add a bit of debug logging if dm-crypt fails on us
386ae68a0 cryptsetup: support LUKS2 on-disk format (bsc#1083571)
5f3b66fdb systemd-udevd: limit children-max by available memory (#8668) (bsc#1086785 bsc#1066422)
54833e3ab tmpfiles: fix directory removal with force symlink (#8619)
04ef8e535 rules: fix syntax inconsistency in 75-persistent-net-generator.rules spotted by rule syntax checker
2018-04-18 - fbui@suse.com
- Drop dangling symlinks when systemd-container is not installed (bsc#1089376)
- /usr/lib/systemd/system/remote-fs.target.wants/var-lib-machines.mount
symlink is now part of systemd-container.
- Dangling org.freedesktop.*.busname symlinks have been dropped
completely and the support of busname has been removed from the
git repo since it was dead code (kdbus was rejected).
2018-04-16 - jlee@suse.com
- systemd: add offline environmental condition to 80-acpi-container-hotplug.rules (bsc#1082485)
Add the offline event environmental condition to restrict the rule
that is can only be triggered when the change event is received with
the "offline" environmental data. The 27664c581 "ACPI / scan: Send
change uevent with offine environmental data" kernel patch changed
the corresponding code in kernel.
This change prevents the udev rules for acpi container be triggered
by "udevadm trigger" from user space.
2018-04-05 - fbui@suse.com
- Split systemd-coredump sub-package off (bsc#1083849)
2018-03-28 - fbui@suse.com
- Rename the tarball to reflect the exact version used (bsc#1087323)
So it's clear that it contains some additional patches on top of the
upstream version. Use the commit hash in the name so the exact
version can easily be identified.
Provide _service file which can be used to retrieve the tarball from
the git repo (with "osc service disabledrun").
2018-03-28 - fbui@suse.com
- Import commit b83c42d5d91a5ace2b4aa7420e83c98292e6f9e3
a59988ee5 sysusers: make sure to reset errno before calling fget*ent()
98ddbf6b3 sysusers: also add support for NIS entries in /etc/shadow
586c08f63 sysusers: do not append entries after the NIS ones (bsc#1085062 bsc#1045092)
3993df26a compat-rules: fix error detected by the rule syntax checker

See Also

Package Description
libsystemd0-32bit-234-lp150.19.1.x86_64.rpm Component library for systemd
libsz2-1.0.2-lp150.1.4.x86_64.rpm Lossless compression library for scientific data
libsz2-32bit-1.0.2-lp150.1.4.x86_64.rpm Lossless compression library for scientific data
libt3config-devel-0.2.10-lp150.1.7.x86_64.rpm Development files for libt3config, a library for reading/writing config files
libt3config0-0.2.10-lp150.1.7.x86_64.rpm The Tilde Toolkit's library for reading and writing configuration files
libt3highlight-devel-0.4.2-lp150.1.7.x86_64.rpm Development files for libt3highlight, a syntax highlighting library
libt3highlight-utils-0.4.2-lp150.1.7.x86_64.rpm Utilities for working with libt3highlight
libt3highlight2-0.4.2-lp150.1.7.x86_64.rpm The Tilde Toolkit's syntax highlighting library
libt3key-devel-0.2.6-lp150.1.7.x86_64.rpm Development files for libt3key, a terminal key sequence db library
libt3key-utils-0.2.6-lp150.1.7.x86_64.rpm Utilities for working with libt3key terminal descriptions
libt3key1-0.2.6-lp150.1.7.x86_64.rpm The Tilde Toolkit's terminal key sequence database library
libt3widget-devel-0.5.2-lp150.1.7.x86_64.rpm Development files for libt3widget, a terminal dialog library
libt3widget1-0.5.2-lp150.1.7.x86_64.rpm The Tilde terminal dialog toolkit
libt3window-devel-0.2.3-lp150.1.7.x86_64.rpm Development files for libt3window, a library for window-based terminal drawing
libt3window0-0.2.3-lp150.1.7.x86_64.rpm The Tilde Toolkit's window-based terminal program library
Advertisement
Advertisement