libpopt0-32bit-1.16-lp150.2.15.x86_64.rpm


Advertisement

Description

libpopt0-32bit - A C library for parsing command line parameters

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package filename libpopt0-32bit-1.16-lp150.2.15.x86_64.rpm
Package name libpopt0-32bit
Package version 1.16
Package release lp150.2.15
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.rpm5.org/
License MIT
Maintainer -
Download size 34.11 KB
Installed size 50.05 KB
Popt is a C library for parsing command line parameters.  Popt was
heavily influenced by the getopt() and getopt_long() functions. It
improves on them by allowing more powerful argument expansion. Popt can
parse arbitrary argv[] style arrays and automatically set variables
based on command line arguments.  Popt allows command line arguments to
be aliased via configuration files and includes utility functions for
parsing arbitrary strings into argv[] arrays using shell-like rules.

Alternatives

Package Version Architecture Repository
libpopt0-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.17) -

Provides

Name Value
libpopt.so.0 -
libpopt.so.0(LIBPOPT_0) -
libpopt0-32bit = 1.16-lp150.2.15
libpopt0-32bit(x86-32) = 1.16-lp150.2.15

Obsoletes

Name Value
popt-32bit <= 1.16

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libpopt0-32bit-1.16-lp150.2.15.x86_64.rpm
Source Package popt-1.16-lp150.2.15.src.rpm

Install Howto

Install libpopt0-32bit rpm package:

# zypper install libpopt0-32bit

Files

Path
/usr/lib/libpopt.so.0
/usr/lib/libpopt.so.0.0.0

Changelog

2018-02-22 - fvogt@suse.com
- Use %license (boo#1082318)
2017-08-08 - jengelh@inai.de
- Remove --with-pic which is only for static libs.
- Fix RPM groups.
2013-10-07 - schwab@suse.de
- popt-alignment-checks.patch: fix alignment checks
2013-07-07 - jengelh@inai.de
- Fix typo in popt-libc-updates.patch that prevented it to work
with glibc before 2.17.
- More robust make install call; remove redundant %clean section
2013-06-14 - coolo@suse.com
- fix popt-libc-updates.patch to work also with automake 1.13
2013-04-15 - idonmez@suse.com
- Add Source URL, see https://en.opensuse.org/SourceUrls
2013-02-13 - crrodriguez@opensuse.org
- Remove patches:
- config-guess-sub-update.patch
- popt-secure-getenv.patch
run autoreconf instead .
- popt-libc-updates.patch replaces popt-secure-getenv.patch
* test for secure_getenv instead of __secure_getenv
* update configure.ac so it can be regenerated with modern
autotools.
* Internal symbols are already hidden with a linker script,
improve that by hidding symbols with the compiler too.
* use strerror_r instead of strerror in the library.
2013-02-11 - crrodriguez@opensuse.org
- popt wants __secure_getenv at configure time, but This
function is no longer available as of glibc 2.17.
test for secure_getenv() instead (popt-secure-getenv.patch)
2013-02-04 - dmueller@suse.com
- Add config-guess-sub-update.patch:
* Update config.guess/sub for AArch64
2013-01-25 - cfarrell@suse.com
- license update: X11
New spdx.org license list now contains an official entry for X11

See Also

Package Description
libportaudio2-190600_20161030-lp150.1.12.x86_64.rpm Portable Real-Time Audio Library
libportaudio2-32bit-190600_20161030-lp150.1.12.x86_64.rpm Portable Real-Time Audio Library
libportaudiocpp0-190600_20161030-lp150.1.12.x86_64.rpm Portable Real-Time Audio Library
libportmidi0-217-lp150.1.3.x86_64.rpm Real-time MIDI input/output audio library
libpostproc-devel-3.4.2-lp150.2.1.x86_64.rpm Development files for the FFmpeg post-processing library
libpostproc54-3.4.2-lp150.2.1.x86_64.rpm FFmpeg post-processing library
libpostproc54-32bit-3.4.2-lp150.2.1.x86_64.rpm FFmpeg post-processing library
libpotrace0-1.15-lp150.3.3.x86_64.rpm Library for Tracing a Bitmap to Scalable Outline Image
libpowerman0-2.3.24-lp150.1.6.x86_64.rpm Libraries for applications using PowerMan
libpq5-10.3-lp150.2.2.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-32bit-10.3-lp150.2.2.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpqos1-1.1.1-lp150.1.11.x86_64.rpm Runtime qpos library
libpqos1-devel-1.1.1-lp150.1.11.x86_64.rpm Development package for libpqos1
libpqxx-5_0-5.0.1-lp150.1.4.x86_64.rpm C++ Client Library for PostgreSQL
libpqxx-devel-5.0.1-lp150.1.4.x86_64.rpm C++ Client Library for PostgreSQL
Advertisement
Advertisement