libkde4-32bit-4.14.38-lp150.5.34.x86_64.rpm


Advertisement

Description

libkde4-32bit - KDE Base Libraries

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package filename libkde4-32bit-4.14.38-lp150.5.34.x86_64.rpm
Package name libkde4-32bit
Package version 4.14.38
Package release lp150.5.34
Package architecture x86_64
Package type rpm
Category System/GUI/KDE
Homepage http://www.kde.org
License LGPL-2.1+
Maintainer -
Download size 6.95 MB
Installed size 26.87 MB
This package contains the basic packages of the K Desktop Environment.
It contains the necessary libraries for the KDE desktop.
This package is absolutely necessary for using graphical KDE
applications.

Alternatives

Package Version Architecture Repository
libkde4-32bit - - -

Requires

Name Value
libICE.so.6 -
libQt3Support.so.4 -
libQtCore.so.4 -
libQtDBus.so.4 -
libQtDeclarative.so.4 -
libQtGui.so.4 -
libQtNetwork.so.4 -
libQtOpenGL.so.4 -
libQtScript.so.4 -
libQtSql.so.4 -
libQtSvg.so.4 -
libQtXml.so.4 -
libSM.so.6 -
libX11.so.6 -
libXcursor.so.1 -
libXext.so.6 -
libXfixes.so.3 -
libXrender.so.1 -
libXtst.so.6 -
libacl.so.1 -
libacl.so.1(ACL_1.0) -
libattica.so.0.4 -
libattr.so.1 -
libattr.so.1(ATTR_1.0) -
libc.so.6(GLIBC_2.15) -
libdbusmenu-qt.so.2 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libgif.so.7 -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libkdecore.so.5 -
libkpty.so.4 -
libksuseinstall.so.1 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpcre.so.1 -
libphonon.so.4 -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.2.3) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libudev.so.1 -
libudev.so.1(LIBUDEV_183) -
libz.so.1 -

Provides

Name Value
libkcmutils.so.4 -
libkde3support.so.4 -
libkde4-32bit = 4.14.38-lp150.5.34
libkde4-32bit(x86-32) = 4.14.38-lp150.5.34
libkdeclarative.so.5 -
libkdesu.so.5 -
libkdeui.so.5 -
libkdnssd.so.4 -
libkemoticons.so.4 -
libkfile.so.4 -
libkhtml.so.5 -
libkidletime.so.4 -
libkimproxy.so.4 -
libkio.so.5 -
libkjs.so.4 -
libkjsapi.so.4 -
libkjsembed.so.4 -
libkmediaplayer.so.4 -
libknewstuff2.so.4 -
libknewstuff3.so.4 -
libknotifyconfig.so.4 -
libkntlm.so.4 -
libkparts.so.4 -
libkprintutils.so.4 -
libkrosscore.so.4 -
libkrossui.so.4 -
libktexteditor.so.4 -
libkunitconversion.so.4 -
libkunittest.so.4 -
libkutils.so.4 -
libplasma.so.3 -
libsolid.so.4 -
libthreadweaver.so.4 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libkde4-32bit-4.14.38-lp150.5.34.x86_64.rpm
Source Package kdelibs4-4.14.38-lp150.5.34.src.rpm

Install Howto

Install libkde4-32bit rpm package:

# zypper install libkde4-32bit

Files

Path
/usr/lib/libkcmutils.so.4
/usr/lib/libkcmutils.so.4.14.38
/usr/lib/libkde3support.so.4
/usr/lib/libkde3support.so.4.14.38
/usr/lib/libkdeclarative.so.5
/usr/lib/libkdeclarative.so.5.14.38
/usr/lib/libkdesu.so.5
/usr/lib/libkdesu.so.5.14.38
/usr/lib/libkdeui.so.5
/usr/lib/libkdeui.so.5.14.38
/usr/lib/libkdnssd.so.4
/usr/lib/libkdnssd.so.4.14.38
/usr/lib/libkemoticons.so.4
/usr/lib/libkemoticons.so.4.14.38
/usr/lib/libkfile.so.4
/usr/lib/libkfile.so.4.14.38
/usr/lib/libkhtml.so.5
/usr/lib/libkhtml.so.5.14.38
/usr/lib/libkidletime.so.4
/usr/lib/libkidletime.so.4.14.38
/usr/lib/libkimproxy.so.4
/usr/lib/libkimproxy.so.4.14.38
/usr/lib/libkio.so.5
/usr/lib/libkio.so.5.14.38
/usr/lib/libkjs.so.4
/usr/lib/libkjs.so.4.14.38
/usr/lib/libkjsapi.so.4
/usr/lib/libkjsapi.so.4.14.38
/usr/lib/libkjsembed.so.4
/usr/lib/libkjsembed.so.4.14.38
/usr/lib/libkmediaplayer.so.4
/usr/lib/libkmediaplayer.so.4.14.38
/usr/lib/libknewstuff2.so.4
/usr/lib/libknewstuff2.so.4.14.38
/usr/lib/libknewstuff3.so.4
/usr/lib/libknewstuff3.so.4.14.38
/usr/lib/libknotifyconfig.so.4
/usr/lib/libknotifyconfig.so.4.14.38
/usr/lib/libkntlm.so.4
/usr/lib/libkntlm.so.4.14.38
/usr/lib/libkparts.so.4
/usr/lib/libkparts.so.4.14.38
/usr/lib/libkprintutils.so.4
/usr/lib/libkprintutils.so.4.14.38
/usr/lib/libkrosscore.so.4
/usr/lib/libkrosscore.so.4.14.38
/usr/lib/libkrossui.so.4
/usr/lib/libkrossui.so.4.14.38
/usr/lib/libktexteditor.so.4
/usr/lib/libktexteditor.so.4.14.38
/usr/lib/libkunitconversion.so.4
/usr/lib/libkunitconversion.so.4.14.38
/usr/lib/libkunittest.so.4
/usr/lib/libkunittest.so.4.14.38
/usr/lib/libkutils.so.4
/usr/lib/libkutils.so.4.14.38
/usr/lib/libplasma.so.3
/usr/lib/libplasma.so.3.0.0
/usr/lib/libsolid.so.4
/usr/lib/libsolid.so.4.14.38
/usr/lib/libthreadweaver.so.4
/usr/lib/libthreadweaver.so.4.14.38

Changelog

2017-12-16 - fabian@ritter-vogt.de
- Do not build against QCA
2017-12-12 - wbauer@tmo.at
- Add 0001-Make-kssl-compile-against-OpenSSL-1.1.0.patch (backported
from KF5's kdelibs4support) to allow building with openSSL 1.1.0
2017-12-10 - dimstar@opensuse.org
- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.
2017-12-02 - fabian@ritter-vogt.de
- Add patch to not build against Qt4 WebKit:
* Skip-qtwebkit-parts.patch
* Vade retro satana
2017-11-09 - lbeltrame@kde.org
- Update to 4.14.38
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.08.3.php
- Changes since 4.14.37:
* Prepare for 4.14.38
2017-10-17 - wbauer@tmo.at
- Update to 17.08.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.08.2.php
- Changes since 4.14.35:
* Fix build with >=enchant-2
2017-08-11 - christophe@krop.fr
- Update to 17.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.08.0.php
- Changes since 4.14.34:
* Support SVG in Konqueror's about page
* [cmake]: De-duplicate "else" to fix build with cmake-3.9
2017-07-15 - lbeltrame@kde.org
- Update to 17.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.3.php
- Changes since 4.14.33:
* Prepare for 4.14.34
2017-06-07 - lbeltrame@kde.org
- Update to 4.14.33
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.2.php
- Changes since 4.14.32:
* Prepare for 4.14.33
2017-05-17 - lbeltrame@kde.org
- Update to 4.14.32
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 4.14.31:
* Verify that whoever is calling us is actually who he says he is
* Prepare for 4.14.32
* http slave: send error page after authorization failure (kde#373323)
- Drop upstreamed patches:
* fix-kauth-bypass-CVE-2017-8422.patch

See Also

Package Description
libkde4-4.14.38-lp150.5.34.x86_64.rpm KDE Base Libraries
libkde4-devel-4.14.38-lp150.5.34.x86_64.rpm KDE Base Libraries: Build Environment
libkdecoration2-devel-32bit-5.12.5-lp150.1.2.x86_64.rpm KDE's window decorations library (development package)
libkdecoration2-devel-5.12.5-lp150.1.2.x86_64.rpm KDE's window decorations library (development package)
libkdecorations2-5-32bit-5.12.5-lp150.1.2.x86_64.rpm KDE's window decorations library
libkdecorations2-5-5.12.5-lp150.1.2.x86_64.rpm KDE's window decorations library
libkdecorations2private5-32bit-5.12.5-lp150.1.2.x86_64.rpm KDE's window decorations library
libkdecorations2private5-5.12.5-lp150.1.2.x86_64.rpm KDE's window decorations library
libkdecore4-32bit-4.14.38-lp150.5.34.x86_64.rpm KDE Core Libraries
libkdecore4-4.14.38-lp150.5.34.x86_64.rpm KDE Core Libraries
libkdecore4-devel-4.14.38-lp150.5.34.x86_64.rpm KDE Core Libraries: Build Environment
libkdegames-17.12.3-lp150.1.1.x86_64.rpm General Data for KDE Games
libkdegames-devel-17.12.3-lp150.1.1.x86_64.rpm Library for KDE Games: Build Environment
libkdegames-lang-17.12.3-lp150.1.1.noarch.rpm Translations for package libkdegames
libkdegames4-14.12.3-lp150.1.3.x86_64.rpm General Data for KDE Games
Advertisement
Advertisement