libgmp10-32bit-6.1.2-lp150.2.20.x86_64.rpm


Advertisement

Description

libgmp10-32bit - Shared library for the GNU MP Library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package filename libgmp10-32bit-6.1.2-lp150.2.20.x86_64.rpm
Package name libgmp10-32bit
Package version 6.1.2
Package release lp150.2.20
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://gmplib.org/
License GPL-3.0+ and LGPL-3.0+
Maintainer -
Download size 253.32 KB
Installed size 566.83 KB
A library for calculating huge numbers (integer and floating point).

Alternatives

Package Version Architecture Repository
libgmp10-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.7) -

Provides

Name Value
libgmp.so.10 -
libgmp10-32bit = 6.1.2-lp150.2.20
libgmp10-32bit(x86-32) = 6.1.2-lp150.2.20

Obsoletes

Name Value
gmp-32bit -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgmp10-32bit-6.1.2-lp150.2.20.x86_64.rpm
Source Package gmp-6.1.2-lp150.2.20.src.rpm

Install Howto

Install libgmp10-32bit rpm package:

# zypper install libgmp10-32bit

Files

Path
/usr/lib/libgmp.so.10
/usr/lib/libgmp.so.10.3.2

Changelog

2018-02-22 - fvogt@suse.com
- Use %license (boo#1082318)
2017-02-09 - dimstar@opensuse.org
- Explicitly BuildRequire m4
2017-01-04 - rguenther@suse.com
- Update to GMP 6.1.2 release.
* Mini-GMP: Fixed a division bug, which on a machine with 64-bit
unsigned long affects approximately 1 out of 2^32 divisors.
* Mini-GMP: Fix mpz_set_str crash on inputs with a large number of
leading zeros. Also stricter input validation, rejecting inputs
with no digits.
* Handle more systems which require PIC code in static libraries (e.g.,
"hardened" Gentoo and Debian 9).
* Configuration for arm (-32 and -64) has been rewritten, fixing poor
code selection for many CPUs.
* Mini-GMP: Updated to the latest development version, including
new functions mpn_com and mpn_neg.
- Add gmp-6.1.2-conftest.patch to fix configure test.
2016-06-30 - mpluskal@suse.com
- Use macro for configure (as bsc#870358) is already fixed
- Use xz compressed archives
- Update info pages dependencies
2016-06-23 - astieger@suse.com
- gmp 6.1.1:
* Work around faulty cpuid on some recent Intel chips (this
allows GMP to run on Skylake Pentiums).
2015-11-02 - rguenther@suse.com
- Update to GMP 6.1.0 release.
* New C++ functions gcd and lcm for mpz_class
* New public mpn functions mpn_divexact_1, mpn_zero_p, and mpn_cnd_swap
* New public mpq_cmp_z function, to efficiently compare rationals with
integers
* Support for more 32-bit arm processors
* Support for AVX-less modern x86 CPUs
* Speedups and bugfixes
- Includes gmp-6.0.0-ppc64-gcd.diff, now removed
- Update gmp keyring
2015-02-24 - mpluskal@suse.com
- Remove old ppc related conditionals
2015-02-24 - mpluskal@suse.com
- Cleanup spec file with spec-cleaner
- Refresh sources
- Add gpg signature
- Correct version number so that it matches actuall version
2014-11-17 - schwab@suse.de
- Make gmp-noexec.diff compatible with arm
- Use correct version number
2014-11-07 - afaerber@suse.de
- Fix tarball directory name to unbreak build

See Also

Package Description
libgmp10-6.1.2-lp150.2.20.x86_64.rpm Shared library for the GNU MP Library
libgmpxx4-32bit-6.1.2-lp150.2.20.x86_64.rpm C++ bindings for the GNU MP Library
libgmpxx4-6.1.2-lp150.2.20.x86_64.rpm C++ bindings for the GNU MP Library
libgnome-2.32.2+20170910.8487c2b4-lp150.1.2.x86_64.rpm The GNOME 2.x Desktop Base Libraries
libgnome-32bit-2.32.2+20170910.8487c2b4-lp150.1.2.x86_64.rpm The GNOME 2.x Desktop Base Libraries
libgnome-autoar-0-0-0.2.3-lp150.1.1.x86_64.rpm Automatic archives creating and extracting library
libgnome-autoar-gtk-0-0-0.2.3-lp150.1.1.x86_64.rpm Automatic archives creating and extracting library
libgnome-bluetooth13-3.26.1-lp150.2.1.x86_64.rpm GNOME Bluetooth graphical utilities
libgnome-desktop-2-17-2.32.1-lp150.2.1.x86_64.rpm The GNOME Desktop API Library
libgnome-desktop-2-17-32bit-2.32.1-lp150.2.1.x86_64.rpm The GNOME Desktop API Library
libgnome-desktop-2-devel-2.32.1-lp150.2.1.x86_64.rpm The GNOME Desktop API Library -- Development Files
libgnome-desktop-3-12-3.26.2-lp150.2.2.x86_64.rpm The GNOME Desktop API Library
libgnome-desktop-3-12-32bit-3.26.2-lp150.2.2.x86_64.rpm The GNOME Desktop API Library
libgnome-desktop-3-devel-3.26.2-lp150.2.2.x86_64.rpm Development files for the GNOME Desktop API library
libgnome-desktop-3_0-common-3.26.2-lp150.2.2.x86_64.rpm Common data files for the GNOME Desktop API library
Advertisement
Advertisement