libgcc_s1-32bit-7.3.1+r258812-lp150.2.10.x86_64.rpm


Advertisement

Description

libgcc_s1-32bit - C compiler runtime library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package filename libgcc_s1-32bit-7.3.1+r258812-lp150.2.10.x86_64.rpm
Package name libgcc_s1-32bit
Package version 7.3.1+r258812
Package release lp150.2.10
Package architecture x86_64
Package type rpm
Category System/Base
Homepage http://gcc.gnu.org/
License GPL-3.0-with-GCC-exception
Maintainer -
Download size 60.61 KB
Installed size 105.57 KB
Libgcc is needed for dynamically linked C programs.

Alternatives

Package Version Architecture Repository
libgcc_s1-32bit-8.2.1+r264010-lp150.3.3.x86_64.rpm 8.2.1+r264010 x86_64 openSUSE Update Oss
libgcc_s1-32bit - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.2.4) -

Provides

Name Value
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.3) -
libgcc_s.so.1(GCC_3.3.1) -
libgcc_s.so.1(GCC_3.4) -
libgcc_s.so.1(GCC_3.4.2) -
libgcc_s.so.1(GCC_4.0.0) -
libgcc_s.so.1(GCC_4.2.0) -
libgcc_s.so.1(GCC_4.3.0) -
libgcc_s.so.1(GCC_4.4.0) -
libgcc_s.so.1(GCC_4.5.0) -
libgcc_s.so.1(GCC_4.7.0) -
libgcc_s.so.1(GCC_4.8.0) -
libgcc_s.so.1(GCC_7.0.0) -
libgcc_s.so.1(GLIBC_2.0) -
libgcc_s1-32bit = 7.3.1+r258812-lp150.2.10
libgcc_s1-32bit(x86-64) = 7.3.1+r258812-lp150.2.10

Conflicts

Name Value
libgcc_s1-32bit -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgcc_s1-32bit-7.3.1+r258812-lp150.2.10.x86_64.rpm
Source Package gcc7-7.3.1+r258812-lp150.2.10.src.rpm

Install Howto

Install libgcc_s1-32bit rpm package:

# zypper install libgcc_s1-32bit

Files

Path
/lib/libgcc_s.so.1

Changelog

2018-04-18 - rguenther@suse.com
- Update gcc7-bnc1087550.diff with latest changes.  [bnc#1087550]
2018-04-11 - rguenther@suse.com
- Update gcc7-bnc1087550.diff with fix from upstream that supports
both ABIs for ios_base::failure.  [bnc#1087550]
2018-04-09 - rguenther@suse.com
- Set SUSE_ASNEEDED to zero during %install so libasan keeps its
NEEDED entry for libstdc++.so.  [GCC#84428]
2018-04-06 - rguenther@suse.com
- Enable --enable-fix-cortex-a53-835769 for aarch64.
- Add gcc7-bnc1087550.diff to revert the ios_base::failure ABI
back to compatible behavior with the default ABI.  [bnc#1087550]
2018-04-03 - rguenther@suse.com
- Update to gcc-7-branch head (r258812).
* Picks fix to no longer enable -mpc-relative-literal-loads by default
with --enable-fix-cortex-a53-843419.
- Enable --enable-fix-cortex-a53-843419 on aarch64.  [bnc#1084812]
[bnc#1087930]
2018-03-07 - rguenther@suse.com
- Update to gcc-7-branch head (r258313).
* includes spectre V2 mitigation patch for s390x.  [bnc#1083946]
2018-03-01 - rguenther@suse.com
- Fix nvptx offload target compiler install so GCC can pick up
required files.  Split out the newlib part into cross-nvptx-newlib7-devel
and avoid conflicts with GCC 8 variant via Provides/Conflicts
of cross-nvptx-newlib-devel.
2018-02-27 - mliska@suse.cz
- Update to gcc-7-branch head (r258025).
* includes fix for chromium build failure.  [bnc#1083290]
2018-02-26 - rguenther@suse.com
- Update to gcc-7-branch head (r257981).
- Add conflicts to non-bootstrap variant for cross packages to silence
repo-checker.
- Amend gcc48-remove-mpfr-2.4.0-requirement.patch to fix build on SLE11.
2018-02-01 - rguenther@suse.com
- Use %{?_smp_mflags} everywhere.
- Update _constraints to bump physicalmemory and general simplification.

See Also

Package Description
libgcc_s1-7.3.1+r258812-lp150.2.10.x86_64.rpm C compiler runtime library
libgcin-im-client1-2.8.5-lp150.1.15.x86_64.rpm Share libraries of gcin
libgcin-im-client1-32bit-2.8.5-lp150.1.15.x86_64.rpm Share libraries of gcin
libgck-1-0-3.20.0-lp150.2.3.x86_64.rpm GObject library to access for PKCS#11 modules
libgck-1-0-32bit-3.20.0-lp150.2.3.x86_64.rpm GObject library to access for PKCS#11 modules
libgck-devel-3.20.0-lp150.2.3.x86_64.rpm GObject library to access for PKCS#11 modules - Development Files
libgck-devel-32bit-3.20.0-lp150.2.3.x86_64.rpm GObject library to access for PKCS#11 modules - Development Files
libgck-modules-gnome-keyring-3.20.1-lp150.2.2.x86_64.rpm Glib wrapper library for PKCS#11 - Modules
libgconfmm-2_6-1-2.28.3-lp150.2.1.x86_64.rpm C++ Interface for GConf
libgcr-3-1-3.20.0-lp150.2.3.x86_64.rpm Library for Crypto UI related task
libgcr-3-1-32bit-3.20.0-lp150.2.3.x86_64.rpm Library for Crypto UI related task
libgcr-devel-3.20.0-lp150.2.3.x86_64.rpm Library for Crypto UI related task - Development Files
libgcr-devel-32bit-3.20.0-lp150.2.3.x86_64.rpm Library for Crypto UI related task - Development Files
libgcrypt-cavs-1.8.2-lp150.4.2.x86_64.rpm The GNU Crypto Library
libgcrypt-devel-1.8.2-lp150.4.2.x86_64.rpm The GNU Crypto Library
Advertisement
Advertisement