libdbusmenu-jsonloader4-16.04.0-lp150.2.1.x86_64.rpm


Advertisement

Description

libdbusmenu-jsonloader4 - Small library that passes a menu structure across DBus -- Test library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package filename libdbusmenu-jsonloader4-16.04.0-lp150.2.1.x86_64.rpm
Package name libdbusmenu-jsonloader4
Package version 16.04.0
Package release lp150.2.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://launchpad.net/dbusmenu
License GPL-3.0-only AND (LGPL-2.1-only OR LGPL-3.0-only)
Maintainer -
Download size 32.14 KB
Installed size 82.62 KB
This package contains the shared libraries for dbusmenu-jsonloader, a library
meant for test suites.

Alternatives

Package Version Architecture Repository
libdbusmenu-jsonloader4 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
libdbusmenu-glib.so.4()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libjson-glib-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
libdbusmenu-jsonloader.so.4()(64bit) -
libdbusmenu-jsonloader4 = 16.04.0-lp150.2.1
libdbusmenu-jsonloader4(x86-64) = 16.04.0-lp150.2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libdbusmenu-jsonloader4-16.04.0-lp150.2.1.x86_64.rpm
Source Package libdbusmenu-16.04.0-lp150.2.1.src.rpm

Install Howto

Install libdbusmenu-jsonloader4 rpm package:

# zypper install libdbusmenu-jsonloader4

Files

Path
/usr/lib64/libdbusmenu-jsonloader.so.4
/usr/lib64/libdbusmenu-jsonloader.so.4.0.12
/usr/share/doc/packages/libdbusmenu-jsonloader4/NEWS
/usr/share/licenses/libdbusmenu-jsonloader4/COPYING
/usr/share/licenses/libdbusmenu-jsonloader4/COPYING-GPL3
/usr/share/licenses/libdbusmenu-jsonloader4/COPYING.2.1

Changelog

2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2016-09-08 - dimstar@opensuse.org
- Use proper libdbusmenu 16.04.0 tarball directly from launchpad:
+ The old tarball's configure.ac happened to still use an old
version, causing the .pc file to advertise insufficient
capabilities.
2016-03-04 - sor.alexei@meowr.ru
- Update to 12.10.3+bzr20160223 (changes since 12.10.3+bzr20150410):
* Disable test-json-instruction, hangs on builds (lp#1429291).
* gtk: Look for GtkImages on regular GtkMenuItems too (lp#1549021).
2015-05-05 - sor.alexei@meowr.ru
- Update to 12.10.3+bzr20150410 (changes since 12.10.3+bzr20140610):
* Use the configure-generated libtool script instead of
/usr/bin/libtool, which might not match what we have.
* Use gi's typelibdir pkgconfig variable and install into this
directory, now that gi supports multiarch.
* Parser: don't override the label for stock items if a custom
one is provided.
- Minor spec cleanup.
2014-10-26 - p.drouand@gmail.com
- Update to version 12.10.3+14.10.20140610
+ No changelog available
2014-03-10 - cfarrell@suse.com
- license update: GPL-3.0 and (LGPL-2.1 or LGPL-3.0)
Interaction is not aggregation (^and^) but rather option (^or^). Also,
the GPL-3.0 components are in the separate tools/ subdirectory
2014-03-07 - hrvoje.senjan@gmail.com
- Init libdbusmenu package

See Also

Package Description
libdbusmenu-qt-devel-0.9.2+14.04.20131209-lp150.1.9.x86_64.rpm Development package for libdbusmenu-qt
libdbusmenu-qt2-0.9.2+14.04.20131209-lp150.1.9.x86_64.rpm Development package for dbusmenu-qt
libdbusmenu-qt2-32bit-0.9.2+14.04.20131209-lp150.1.9.x86_64.rpm Development package for dbusmenu-qt
libdbusmenu-qt5-2-0.9.3+15.10.20150604-lp150.1.14.x86_64.rpm Development package for dbusmenu-qt5
libdbusmenu-qt5-2-32bit-0.9.3+15.10.20150604-lp150.1.14.x86_64.rpm Development package for dbusmenu-qt5
libdbusmenu-qt5-devel-0.9.3+15.10.20150604-lp150.1.14.x86_64.rpm Development package for libdbusmenu-qt5
libdbusmenu-qt5-devel-32bit-0.9.3+15.10.20150604-lp150.1.14.x86_64.rpm Development package for libdbusmenu-qt5
libdbusmenu-tools-16.04.0-lp150.2.1.x86_64.rpm Development tools for the dbusmenu libraries
libdc1394-22-2.2.5-lp150.1.13.x86_64.rpm 1394-based Digital Camera Control library
libdc1394-22-32bit-2.2.5-lp150.1.13.x86_64.rpm 1394-based Digital Camera Control library
libdc1394-devel-2.2.5-lp150.1.13.x86_64.rpm Development libraries and header files for dc1394
libdc1394-tools-2.2.5-lp150.1.13.x86_64.rpm Command-line utilities from libdc1394
libdcerpc-binding0-32bit-4.7.6+git.54.6e3276c9872-lp150.2.20.x86_64.rpm Some samba library
libdcerpc-binding0-4.7.6+git.54.6e3276c9872-lp150.2.20.x86_64.rpm Some samba library
libdcerpc-devel-4.7.6+git.54.6e3276c9872-lp150.2.20.x86_64.rpm Development files for the DCE/RPC library
Advertisement
Advertisement