ktexteditor-5.45.0-lp150.1.1.x86_64.rpm


Advertisement

Description

ktexteditor - Provides a powerful text editor component

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package filename ktexteditor-5.45.0-lp150.1.1.x86_64.rpm
Package name ktexteditor
Package version 5.45.0
Package release lp150.1.1
Package architecture x86_64
Package type rpm
Category System/GUI/KDE
Homepage http://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 1.20 MB
Installed size 3.71 MB
KTextEditor provides a powerful text editor component that you can embed in your
application, either as a KPart or using the KF5::TextEditor library.

Alternatives

Package Version Architecture Repository
ktexteditor-5.58.0git.20190502T151313~743cbe13-ku.84.1.x86_64.rpm 5.58.0git.20190502T151313~743cbe13 x86_64 KDE Frameworks Unstable
ktexteditor-5.58.0-lp150.185.1.x86_64.rpm 5.58.0 x86_64 KDE Frameworks 5
ktexteditor - - -

Requires

Name Value
/sbin/ldconfig -
libKF5Archive.so.5()(64bit) -
libKF5Auth.so.5()(64bit) -
libKF5Codecs.so.5()(64bit) -
libKF5Completion.so.5()(64bit) -
libKF5ConfigCore.so.5()(64bit) -
libKF5ConfigGui.so.5()(64bit) -
libKF5ConfigWidgets.so.5()(64bit) -
libKF5CoreAddons.so.5()(64bit) -
libKF5GuiAddons.so.5()(64bit) -
libKF5I18n.so.5()(64bit) -
libKF5IconThemes.so.5()(64bit) -
libKF5ItemViews.so.5()(64bit) -
libKF5JobWidgets.so.5()(64bit) -
libKF5KIOCore.so.5()(64bit) -
libKF5KIOWidgets.so.5()(64bit) -
libKF5Parts.so.5()(64bit) -
libKF5SonnetCore.so.5()(64bit) -
libKF5SonnetUi.so.5()(64bit) -
libKF5SyntaxHighlighting.so.5()(64bit) -
libKF5TextWidgets.so.5()(64bit) -
libKF5WidgetsAddons.so.5()(64bit) -
libKF5XmlGui.so.5()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.9)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5PrintSupport.so.5()(64bit) -
libQt5PrintSupport.so.5(Qt_5)(64bit) -
libQt5Qml.so.5()(64bit) -
libQt5Qml.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libQt5Xml.so.5()(64bit) -
libQt5Xml.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libeditorconfig.so.0()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.4)(64bit) -
libgit2.so.26()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
syntax-highlighting >= 5.45.0.

Provides

Name Value
ktexteditor = 5.45.0-lp150.1.1
ktexteditor(x86-64) = 5.45.0-lp150.1.1
libKF5TextEditor.so.5()(64bit) -

Obsoletes

Name Value
libKF5TextEditor4 -
libKF5TextEditor5 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ktexteditor-5.45.0-lp150.1.1.x86_64.rpm
Source Package ktexteditor-5.45.0-lp150.1.1.src.rpm

Install Howto

Install ktexteditor rpm package:

# zypper install ktexteditor

Files

Path
/usr/lib64/libKF5TextEditor.so.5
/usr/lib64/libKF5TextEditor.so.5.45.0
/usr/lib64/qt5/plugins/
/usr/lib64/qt5/plugins/kf5/
/usr/lib64/qt5/plugins/kf5/parts/katepart.so
/usr/share/doc/packages/ktexteditor/COPYING.GPL-2
/usr/share/doc/packages/ktexteditor/COPYING.LGPL-2
/usr/share/doc/packages/ktexteditor/COPYING.LIB
/usr/share/doc/packages/ktexteditor/README.md
/usr/share/katepart5/
/usr/share/katepart5/script/README.md
/usr/share/kdevappwizard/
/usr/share/kdevappwizard/templates/ktexteditor-plugin.tar.bz2
/usr/share/kservices5/katepart.desktop
/usr/share/kservicetypes5/ktexteditor.desktop
/usr/share/kservicetypes5/ktexteditorplugin.desktop

Changelog

2018-04-18 - wbauer@tmo.at
- Add Fix-font-attributes.patch to fix missing bold/italic/...
markup with modern Qt versions (>= 5.9)
2018-04-14 - lbeltrame@kde.org
- Update to 5.45.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.45.0.php
- Changes since 5.44.0:
* Make it possible for KTextEditor to build on Android NDK's gcc 4.9
* avoid Asan runtime error: shift exponent -1 is negative
* We depend against 5.8.0
* optimization of TextLineData::attribute
* Don't calculate attribute() twice.
* Revert Fix: View jumps when Scroll past end of document is enabled (kde#391838)
* don't pollute the clipboard history with dupes
* Revert "[KateCompletionWidget] Create configuration interface on demand" (kde#391955)
* [KateCompletionWidget] Create configuration interface on demand
* Remove not necessary QtCore and co
2018-03-12 - lbeltrame@kde.org
- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Initialize value
* Iterate over initializer_lists to avoid mem allocs
* Add icons for KTextEditor Document-Export, Bookmark-Remove and Formatting Text Upppercase, Lowercase and Capitalize
2018-02-12 - lbeltrame@kde.org
- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* improve line heigh computation try to avoid cutting of parts of glyphs
* Fix: View jumps when Scroll past end of document is enabled (kde#306745)
* KateView unit test: simplify finding KateViewInternal
* Use at least the requested width for the argument hint tree
* ExpandingWidgetModel: find the right-most column based on location
* Simplify code: return early to reduce indentation depth
2018-01-16 - lbeltrame@kde.org
- Update to 5.42.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.42.0.php
- Changes since 5.41.0:
* Remove obsolete reviewboardrc file
* clang-tidy modernize-use-override
* Fix wildcard matching for modelines
* Fix Unit Test
* Fix compilation
* Fix a regression caused by changing backspace key behavior
* port to non-deprecated API like already used at other place (kde#386823)
* Add missing include for std::array
* MessageInterface: Add CenterInView as additional position
* Verify if QTest::qWaitForWindowExposed returns true
* QStringList initializer list cleanup
* Migrate some QRegExps to QRegularExpression
* Fix warning about unused variable
* Fix syntax unit tests
* Fix API documentation about RangeCommand
2017-12-17 - lbeltrame@kde.org
- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Use directly QStringLiteral
* We depend against 5.7
* API dox: fix section id
* Plugin template: remove bogus translation strings
* Fix VI-Mode buffer commands
* Remove unused member variable
* prevent accidental zooming.
* autotests: Remove dep on Qt5::Script again
* Fix: Missing dependencies for ktexeditor autotests
2017-11-13 - lbeltrame@kde.org
- Update to 5.40.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.40.0.php
- Changes since 5.39.0:
* API dox: fix wrong names of methods and args, add missing \since
* Avoid (certain) crashes while executing QML scripts (kde#385413)
* Avoid a QML crash triggered by C style indentation scripts
* - Increase size of trailing mark
* add autotests for D8333
* fix some indenters from indenting on random characters
* Fix deprecation warning
- Remove patches, now upstream:
* fix-some-indenters-from-indenting-on-random-characters.patch
2017-10-24 - wbauer@tmo.at
- Add fix-some-indenters-from-indenting-on-random-characters.patch
to fix broken indentation of some languages (e.g. Python)

See Also

Package Description
ktexteditor-devel-32bit-5.45.0-lp150.1.1.x86_64.rpm Provides a powerful text editor component
ktexteditor-devel-5.45.0-lp150.1.1.x86_64.rpm Provides a powerful text editor component
ktexteditor-lang-5.45.0-lp150.1.1.noarch.rpm Translations for package ktexteditor
ktextwidgets-devel-32bit-5.45.0-lp150.1.1.x86_64.rpm KDE Text editing widgets: Build Environment
ktextwidgets-devel-5.45.0-lp150.1.1.x86_64.rpm KDE Text editing widgets: Build Environment
ktimer-17.12.3-lp150.1.1.x86_64.rpm Countdown Launcher
ktimer-lang-17.12.3-lp150.1.1.noarch.rpm Translations for package ktimer
ktnef-17.12.3-lp150.1.2.x86_64.rpm Viewer for email attachments in TNEF format
ktnef-devel-17.12.3-lp150.1.1.x86_64.rpm KDE PIM Libraries: Build Environment
ktnef-lang-17.12.3-lp150.1.1.noarch.rpm Translations for package ktnef
ktoblzcheck-1.48-lp150.1.3.x86_64.rpm A library to check account numbers and bank codes of German banks
ktoblzcheck-devel-1.48-lp150.1.3.x86_64.rpm KtoBLZCheck development files
ktorrent-5.1.0-lp150.2.10.x86_64.rpm KDE BitTorrent Client
ktorrent-lang-5.1.0-lp150.2.10.noarch.rpm Translations for package ktorrent
ktouch-17.12.3-lp150.1.2.x86_64.rpm Touch Typing Tutor
Advertisement
Advertisement