gv-3.7.4-lp150.1.7.x86_64.rpm


Advertisement

Description

gv - A Program to View PostScript Files

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gv
Package version 3.7.4
Package release lp150.1.7
Package architecture x86_64
Package type rpm
Installed size 671.74 KB
Download size 195.46 KB
Official Mirror widehat.opensuse.org
GV offers you an X Window System GUI for viewing PostScript files. This
is an X Window System interface to ghostscript.
Authors:
--------
Tim Theisen <tim@cs.wisc.edu>
Johannes Plass <plass@dipmza.physik.uni-mainz.de>

Alternatives

Package Version Architecture Repository
gv - - -

Requires

Name Value
/usr/bin/perl -
ghostscript_x11 -
info -
libX11.so.6()(64bit) -
libXaw3d.so.8()(64bit) -
libXinerama.so.1()(64bit) -
libXmu.so.6()(64bit) -
libXt.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libzio.so.1()(64bit) -

Provides

Name Value
application() -
application(gv.desktop) -
config(gv) = 3.7.4-lp150.1.7
gv = 3.7.4-lp150.1.7
gv(x86-64) = 3.7.4-lp150.1.7
mimehandler(application/illustrator) -
mimehandler(application/pdf) -
mimehandler(application/postscript) -
mimehandler(image/x-eps) -

Conflicts

Name Value
gs_serv -
gs_vga -

Download

Type URL
Binary Package gv-3.7.4-lp150.1.7.x86_64.rpm
Source Package gv-3.7.4-lp150.1.7.src.rpm

Install Howto

Install gv rpm package:

# zypper install gv

Files

Path
/usr/bin/gv
/usr/bin/gv-update-userconfig
/usr/share/X11/app-defaults/GV
/usr/share/X11/gv/gv_system.ad
/usr/share/X11/gv/safe-gs-workdir/
/usr/share/X11/ja_JP.EUC-JP/
/usr/share/X11/ja_JP.EUC-JP/app-defaults/GV
/usr/share/X11/ja_JP.SJIS/
/usr/share/X11/ja_JP.SJIS/app-defaults/GV
/usr/share/X11/ja_JP.UTF-8/
/usr/share/X11/ja_JP.UTF-8/app-defaults/GV
/usr/share/X11/ko_KR.EUC-KR/
/usr/share/X11/ko_KR.EUC-KR/app-defaults/GV
/usr/share/X11/ko_KR.UTF-8/
/usr/share/X11/ko_KR.UTF-8/app-defaults/GV
/usr/share/applications/gv.desktop
/usr/share/doc/packages/gv/Copyright
/usr/share/info/gv.info.gz
/usr/share/man/man1/gv-update-userconfig.1.gz
/usr/share/man/man1/gv.1.gz
/usr/share/pixmaps/gv.png

Changelog

2013-12-09 - werner@suse.de
- Update to gv 3.7.4
* Fixed CVE-2012-3386 (by using updated automake)
* Fixed bug-gv] Problem after saving gv-settings
* improve wording of gv-update-userconfig manual
* Scrolling and memory access improved
* README.I18N adjusted for libXaw3d 1.6.x
* Fixed GNU gv 3.6.4 - 3.7.3 page selector button geometry bug
* Support for libXaw3d-1.6.x
* Updated Translations
* Reverted fix of debian bug #594991: unexpected scrolling of the TOC widget",
this fixes the following bug:
* Pressng END does not scroll TOC wodget.
* Fixed "Save document" dialog for PDF files
* Fix debian bug 627471: gv: fails to read bounding box (depending on the
command line!), see http://bugs.debian.org/627471 for details
* ignore resource and style files without absolute paths
(in order to improve security)
* Do not install files that re not used
* avoid make distcheck failing because of gv-i18n.h
* Update gnulib, import signal,
* this should fix compiling on Mac OS again
* Improved handling of DSC parse errors
* Varuos code cleanups - for details see either CHANGELOG or the git repotory.
2013-03-28 - mmeister@suse.com
- Added url as source.
Please see http://en.opensuse.org/SourceUrls
2013-02-26 - werner@suse.de
- Add patch gv-3.7.2-libzio.dif: make libzio usable (bnc#805149)
2013-02-22 - werner@suse.de
- Update to gv 3.7.2
* "Fit to window magnification" and "Fit width to window magnification" with
"Automatic resizing" turned on sometime miss rescaling, especially when
changing the orientation or resizing the window.
* Interactive prompting for the password of encrypted PDF files do not work
if and only if DSC is turned off.
* Fix Debian bug #594991: unexpected scrolling of the TOC widget
* Fixed file descriptor leak
* Added Dutch, French, Italian and Spanish translation
* Code cleanup
* Fix bug: unable to print/save pdf files.
- This update fixes bnc#805149
2012-09-08 - idonmez@suse.com
- Add explicit build requires on makeinfo
2011-12-01 - coolo@suse.com
- add automake as buildrequire to avoid implicit dependency
2011-01-12 - werner@suse.de
- Update to gv 3.7.0
* Support starting ghostscript from a safe directory.
* ghostscript is startet with -P- if SAFER is enabled.
* ghostscript is startet with -dSAFER and -dDELAYSAFER for "pdf2dsc"
and "pdf2ps" if safer is enabled
* Support for localised user interfaces
* Bugfix in gv-update-userconfig
* Fixed compiling on Xaw3d 1.5.
* UTF-8 Support. Read the included file README.I18N for details.
- Remove apLineDelSym key as this one is not defined (bnc#662578)
2010-06-08 - werner@suse.de
- Update to gv 3.6.8
* Includes both our settitle and I18N patch
* Includes security fix for bnc#610933
2010-02-24 - werner@suse.de
- Update to gv 3.6.8
* Various fixes
+ DSC parser now respects the level of BeginDocument/EndDocument
+ Possible segfault has been fixed
+ Fixed bug #21239: Vlist.c produces garbage if International is set
+ Fixed bug #21740: popup windows may partly invisible as not on the screen
+ The escape key is now working in more contexts
+ The filename can optionally be shown insted of the title
+ Fixed bug #23199: No error message for errors in opened file
+ Got rid of non-free code.
* New feartures
2010-02-24 - werner@suse.de
- Ensure that button and titles are reset to its default values (bnc#582290)

See Also

Package Description
gvfs-1.34.2.1-lp150.2.5.x86_64.rpm Virtual File System functionality for GLib
gvfs-32bit-1.34.2.1-lp150.2.5.x86_64.rpm Virtual File System functionality for GLib
gvfs-backend-afc-1.34.2.1-lp150.2.5.x86_64.rpm VFS functionality for GLib -- iPod / iPhone Support
gvfs-backend-samba-1.34.2.1-lp150.2.5.x86_64.rpm VFS functionality for GLib -- Samba Support
gvfs-backends-1.34.2.1-lp150.2.5.x86_64.rpm VFS functionality for GLib
gvfs-devel-1.34.2.1-lp150.2.5.x86_64.rpm Development files for the GNOME Virtual file system
gvfs-fuse-1.34.2.1-lp150.2.5.x86_64.rpm VFS functionality for GLib
gvfs-lang-1.34.2.1-lp150.2.5.noarch.rpm Translations for package gvfs
gvim-8.0.1568-lp150.3.1.x86_64.rpm A GUI for Vi
gweather-data-3.26.1-lp150.1.5.noarch.rpm Auxiliary schema data for libgweather
gwenhywfar-4.18.0-lp150.1.5.x86_64.rpm Multiplatform helper library for other libraries
gwenhywfar-devel-4.18.0-lp150.1.5.x86_64.rpm Multi-Platform Helper Library for Other Libraries
gwenhywfar-lang-4.18.0-lp150.1.5.noarch.rpm Translations for package gwenhywfar
gwenhywfar-tools-4.18.0-lp150.1.5.x86_64.rpm Multiplatform Helper Library for Other Libraries - Tools
gwenview5-17.12.3-lp150.1.3.x86_64.rpm Image Viewer for KDE
Advertisement
Advertisement