gtkspell-devel-2.0.16-lp150.3.3.x86_64.rpm


Advertisement

Description

gtkspell-devel - Static libraries and header files from gtkspell

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gtkspell-devel
Package version 2.0.16
Package release lp150.3.3
Package architecture x86_64
Package type rpm
Installed size 1.65 KB
Download size 10.64 KB
Official Mirror widehat.opensuse.org
Static libraries and header files from gtkspell.

Alternatives

Package Version Architecture Repository
gtkspell-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libgtkspell0 = 2.0.16
pkgconfig(gtk+-2.0) -

Provides

Name Value
gtkspell-devel = 2.0.16-lp150.3.3
gtkspell-devel(x86-64) = 2.0.16-lp150.3.3
pkgconfig(gtkspell-2.0) = 2.0.16

Download

Type URL
Binary Package gtkspell-devel-2.0.16-lp150.3.3.x86_64.rpm
Source Package gtkspell-2.0.16-lp150.3.3.src.rpm

Install Howto

Install gtkspell-devel rpm package:

# zypper install gtkspell-devel

Files

Path
/usr/include/gtkspell-2.0/
/usr/include/gtkspell-2.0/gtkspell/gtkspell.h
/usr/lib64/libgtkspell.so
/usr/lib64/pkgconfig/gtkspell-2.0.pc

Changelog

2017-12-14 - dimstar@opensuse.org
- Replace enchant-devel and gtk2-devel BuildRequires with their
pkgconfig() equivalents: pkgconfig(enchant) and
pkgconfig(gtk+-2.0).
2017-08-15 - zaitor@opensuse.org
- Drop gtk-doc BuildRequires and pass --enable-gtk-doc=no to
configure, needed with gtk-doc 1.26 and newer, as gtkdoc-mktmpl
was dropped from it.
2013-03-01 - dimstar@opensuse.org
- Spec-cleanup using format_spec_file service.
2011-06-17 - vuntz@opensuse.org
- Stop using source service to download the tarball, as Factory
will move away from this.
2011-05-03 - dimstar@opensuse.org
- bnc#691401: SLPP for gtkspell:
+ Create new subpackage libgtkspell0 with gtkspell
Provides/Obsoletes for proper upgrade path.
+ Move -lang Recommends to the lib-package.
- Remove explicit Requires for gtk2-devel,g lib2-devel,
pango-devel, atk-devel and enchant-devel from the -devel package:
they will automatically be added the pkgconfig() way.
- Clean spec file using spec-cleaner.
2011-05-02 - vuntz@opensuse.org
- Remove now unneeded call to autoreconf.
- Do not package .la files.
2011-04-29 - dimstar@opensuse.org
- Update to 2.0.16:
+ Additional and updated translations (see po/ChangeLog).
+ sf#2431005: Language codes that contain "C" (e.g. "cs_CZ")
defaulted to "en"
+ sf#2715972: Remove an extra comma at the end of the
GtkSpellError enum definition.
+ sf#2526949: Sort languages list submenu.
+ sf#2526959: Currently selected language appears with radio
button selection in Language selector sub-menu
+ sf#2642198: Enchant Broker should be a singleton.
+ sf#2875116 Support changing of the GtkTextBuffer in the
attached GtkTextView.
- Use source services: download_url, recompress and set_version.
- Drop gtkspell-locale.patch: fixed upstream.
2011-02-22 - sbrabec@suse.cz
- Added support for translation-update-upstream (bnc#673924).
2010-08-31 - aj@suse.de
- Recommend instead of require lang package since it's not mandatory.
2009-02-10 - pgajdos@suse.cz
- removed redundant aspell-devel from BuildRequires [fate#305688]

See Also

Package Description
gtkspell-doc-2.0.16-lp150.3.3.x86_64.rpm GTK2 Spell Checker Interface Library
gtkspell-lang-2.0.16-lp150.3.3.noarch.rpm Translations for package gtkspell
gtkspell3-devel-3.0.9-lp150.1.7.x86_64.rpm GTK3 Spell Checker Interface Library -- Development Files
gtkspell3-lang-3.0.9-lp150.1.7.noarch.rpm Translations for package gtkspell3
gtkwave-3.3.79-lp150.1.7.x86_64.rpm Waveform viewer for Ditital Signals
gtkwave-doc-3.3.79-lp150.1.7.noarch.rpm Documentation for GTKWave
gtkwave-examples-3.3.79-lp150.1.7.noarch.rpm Examples for GTKWave
gtranslator-2.91.7-lp150.1.8.x86_64.rpm A GNOME po file editor with many bells and whistles
gtranslator-devel-2.91.7-lp150.1.8.x86_64.rpm A GNOME po file editor with many bells and whistles
gtranslator-lang-2.91.7-lp150.1.8.noarch.rpm Translations for package gtranslator
gts-0.7.6_p20121130-lp150.1.8.x86_64.rpm GNU Triangulated Surface Library (GTS)
gts-devel-0.7.6_p20121130-lp150.1.8.x86_64.rpm Development files and documentation for GTS
gtypist-2.9.5-lp150.1.5.x86_64.rpm Universal typing tutor
gtypist-lang-2.9.5-lp150.1.5.x86_64.rpm Language files for package gtypist
guake-3.2.1-lp150.1.1.noarch.rpm Drop-down terminal for GNOME
Advertisement
Advertisement