gtk2-immodule-thai-32bit-2.24.32-lp150.2.3.x86_64.rpm


Advertisement

Description

gtk2-immodule-thai-32bit - Thai-Lao input method for the GTK+ toolkit library v2

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gtk2-immodule-thai-32bit
Package version 2.24.32
Package release lp150.2.3
Package architecture x86_64
Package type rpm
Installed size 9.46 KB
Download size 81.86 KB
Official Mirror widehat.opensuse.org
GTK+ is a multi-platform toolkit for creating graphical user interfaces.
Offering a complete set of widgets, GTK+ is suitable for projects
ranging from small one-off projects to complete application suites.
This package provides an input method for Thai-Lao.

Alternatives

Package Version Architecture Repository
gtk2-immodule-thai-32bit - - -

Requires

Name Value
gtk2-32bit -
libc.so.6(GLIBC_2.1.3) -
libgdk-x11-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk-x11-2.0.so.0 -
libpthread.so.0 -

Provides

Name Value
gtk2-immodule-thai-32bit = 2.24.32-lp150.2.3
gtk2-immodule-thai-32bit(x86-32) = 2.24.32-lp150.2.3

Download

Type URL
Binary Package gtk2-immodule-thai-32bit-2.24.32-lp150.2.3.x86_64.rpm
Source Package gtk2-2.24.32-lp150.2.3.src.rpm

Install Howto

Install gtk2-immodule-thai-32bit rpm package:

# zypper install gtk2-immodule-thai-32bit

Files

Path
/usr/lib/gtk-2.0/
/usr/lib/gtk-2.0/2.10.0/
/usr/lib/gtk-2.0/2.10.0/immodules/im-thai.so

Changelog

2018-03-20 - dimstar@opensuse.org
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
2018-02-26 - dimstar@opensuse.org
- Use SPDX3.0 license tags and package COPYING as %license
2018-01-09 - zaitor@opensuse.org
- Update to version 2.24.32:
+ Fix abicheck.
- Use the release version as revision and set versionformat to
PARENT_TAG, ensure we build the upstream released tag.
2017-12-29 - jengelh@inai.de
- Sync summaries with gtk4.
2017-12-26 - yfjiang@suse.com
- Manually move the position of "Group System/Libraries" line,
which was moved automatically by format_spec_file, above the
comment of "Requires: hicolor-icon-theme":
https://lists.opensuse.org/opensuse-packaging/2017-07/msg00062.html
2017-12-21 - zaitor@opensuse.org
- Update to version 2.24.31+20171209.61d5c82f5c:
+ Fix updating the widget accessible description when using its
tooltip
+ Fix introspection builds on Visual Studio 2017
+ imcontextxim: Fix showing glyph in status window
+ Visual Studio builds: Improve binary security
+ Fixed: If can?t add child, don?t add to child info
+ ComboBox: Don?t let modes disconnect each other
+ Enter submenus when activating their parent item
+ ComboBox: Don?t pile up ::grab-broken handlers
+ testcombo: Test grid :row- and :column-span-column
+ Updated translations.
- Switch to git checkout via source service.
- Following the above, remove gnome-common BuildRequires and
gnome-autogen.sh call. Replace with libtool BuildRequires and
autogen.sh call, also add gtk-doc BuildRequires and pass
- -enable-gtk-doc to configure.
- Clean up patch numbering.
- Drop gtk2-window-dragging.patch: Fixed upstream (bgo#554057).
- Drop bugzilla-131498-allow-xim-for-all-languages.patch: This
patch was only applied to work around a missing recommends for
scim-32Bit, stop doing that, as we should not fix errors in other
packages in a toolkit.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
2017-12-05 - dimstar@opensuse.org
- Switch to using python3:
+ Replace -devel's python2-xml Requires with python3-xml.
+ Add gtk2-converter-python3.patch: convert gtk-build-converter
to be a python3 script.
2017-11-01 - mpluskal@suse.com
- Explicitly require python2 modules for devel package
- Cleanup with spec-cleaner
2017-06-27 - dimstar@opensuse.org
- Migrate %icon_theme_cache_post/postun macro from
hicolor-icon-theme to gtk2-tools file triggers. Any package
installing icons below /usr/share/icons will trigger. Each
package will produce the cache for every icon theme being
updated. The same trigger is also added to gtk3-tools, where only
the one owning the current instance of
/usr/bin/gtk-update-icon-cache update-alternatie link actually
executes the update.
2017-06-14 - olaf@aepfle.de
- Add gtk2-updateiconcache_sort.patch: have gtk-update-icon-cache
sort directory entries when creating caches. The build system
uses this to produce an embedded cache for the stock icons. With
this, we can have reproducible builds.

See Also

Package Description
gtk2-immodule-vietnamese-2.24.32-lp150.2.3.x86_64.rpm Vietnamese input method for the GTK+ toolkit library v2
gtk2-immodule-vietnamese-32bit-2.24.32-lp150.2.3.x86_64.rpm Vietnamese input method for the GTK+ toolkit library v2
gtk2-immodule-xim-2.24.32-lp150.2.3.x86_64.rpm X input method for the GTK+ toolkit library v2
gtk2-immodule-xim-32bit-2.24.32-lp150.2.3.x86_64.rpm X input method for the GTK+ toolkit library v2
gtk2-immodules-tigrigna-2.24.32-lp150.2.3.x86_64.rpm Tigrigna input methods for the GTK+ toolkit library v2
gtk2-immodules-tigrigna-32bit-2.24.32-lp150.2.3.x86_64.rpm Tigrigna input methods for the GTK+ toolkit library v2
gtk2-lang-2.24.32-lp150.2.3.noarch.rpm Translations for package gtk2
gtk2-metatheme-adapta-3.93.1.4-lp150.1.1.noarch.rpm Adapta GTK+2 themes
gtk2-metatheme-adwaita-3.22.3-lp150.2.1.noarch.rpm Adwaita GNOME Theme -- GTK+ 2 Support
gtk2-metatheme-ambiance-16.10~bzr20180122-lp150.1.1.noarch.rpm Ambiance Gtk Theme -- GTK+ 2 Support
gtk2-metatheme-ambiant-mate-17.10.0-lp150.1.3.noarch.rpm Ambiant-MATE Gtk Theme -- GTK+ 2 Support
gtk2-metatheme-arc-20170302-lp150.1.3.noarch.rpm Arc GTK+2 Theme
gtk2-metatheme-breeze-5.12.5-lp150.1.1.noarch.rpm GTK+ theme matching KDE's Breeze -- GTK+ 2 Support
gtk2-metatheme-elementary-5.1.1-lp150.1.2.noarch.rpm The elementary GTK Theme -- GTK+ 2 Support
gtk2-metatheme-equinox-1.50-lp150.1.3.x86_64.rpm Equinox Metathemes for GTK+
Advertisement
Advertisement