gstreamer-validate-1.12.5-lp150.1.1.x86_64.rpm


Advertisement

Description

gstreamer-validate - Validate GStreamer Pipelines

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gstreamer-validate
Package version 1.12.5
Package release lp150.1.1
Package architecture x86_64
Package type rpm
Installed size 1.26 MB
Download size 244.89 KB
Official Mirror widehat.opensuse.org
The goal of GstValidate is to be able to detect when elements are not
behaving as expected and report it to the user so he knows how things
are supposed to work inside a GstPipeline. In the end, fixing issues
found by the tool will ensure that all elements behave all together in
the expected way.
The easiest way of using GstValidate is to use one of its command-line
tools, located at tools/ directory. It is also possible to monitor
GstPipelines from any application by using the LD_PRELOAD gstvalidate
lib. The third way of using it is to write your own application that
links and uses libgstvalidate.

Alternatives

Package Version Architecture Repository
gstreamer-validate-1.14.4-lp150.41.3.x86_64.rpm 1.14.4 x86_64 Multimedia Libs
gstreamer-validate - - -

Requires

Name Value
/usr/bin/env -
libc.so.6(GLIBC_2.14)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgstpbutils-1.0.so.0()(64bit) -
libgstreamer-1.0.so.0()(64bit) -
libgstvalidate-1.0.so.0()(64bit) -
libgstvalidatevideo-1.0.so.0()(64bit) -
libgstvideo-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
gstreamer-validate = 1.12.5-lp150.1.1
gstreamer-validate(x86-64) = 1.12.5-lp150.1.1

Download

Type URL
Binary Package gstreamer-validate-1.12.5-lp150.1.1.x86_64.rpm
Source Package gstreamer-validate-1.12.5-lp150.1.1.src.rpm

Install Howto

Install gstreamer-validate rpm package:

# zypper install gstreamer-validate

Files

Path
/usr/bin/gst-validate-1.0
/usr/bin/gst-validate-images-check-1.0
/usr/bin/gst-validate-launcher
/usr/bin/gst-validate-media-check-1.0
/usr/bin/gst-validate-transcoding-1.0
/usr/lib64/gst-validate-launcher/
/usr/lib64/gst-validate-launcher/python/
/usr/lib64/gst-validate-launcher/python/launcher/RangeHTTPServer.py
/usr/lib64/gst-validate-launcher/python/launcher/__init__.py
/usr/lib64/gst-validate-launcher/python/launcher/baseclasses.py
/usr/lib64/gst-validate-launcher/python/launcher/config.py
/usr/lib64/gst-validate-launcher/python/launcher/httpserver.py
/usr/lib64/gst-validate-launcher/python/launcher/loggable.py
/usr/lib64/gst-validate-launcher/python/launcher/main.py
/usr/lib64/gst-validate-launcher/python/launcher/reporters.py
/usr/lib64/gst-validate-launcher/python/launcher/utils.py
/usr/lib64/gst-validate-launcher/python/launcher/vfb_server.py
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/RangeHTTPServer.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/RangeHTTPServer.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/__init__.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/baseclasses.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/baseclasses.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/config.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/config.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/httpserver.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/httpserver.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/loggable.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/loggable.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/main.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/main.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/reporters.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/reporters.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/utils.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/utils.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/vfb_server.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/__pycache__/vfb_server.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/apps/__init__.py
/usr/lib64/gst-validate-launcher/python/launcher/apps/gstcheck.py
/usr/lib64/gst-validate-launcher/python/launcher/apps/gstvalidate.py
/usr/lib64/gst-validate-launcher/python/launcher/apps/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/apps/__pycache__/__init__.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/apps/__pycache__/gstcheck.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/apps/__pycache__/gstcheck.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/apps/__pycache__/gstvalidate.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/apps/__pycache__/gstvalidate.cpython-36.pyc
/usr/lib64/gst-validate-launcher/python/launcher/testsuites/check.py
/usr/lib64/gst-validate-launcher/python/launcher/testsuites/__pycache__/check.cpython-36.opt-1.pyc
/usr/lib64/gst-validate-launcher/python/launcher/testsuites/__pycache__/check.cpython-36.pyc
/usr/lib64/gstreamer-1.0/
/usr/lib64/gstreamer-1.0/validate/
/usr/share/doc/packages/gstreamer-validate/ChangeLog
/usr/share/doc/packages/gstreamer-validate/README
/usr/share/gstreamer-1.0/
/usr/share/gstreamer-1.0/validate/gst.supp
/usr/share/gstreamer-1.0/validate/gstvalidate.supp
/usr/share/gstreamer-1.0/validate/valgrind.config
/usr/share/gstreamer-1.0/validate/scenarios/adaptive_video_framerate.scenario
/usr/share/gstreamer-1.0/validate/scenarios/adaptive_video_framerate_size.scenario
/usr/share/gstreamer-1.0/validate/scenarios/adaptive_video_size.scenario
/usr/share/gstreamer-1.0/validate/scenarios/alternate_fast_backward_forward.scenario
/usr/share/gstreamer-1.0/validate/scenarios/change_state_intensive.scenario
/usr/share/gstreamer-1.0/validate/scenarios/disable_subtitle_track_while_paused.scenario
/usr/share/gstreamer-1.0/validate/scenarios/fast_backward.scenario
/usr/share/gstreamer-1.0/validate/scenarios/fast_forward.scenario
/usr/share/gstreamer-1.0/validate/scenarios/force_key_unit.scenario
/usr/share/gstreamer-1.0/validate/scenarios/pause_resume.scenario
/usr/share/gstreamer-1.0/validate/scenarios/play_15s.scenario
/usr/share/gstreamer-1.0/validate/scenarios/reverse_playback.scenario
/usr/share/gstreamer-1.0/validate/scenarios/scrub_backward_seeking.scenario
/usr/share/gstreamer-1.0/validate/scenarios/scrub_backward_seeking_full.scenario
/usr/share/gstreamer-1.0/validate/scenarios/scrub_forward_seeking.scenario
/usr/share/gstreamer-1.0/validate/scenarios/scrub_forward_seeking_full.scenario
/usr/share/gstreamer-1.0/validate/scenarios/seek_backward.scenario
/usr/share/gstreamer-1.0/validate/scenarios/seek_forward.scenario
/usr/share/gstreamer-1.0/validate/scenarios/seek_forward_backward.scenario
/usr/share/gstreamer-1.0/validate/scenarios/seek_with_stop.scenario
/usr/share/gstreamer-1.0/validate/scenarios/setup_sink_props_max_lateness.scenario
/usr/share/gstreamer-1.0/validate/scenarios/simple_seeks.scenario
/usr/share/gstreamer-1.0/validate/scenarios/switch_audio_track.scenario
/usr/share/gstreamer-1.0/validate/scenarios/switch_audio_track_while_paused.scenario
/usr/share/gstreamer-1.0/validate/scenarios/switch_subtitle_track.scenario
/usr/share/gstreamer-1.0/validate/scenarios/switch_subtitle_track_while_paused.scenario
/usr/share/gstreamer-1.0/validate/scenarios/trick_mode_seeks.scenario
/usr/share/licenses/gstreamer-validate/COPYING

Changelog

2018-03-30 - bjorn.lie@gmail.com
- Update to version 1.12.5:
+ Various bugfixes.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-12-11 - zaitor@opensuse.org
- Update to version 1.12.4:
+ No changes, stable version bump only.
2017-12-06 - dimstar@opensuse.org
- Drop pkgconfig(libgee-1.0) BuildRequires: the build system makes
no reference to libgee anymore.
2017-09-18 - zaitor@opensuse.org
- Update to version 1.12.3:
+ launcher: Automatically disable output coloration if not
supported.
+ meson: Fix the way we set the testsuite version.
+ validate:launcher: Use the number of failed test as exit code.
2017-07-14 - zaitor@opensuse.org
- Update to version 1.12.2:
+ Bugs fixed: bgo#764025.
2017-06-21 - zaitor@opensuse.org
- Update to version 1.12.1:
+ validate: Target the 1.12 integration testsuite.
+ Fixup version in meson.build.
2017-05-10 - zaitor@opensuse.org
- Update to version 1.12.0:
+ launcher: Allow using the base launcher as a test manager.
+ tools: Fix dotfile name.
- Changes from version 1.11.91:
+ Bugs fixed: bgo#781213.
- Changes from version 1.11.90:
+ Misc fixes.
2017-02-25 - zaitor@opensuse.org
- Update to version 1.11.2:
+ Bugs fixed: bgo#778279, bgo#777938, bgo#777977.
2017-02-23 - zaitor@opensuse.org
- Update to version 1.11.1:
+ Bugs fixed: bgo#773898.
- Drop pkgconfig(gstreamer-video-1.0) BuildRequires following
upstream changes.

See Also

Package Description
gstreamer-validate-devel-1.12.5-lp150.1.1.x86_64.rpm Validate GStreamer Pipelines -- Developer's files
gstreamermm-devel-1.10.0-lp150.1.3.x86_64.rpm C++ bindings for the GStreamer streaming multimedia library
gstreamermm-doc-1.10.0-lp150.1.3.noarch.rpm C++ bindings for the GStreamer streaming multimedia library
gsynaptics-0.9.16-lp150.1.6.x86_64.rpm A Graphical Front-End for Synaptics Touchpad Configuration
gsynaptics-lang-0.9.16-lp150.1.6.noarch.rpm Translations for package gsynaptics
gtef-2-lang-2.0.1-lp150.2.1.noarch.rpm Translations for package gtef
gtef-devel-2.0.1-lp150.2.1.x86_64.rpm GNOME Text Editor Framework
gtest-1.8.0-lp150.1.4.x86_64.rpm Google C++ Testing Framework - Development files
gtg-0.3.1-lp150.2.2.noarch.rpm Personal Organizer for GNOME
gtg-lang-0.3.1-lp150.2.2.noarch.rpm Translations for package gtg
gthumb-3.6.1-lp150.2.4.x86_64.rpm An Image Viewer and Browser for GNOME
gthumb-devel-3.6.1-lp150.2.4.x86_64.rpm An Image Viewer and Browser for GNOME - Development Files
gthumb-lang-3.6.1-lp150.2.4.noarch.rpm Translations for package gthumb
gti-1.6.1-lp150.1.7.x86_64.rpm ASCII art punishmet for misspelling git
gtick-0.5.4-lp150.1.6.x86_64.rpm A metronome application
Advertisement
Advertisement