gstreamer-plugin-python-1.12.5-lp150.1.1.x86_64.rpm


Advertisement

Description

gstreamer-plugin-python - GStreamer 1.0 plugin for python

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gstreamer-plugin-python
Package version 1.12.5
Package release lp150.1.1
Package architecture x86_64
Package type rpm
Installed size 18.61 KB
Download size 18.18 KB
Official Mirror widehat.opensuse.org
This module contains a wrapper that allows GStreamer applications to be
written in Python.

Alternatives

Package Version Architecture Repository
gstreamer-plugin-python-1.14.4-lp150.51.2.x86_64.rpm 1.14.4 x86_64 Multimedia Libs
gstreamer-plugin-python - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgstreamer-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpython3.6m.so.1.0()(64bit) -

Provides

Name Value
gstreamer-plugin-python = 1.12.5-lp150.1.1
gstreamer-plugin-python(x86-64) = 1.12.5-lp150.1.1
libgstpythonplugin.cpython-36m-x86_64-linux-gnu.so()(64bit) -

Download

Type URL
Binary Package gstreamer-plugin-python-1.12.5-lp150.1.1.x86_64.rpm
Source Package python-gst-1.12.5-lp150.1.1.src.rpm

Install Howto

Install gstreamer-plugin-python rpm package:

# zypper install gstreamer-plugin-python

Files

Path
/usr/lib64/gstreamer-1.0/libgstpythonplugin.cpython-36m-x86_64-linux-gnu.so

Changelog

2018-03-30 - bjorn.lie@gmail.com
- Update to version 1.12.5:
+ Bugs fixed: bgo#793560, bgo#793756.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-12-11 - zaitor@opensuse.org
- Update to version 1.12.4:
+ No changes, stable version bump only.
2017-09-18 - zaitor@opensuse.org
- Update to version 1.12.3:
+ plugin: Always initialize GIL state.
+ Add support for Gst.Bitmask.
+ tests: Stop using deprecated assertion methods.
+ tests: Move all Fundamental types tests in a file.
+ structure: Add a .keys() method and implement __str__.
+ Return a Gst.*Range instead of a python range converting from
GValue to python.
+ structures: Override __new__ to make it more pythonic.
+ overrides: Remove IntRange And Int64Range on Python2.
2017-07-14 - dimstar@opensuse.org
- Convert to single-spec.
2017-07-14 - zaitor@opensuse.org
- Update to version 1.12.2:
+ No changes, stable version bump only.
2017-06-21 - zaitor@opensuse.org
- Update to version 1.12.1:
+ No changes, stable version bump only.
2017-05-10 - zaitor@opensuse.org
- Update to version 1.12.0:
+ No changes, stable version bump only.
- Changes from version 1.11.91:
+ No changes.
- Changes from version 1.11.90:
+ Bugs fixed: bgo#780369.
2017-02-25 - zaitor@opensuse.org
- Update to version 1.11.2:
+ Port old helloworld.py example to GI.
+ python: Add an option to set where to install pygi overrides.
+ meson: bump version and bump meson requirement.
2017-02-23 - zaitor@opensuse.org
- Update to version 1.11.1:
+ Meson build fixes and updates.
+ Play nicely with gst-build uninstalled.
+ common: use https protocol for common submodule.
+ Remove bitrotten and unused gst-python.spec.in file.

See Also

Package Description
gstreamer-plugins-bad-1.12.5-lp150.1.3.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-bad-32bit-1.12.5-lp150.1.3.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-bad-chromaprint-1.12.5-lp150.1.3.x86_64.rpm Chromaprint plugin for GStreamer
gstreamer-plugins-bad-chromaprint-32bit-1.12.5-lp150.1.3.x86_64.rpm Chromaprint plugin for GStreamer
gstreamer-plugins-bad-devel-1.12.5-lp150.1.3.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-bad-doc-1.12.5-lp150.1.3.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-bad-fluidsynth-1.12.5-lp150.1.3.x86_64.rpm Fluidsynth plugin for GStreamer
gstreamer-plugins-bad-fluidsynth-32bit-1.12.5-lp150.1.3.x86_64.rpm Fluidsynth plugin for GStreamer
gstreamer-plugins-bad-lang-1.12.5-lp150.1.3.noarch.rpm Translations for package gstreamer-plugins-bad
gstreamer-plugins-base-1.12.5-lp150.1.1.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-base-32bit-1.12.5-lp150.1.1.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-base-devel-1.12.5-lp150.1.1.x86_64.rpm Include files and librs mandatory for development with gstreamer-plugins-base
gstreamer-plugins-base-devel-32bit-1.12.5-lp150.1.1.x86_64.rpm Include files and librs mandatory for development with gstreamer-plugins-base
gstreamer-plugins-base-doc-1.12.5-lp150.1.1.x86_64.rpm Documentation for gstreamer-plugins-base
gstreamer-plugins-base-lang-1.12.5-lp150.1.1.noarch.rpm Translations for package gstreamer-plugins-base
Advertisement
Advertisement