gstreamer-editing-services-1.12.5-lp150.1.1.x86_64.rpm


Advertisement

Description

gstreamer-editing-services - GStreamer Editing Services

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gstreamer-editing-services
Package version 1.12.5
Package release lp150.1.1
Package architecture x86_64
Package type rpm
Installed size 82.56 KB
Download size 43.17 KB
Official Mirror widehat.opensuse.org
The GStreamer multimedia framework and the accompanying GNonLin set of plugins for non-linear editing offer all the building blocks for:
Decoding and encoding to a wide variety of formats, through all the available GStreamer plugins.
Easily choosing segments of streams and arranging them through time through the GNonLin set of plugins.
But all those building blocks only offer stream-level access, which results in developers who want to write non-linear editors to write a consequent amount of code to get to the level of non-linear editing notions which are closer and more meaningful for the end-user (and therefore the application).
The GStreamer Editing Services (hereafter GES) aims to fill the gap between GStreamer/GNonLin and the application developer by offering a series of classes to simplify the creation of many kind of editing-related applications.

Alternatives

Package Version Architecture Repository
gstreamer-editing-services-1.14.4-lp150.57.3.x86_64.rpm 1.14.4 x86_64 Multimedia Libs
gstreamer-editing-services - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libges-1.0.so.0()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgstpbutils-1.0.so.0()(64bit) -
libgstreamer-1.0.so.0()(64bit) -
libgstvalidate-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -
python(abi) = 2.7
typelib(Gst) -

Provides

Name Value
gstreamer-editing-services = 1.12.5-lp150.1.1
gstreamer-editing-services(x86-64) = 1.12.5-lp150.1.1

Download

Type URL
Binary Package gstreamer-editing-services-1.12.5-lp150.1.1.x86_64.rpm
Source Package gstreamer-editing-services-1.12.5-lp150.1.1.src.rpm

Install Howto

Install gstreamer-editing-services rpm package:

# zypper install gstreamer-editing-services

Files

Path
/usr/bin/ges-launch-1.0
/usr/lib64/gst-validate-launcher/python/launcher/apps/geslaunch.py
/usr/lib64/python2.7/site-packages/gstreamer-editing-services/GES.py
/usr/lib64/python2.7/site-packages/gstreamer-editing-services/GES.pyc
/usr/lib64/python2.7/site-packages/gstreamer-editing-services/GES.pyo
/usr/share/bash-completion/completions/ges-launch-1.0
/usr/share/gstreamer-1.0/validate-scenario/ges-edit-clip-while-paused.scenario
/usr/share/licenses/gstreamer-editing-services/COPYING
/usr/share/man/man1/ges-launch-1.0.1.gz

Changelog

2018-03-30 - bjorn.lie@gmail.com
- Update to version 1.12.5:
+ Bugs fixed: glgo#pitivi#2142, glgo#pitivi#2133, bgo#793874.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-12-11 - zaitor@opensuse.org
- Update to version 1.12.4:
+ Misc fixes.
2017-09-18 - zaitor@opensuse.org
- Update to version 1.12.3:
+ track_element: Always emit "control-binding-removed" signal.
+ Revert "timeline: Return FALSE when commiting an empty
timeline".
+ xml-formatter: Save encoder and muxer advanced settings.
+ Enhance some pad linking issue debug logging.
+ smartmixer: Give a unique name to each compositor instances.
+ pipeline: Allow up to 2 seconds queueing in the playsink video
queue.
+ asset:
- Add a function to stop proxying an asset.
- Clear loading error when reload is requested.
+ nlecomposition: Properly update segment->start/stop on commit.
+ timeline: Remove trackelements initating move from the moving
context.
+ xml-formatter: Serialize encoding profiles in reverse order.
+ pipeline: Make sure tracks are unlinked on NULL->NULL state
changes.
2017-07-14 - zaitor@opensuse.org
- Update to version 1.12.2:
+ Bugs fixed: bgo#784769.
2017-06-21 - zaitor@opensuse.org
- Update to version 1.12.1:
+ No changes, stable version bump only.
2017-05-10 - zaitor@opensuse.org
- Update to version 1.12.0:
+ No changes, stable version bump.
- Changes from version 1.11.91:
+ Automatic common submodule update.
- Changes from version 1.11.90:
+ Bugs fixed: bgo#780854.
2017-02-25 - zaitor@opensuse.org
- Update to version 1.11.2:
+ Bugs fixed: bgo#776805, bgo#778248.
2017-02-23 - zaitor@opensuse.org
- Update to version 1.11.1:
+ Bugs fixed: bgo#774480, bgo#765967, bgo#774641, bgo#775051,
bgo#775295, bgo#776063, bgo#776064.
- Add missing Requires on main package in devel sub package.
- Move manpages to mainpackage where the actual binary is.
- Move Changelog and README to devel package.
2017-02-23 - zaitor@opensuse.org
- Update to version 1.10.4:
+ ges-timeline: Properly calculate absolute diff of two unsigned
integers.
+ ges:
- Add NULL check before dereferencing.
- Check if GstDiscoverer could be created at init time.

See Also

Package Description
gstreamer-editing-services-devel-1.12.5-lp150.1.1.x86_64.rpm GStreamer Editing Services - Development files
gstreamer-lang-1.12.5-lp150.1.1.noarch.rpm Translations for package gstreamer
gstreamer-libnice-0.1.14-lp150.1.11.x86_64.rpm Interactive Connectivity Establishment implementation - GStreamer 1.0
gstreamer-plugin-cluttergst3-3.0.26-lp150.1.2.x86_64.rpm GStreamer Clutter Plug-In
gstreamer-plugin-python-1.12.5-lp150.1.1.x86_64.rpm GStreamer 1.0 plugin for python
gstreamer-plugins-bad-1.12.5-lp150.1.3.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-bad-32bit-1.12.5-lp150.1.3.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-bad-chromaprint-1.12.5-lp150.1.3.x86_64.rpm Chromaprint plugin for GStreamer
gstreamer-plugins-bad-chromaprint-32bit-1.12.5-lp150.1.3.x86_64.rpm Chromaprint plugin for GStreamer
gstreamer-plugins-bad-devel-1.12.5-lp150.1.3.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-bad-doc-1.12.5-lp150.1.3.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
gstreamer-plugins-bad-fluidsynth-1.12.5-lp150.1.3.x86_64.rpm Fluidsynth plugin for GStreamer
gstreamer-plugins-bad-fluidsynth-32bit-1.12.5-lp150.1.3.x86_64.rpm Fluidsynth plugin for GStreamer
gstreamer-plugins-bad-lang-1.12.5-lp150.1.3.noarch.rpm Translations for package gstreamer-plugins-bad
gstreamer-plugins-base-1.12.5-lp150.1.1.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
Advertisement
Advertisement