gsl-2.4-lp150.1.9.x86_64.rpm


Advertisement

Description

gsl - GNU Scientific Library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gsl
Package version 2.4
Package release lp150.1.9
Package architecture x86_64
Package type rpm
Installed size 64.60 KB
Download size 36.67 KB
Official Mirror widehat.opensuse.org
The GNU Scientific Library (GSL) is a collection of routines for
numerical computing. The routines are written from scratch by the GSL
team in ANSI C and present a modern Applications Programming Interface
(API) for C programmers, while allowing wrappers to be written for very
high level languages.

Alternatives

Package Version Architecture Repository
gsl-2.5-lp150.26.1.x86_64.rpm 2.5 x86_64 Science
gsl - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libgsl.so.23()(64bit) -
libgslcblas.so.0()(64bit) -

Provides

Name Value
gsl = 2.4-lp150.1.9
gsl(x86-64) = 2.4-lp150.1.9

Download

Type URL
Binary Package gsl-2.4-lp150.1.9.x86_64.rpm
Source Package gsl-2.4-lp150.1.9.src.rpm

Install Howto

Install gsl rpm package:

# zypper install gsl

Files

Path
/usr/bin/gsl-histogram
/usr/bin/gsl-randist
/usr/share/doc/packages/gsl/COPYING
/usr/share/man/man1/gsl-histogram.1.gz
/usr/share/man/man1/gsl-randist.1.gz

Changelog

2017-06-20 - adam.majer@suse.de
- rstat_test.patch - Fix rstat test on PPC platform
- re-enable multi-job support in unit tests (check make target)
2017-06-19 - adam.majer@suse.de
- Update to new upstream version 2.4:
* add const to declaration of appropriate gsl_rstat routines
* added routines for Hermite polynomials, gsl_sf_hermite_*
* added routines to compute integrals with fixed-point
quadrature, based on IQPACK
* added new nonlinear least squares example for fitting
a Gaussian to data
* deprecated routines:
gsl_sf_coupling_6j_INCORRECT
gsl_sf_coupling_6j_INCORRECT_e
* deprecated routine 'gsl_linalg_hessenberg' (replaced
by gsl_linalg_hessenberg_decomp)
* removed routines which were deprecated in v2.1:
gsl_bspline_deriv_alloc
gsl_bspline_deriv_free
* changed COD expression to Q R Z^T instead of Q R Z to
be consistent with standard texts
* added check for nz == 0 in gsl_spmatrix_get
* permit zero-dimension blocks, vectors, matrics, subvectors,
submatrices, and views of the above
* added routine gsl_linalg_COD_lssolve2 for regularized
least squares problems
- obsoletes patches:
* ppc_test_tolerence.patch
* fix_legendre_test.patch
- unit tests re-enabled
2017-06-14 - adam.majer@suse.de
- Update to test version 2.3.90.
2017-05-18 - adam.majer@suse.de
- Add unit test error logs to build logs when there is a failure
- ppc_test_tolerence.patch: Fix unit tests on PPC64 and PPC64LE
- fix_legendre_test.patch: Ignore part of failing unit test on i586
(boo#1030250)
2017-01-06 - mpluskal@suse.com
- Update to version 2.3:
* bug fix in documentation for gsl_linalg_LU_refine
* added gsl_multifit_linear_tsvd and gsl_multifit_wlinear_tsvd
* improved rstat example program and added documentation for
* added function gsl_multifit_linear_rank
* bug fix in nonlinear least squares when using data weights with
* add 2D subspace method for large systems (multilarge_nlinear)
* bug fix in gsl_ran_beta for small parameters
* bug fix in gsl_complex_tan for negative imaginary arguments
* doc bug fix: value of golden ratio
* fixed scaling issue in 2D subspace nonlinear least squares
method
* optimize dogleg methods to calculate Gauss-Newton point
only when needed
* reverted gsl_linalg_cholesky_decomp to its previous behavior
so it is backward compatible; new cholesky routine is
gsl_linalg_cholesky_decomp1
* updated gsl_linalg_cholesky_invert to use Level-2 BLAS
* added functions gsl_linalg_tri_*_invert for inverting
* fix GSL_EIGEN_SORT_VAL_{ASC,DESC} for nonsymmetric
* added complete orthogonal decomposition routines
* and many more - see ChangeLog for full list
- Drop upstreamed patches:
* gsl-disable-multifit-test.patch
* gsl-rstat-test-powerpc.patch
- Packaging changes:
* use https url's for download
* fetch keyring from savannah
2016-07-29 - adam.majer@suse.de
- Add missing Requires in -devel following package split
2016-07-29 - dmitry_r@opensuse.org
- Move gslcblas library to separate package [boo#991155]

See Also

Package Description
gsl-devel-2.4-lp150.1.9.x86_64.rpm GNU Scientific Library - development files
gsl-doc-2.4-lp150.1.9.x86_64.rpm GNU Scientific Library - development files
gsmartcontrol-1.1.3-lp150.1.10.x86_64.rpm Hard Disk Health Inspection Tool
gsoap-devel-2.8.66-lp150.1.1.x86_64.rpm Development files for the gSOAP toolkit
gsoap-doc-2.8.66-lp150.1.1.noarch.rpm Runtime and development documentation for gsoap
gsound-1.0.2-lp150.1.8.x86_64.rpm A small library for playing system sounds
gsound-devel-1.0.2-lp150.1.8.x86_64.rpm Development files for gsound
gspell-1.6.1-lp150.1.7.x86_64.rpm A spell checker library for gtk+ applications
gspell-devel-1.6.1-lp150.1.7.x86_64.rpm Spell checker library for gtk+ -- Development files
gspell-lang-1.6.1-lp150.1.7.noarch.rpm Translations for package gspell
gssdp-utils-1.0.2-lp150.1.10.x86_64.rpm Utilities for resource discovery and announcement over SSDP
gssproxy-0.7.0-lp150.1.2.x86_64.rpm Daemon for managing gss-api requests
gst123-0.3.5-lp150.1.6.x86_64.rpm GStreamer based Command Line Music Player
gstreamer-1.12.5-lp150.1.1.x86_64.rpm Streaming-Media Framework Runtime
gstreamer-1_0-plugins-buzztrax-0.10.2-lp150.3.1.x86_64.rpm Buzztrax GStreamer plugin
Advertisement
Advertisement