grilo-plugins-0.3.5-lp150.2.1.x86_64.rpm


Advertisement

Description

grilo-plugins - Media discovering and browsing framework -- Media and Metadata Plugins

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name grilo-plugins
Package version 0.3.5
Package release lp150.2.1
Package architecture x86_64
Package type rpm
Installed size 2.30 MB
Download size 977.51 KB
Official Mirror widehat.opensuse.org
Grilo is a framework for browsing and searching media content from
various sources using a single API.
This package provides plugins for accessing content from various media
providers, including podcasts, Apple trailers, Flickr,
Jamendo, Vimeo, YouTube.

Alternatives

Package Version Architecture Repository
grilo-plugins - - -

Requires

Name Value
libarchive.so.13()(64bit) -
libavahi-client.so.3()(64bit) -
libavahi-glib.so.1()(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libdmapsharing-3.0.so.2()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgmime-3.0.so.0()(64bit) -
libgoa-1.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgom-1.0.so.0()(64bit) -
libgrilo-0.3.so.0()(64bit) -
libgrlnet-0.3.so.0()(64bit) -
libgrlpls-0.3.so.0()(64bit) -
libgstreamer-1.0.so.0()(64bit) -
libjson-glib-1.0.so.0()(64bit) -
liblua5.3.so.5()(64bit) -
libmediaart-2.0.so.0()(64bit) -
liboauth.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libsoup-2.4.so.1()(64bit) -
libsqlite3.so.0()(64bit) -
libtotem-plparser-mini.so.18()(64bit) -
libtotem-plparser-mini.so.18(LIBTOTEM_PL_PARSER_MINI_1.0)(64bit) -
libtotem-plparser.so.18()(64bit) -
libtotem-plparser.so.18(LIBTOTEM_PL_PARSER_MINI_1.0)(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
libxml2.so.2(LIBXML2_2.6.0)(64bit) -

Provides

Name Value
grilo-plugins = 0.3.5-lp150.2.1
grilo-plugins(x86-64) = 0.3.5-lp150.2.1
libgrlbookmarks.so()(64bit) -
libgrlchromaprint.so()(64bit) -
libgrldaap.so()(64bit) -
libgrldpap.so()(64bit) -
libgrlfilesystem.so()(64bit) -
libgrlflickr.so()(64bit) -
libgrlfreebox.so()(64bit) -
libgrlgravatar.so()(64bit) -
libgrljamendo.so()(64bit) -
libgrllocalmetadata.so()(64bit) -
libgrlluafactory.so()(64bit) -
libgrlmagnatune.so()(64bit) -
libgrlmetadatastore.so()(64bit) -
libgrlopensubtitles.so()(64bit) -
libgrlopticalmedia.so()(64bit) -
libgrlpodcasts.so()(64bit) -
libgrlraitv.so()(64bit) -
libgrlshoutcast.so()(64bit) -
libgrlthetvdb.so()(64bit) -
libgrltmdb.so()(64bit) -
libgrlvimeo.so()(64bit) -

Download

Type URL
Binary Package grilo-plugins-0.3.5-lp150.2.1.x86_64.rpm
Source Package grilo-plugins-0.3.5-lp150.2.1.src.rpm

Install Howto

Install grilo-plugins rpm package:

# zypper install grilo-plugins

Files

Path
/usr/lib64/grilo-0.3/libgrlbookmarks.so
/usr/lib64/grilo-0.3/libgrlchromaprint.so
/usr/lib64/grilo-0.3/libgrldaap.so
/usr/lib64/grilo-0.3/libgrldpap.so
/usr/lib64/grilo-0.3/libgrlfilesystem.so
/usr/lib64/grilo-0.3/libgrlflickr.so
/usr/lib64/grilo-0.3/libgrlfreebox.so
/usr/lib64/grilo-0.3/libgrlgravatar.so
/usr/lib64/grilo-0.3/libgrljamendo.so
/usr/lib64/grilo-0.3/libgrllocalmetadata.so
/usr/lib64/grilo-0.3/libgrlluafactory.so
/usr/lib64/grilo-0.3/libgrlmagnatune.so
/usr/lib64/grilo-0.3/libgrlmetadatastore.so
/usr/lib64/grilo-0.3/libgrlopensubtitles.so
/usr/lib64/grilo-0.3/libgrlopticalmedia.so
/usr/lib64/grilo-0.3/libgrlpodcasts.so
/usr/lib64/grilo-0.3/libgrlraitv.so
/usr/lib64/grilo-0.3/libgrlshoutcast.so
/usr/lib64/grilo-0.3/libgrlthetvdb.so
/usr/lib64/grilo-0.3/libgrltmdb.so
/usr/lib64/grilo-0.3/libgrlvimeo.so
/usr/share/doc/packages/grilo-plugins/AUTHORS
/usr/share/doc/packages/grilo-plugins/COPYING
/usr/share/doc/packages/grilo-plugins/ChangeLog
/usr/share/doc/packages/grilo-plugins/NEWS
/usr/share/doc/packages/grilo-plugins/README
/usr/share/grilo-plugins/
/usr/share/grilo-plugins/grl-lua-factory/grl-acoustid.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-appletrailers.gresource
/usr/share/grilo-plugins/grl-lua-factory/grl-appletrailers.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-euronews.gresource
/usr/share/grilo-plugins/grl-lua-factory/grl-euronews.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-guardianvideos.gresource
/usr/share/grilo-plugins/grl-lua-factory/grl-guardianvideos.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-itunes-podcast.gresource
/usr/share/grilo-plugins/grl-lua-factory/grl-itunes-podcast.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-lastfm-cover.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-metrolyrics.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-musicbrainz.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-pocket.gresource
/usr/share/grilo-plugins/grl-lua-factory/grl-pocket.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-radiofrance.gresource
/usr/share/grilo-plugins/grl-lua-factory/grl-radiofrance.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-spotify-cover.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-thegamesdb.lua
/usr/share/grilo-plugins/grl-lua-factory/grl-video-title-parsing.lua
/usr/share/help/C/examples/example-tmdb.c
/usr/share/help/C/grilo-plugins/grilo-plugins.xml
/usr/share/help/C/grilo-plugins/legal.xml

Changelog

2017-12-07 - fcrozat@suse.com
- Disable chroma and dmapsharing when building on SLE (not
available there).
2017-09-14 - fezhang@suse.com
- Drop SLE12 / Leap42 build conditionals, enable lua and chroma
unconditionally.
2017-08-25 - zaitor@opensuse.org
- Update to version 0.3.5:
+ build: bgo#778858: meson: Fix library name of optical-media
plugin.
+ dmap plugin: bgo#781278: Fix DMAP plugins not loading.
+ flickr plugin: bgo#707643: flickr: populate GrlMediaImage with
EXIF data.
+ lastfm-cover plugin: bgo#766789: Use HTTPS rather then insecure
HTTP.
+ lua-factory plugin:
- bgo#778857: Building lua-factory breaks with gperf 3.1 if
builddir != srcdir.
- bgo#779444: Fix a few leaks in plugins.
- bgo#781318: Fix lua sources path with Meson.
+ tracker plugin: bgo#786602: [Tracker] Use sparql1.1 "AS ?var"
syntax.
- Drop grilo-plugins-tracker-2.0.patch: Fixed upstream, following
this, drop gnomec-common BuildRequires and autoreconf call, no
longer needed.
- Drop obsolete clean section.
- Replace pkgconfig(gmime-2.6) with pkgconfig(gmime-3.0)
BuildRequires: Needed for podcast support.
- Pass --enable-podcasts to configure, ensure we are building
podcast support.
2017-07-21 - dimstar@opensuse.org
- Add grilo-plugins-tracker-2.0.patch: Also detect tracker 2.0 as
a valid option.
- Add gnomec-common BuildRequires and call autoreconf, as above
patch touches the buildsystem.
2017-02-14 - zaitor@opensuse.org
- Update to version 0.3.4:
+ General: Add support for Meson build.
+ Bugs fixed: bgo#775957, bgo#770959, bgo#777210, bgo#771446,
bgo#771445, bgo#773702, bgo#775957, bgo#778596, bgo#775561,
bgo#773310, bgo#776482, bgo#770806, bgo#774748.
+ Updated translations.
- Add gperf BuildRequires: New "optional" dependency.
2017-01-24 - zaitor@opensuse.org
- Add armv7hl to conditional gstreamer1(element-chromaprint)
BuildRequires: Build for armv7.
2016-09-10 - zaitor@opensuse.org
- Update to version 0.3.3:
+ Bugs fixed: bgo#768520, bgo#768185, bgo#768606, bgo#768093,
bgo#769331, bgo#770806, bgo#769347, bgo#769349, bgo#769356,
bgo#769357, bgo#769373, bgo#767684, bgo#770806.
2016-08-26 - dimstar@opensuse.org
- Conditionally disable LUA Factory on openSUSE < 13.2 (SLE and
Leap 42.x). LUA 5.3 is not available and as a consequence we
can't ship LUA Factory plugins.
- Conditionally disabled chromaprint on openSUSE < 13.2 (SLE and
Leap 42.x). GStreamer/chroma support is not available.
2016-06-17 - zaitor@opensuse.org
- Update to version 0.3.2:
+ Bugs fixed: bgo#732879, bgo#732879, bgo#764486, bgo#764077,
bgo#764078, bgo#764814, bgo#764816, bgo#766678, bgo#767631,
bgo#764078, bgo#764814, bgo#764600, bgo#766678, bgo#764486,
bgo#761624, bgo#761869, bgo#766587.
- Add pkgconfig(gstreamer-1.0) and
pkgconfig(gstreamer-plugins-bad-1.0) BuildRequires: New
dependencies needed for the new chromaprint support. Also pass
- -enable-chromaprint to configure to ensure the support is built.
- Following the above add gstreamer1(element-chromaprint)()(64bit)/
gstreamer1(element-chromaprint) BuildRequires. This should not be
needed, and future investigation if the bug is in grilo-plugins
or gstreamer-plugins-bad is needed.
- Drop grilo-plugins-Fix-gcc6-build.patch: Fixed upstream.
2016-06-16 - zaitor@opensuse.org
- Add grilo-plugins-Fix-gcc6-build.patch: Fix build with GCC 6,
patch from upstream.

See Also

Package Description
grilo-plugins-lang-0.3.5-lp150.2.1.noarch.rpm Translations for package grilo-plugins
grilo-tools-0.3.4-lp150.1.10.x86_64.rpm Framework for browsing and searching media content -- Tools
groff-1.22.3-lp150.3.1.x86_64.rpm GNU troff Document Formatting System
groff-doc-1.22.3-lp150.3.14.noarch.rpm HTML documentation and examples for groff
groff-full-1.22.3-lp150.3.14.x86_64.rpm GNU troff Document Formatting System
gromacs-2018.1-lp150.1.10.x86_64.rpm Molecular Dynamics Package
gromacs-bash-2018.1-lp150.1.10.noarch.rpm Bash completion for Gromacs
gromacs-devel-2018.1-lp150.1.10.x86_64.rpm Molecular dynamics package
gromacs-doc-2018.1-lp150.1.10.noarch.rpm Documentation for Gromacs
gromacs-openmpi-2018.1-lp150.1.10.x86_64.rpm Molecular dynamics package
gromit-20041213-lp150.1.3.x86_64.rpm Tool to make annotations on the screen
growpart-0.30-lp150.3.1.noarch.rpm Grow a partition
growpart-rootgrow-1.0.0-lp150.3.1.noarch.rpm Resize root partition
grpc-devel-1.10.0-lp150.1.1.x86_64.rpm Development files for grpc, a HTTP/2 Remote Procedure Call implementation
grsync-1.2.6-lp150.1.5.x86_64.rpm GUI for rsync
Advertisement
Advertisement